Vous ne pouvez pas accéder à Internet via un serveur proxy lorsque vous utilisez une version 32 bits d'Internet Explorer sur un ordinateur qui exécute une version 64 bits de Windows

Traductions disponibles Traductions disponibles
Numéro d'article: 952031 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Envisagez le scénario suivant. Vous exécutez une version 32 bits de Microsoft Internet Explorer sur un ordinateur qui exécute une version 64 bits d'un système d'exploitation Microsoft Windows. Vous activer les paramètres de stratégie de groupe Make par machine du paramètres proxy (plutôt que par utilisateur). Dans ce scénario, vous ne peut pas accéder à Internet via un serveur proxy.

Cause

Ce problème se produit parce que les paramètres de stratégie ne sont pas écrits dans la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Internet Settings
Cette sous-clé est lu par la version 32 bits d'Internet Explorer. Par conséquent, Internet Explorer et d'autres navigateurs 32 bits ne sont pas configurés pour utiliser les paramètres de stratégie correcte.

les programmes 32 bits qui s'exécutent sur une version 64 bits de Windows fonctionnent en mode WOW64. Ces programmes accéder aux clés de Registre et les valeurs qui sont stockés dans la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\Software\WOW6432node

Contournement

Important Cette section, la méthode ou la tâche contient vous explique comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, assurez-vous que vous procédez comme suit. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre en cas de problème. Pour plus d'informations sur la façon de sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
322756Comment faire pour sauvegarder et restaurer le Registre de Windows

Pour contourner ce problème, procédez comme suit :
  1. Créer un script qui lit le contenu à partir de la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  2. Dans le même script, ajoutez le code qui écrit le contenu de la sous-clé de Registre dans l'étape 1 dans la sous-clé de Registre suivante :
    HKLM\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Internet Settings
  3. Exécutez le script.
  4. Assurez-vous que vous accordez à tous les utilisateurs (tout le monde) l'autorisation de définir une valeur pour la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\Connections

Propriétés

Numéro d'article: 952031 - Dernière mise à jour: vendredi 12 mars 2010 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Vista Édition Intégrale 64 bits
  • Windows Vista Édition Familiale Premium 64 bits
  • Windows Vista Entreprise 64 bits
  • Windows Vista Édition Familiale Basique 64 bits
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Entreprise
  • Windows 7 Édition Familiale Premium
  • Windows 7 Professionnel
  • Windows 7 Édition Integrale
Mots-clés : 
kbmt kbexpertiseinter kbtshoot KB952031 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 952031
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com