È Impossibile accedere a Internet tramite un server proxy quando si utilizza una versione a 32 bit di Internet Explorer in un computer che esegue una versione a 64 bit di Windows

Traduzione articoli Traduzione articoli
Identificativo articolo: 952031 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Si consideri il seguente scenario. Si esegue una versione a 32 bit di Microsoft Internet Explorer in un computer che esegue una versione a 64 bit di un sistema operativo Microsoft Windows. Consente di verificare le impostazioni proxy per computer, anziché per singolo utente, impostazioni dei criteri di gruppo. In questo scenario, è Impossibile accedere a Internet tramite un server proxy.

Cause

Questo problema si verifica perché le impostazioni dei criteri non vengono scritti sulla seguente sottochiave del Registro di sistema:
HKEY_LOCAL_MACHINE\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Internet Settings
Questa sottochiave è di lettura dalla versione a 32 bit di Internet Explorer. Di conseguenza, Internet Explorer e altri browser a 32 bit non sono configurati per utilizzare le impostazioni corrette.

programmi che vengono eseguite su una versione a 64 bit di Windows a 32 bit funzionano in modalità WOW64. Questi programmi di accesso delle chiavi del Registro di sistema e i valori memorizzati nella seguente sottochiave del Registro di sistema:
HKEY_LOCAL_MACHINE\Software\WOW6432node

Workaround

Importante Questa sezione, metodo o attività contiene illustrato come modificare il Registro di sistema. Tuttavia, può causare seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi di seguire attentamente questi passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Quindi, è possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756Come eseguire il backup e ripristino del Registro di sistema in Windows

Per aggirare questo problema, attenersi alla seguente procedura:
  1. Creare uno script che legge il contenuto seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  2. Nello stesso script, aggiungere il codice che scrive il contenuto della sottochiave del Registro di sistema nel passaggio 1 per la seguente sottochiave del Registro di sistema:
    HKLM\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Internet Settings
  3. Eseguire lo script.
  4. Assicurarsi di concedere agli utenti tutti (everyone) l'autorizzazione di Imposta valore per la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\Connections

Proprietà

Identificativo articolo: 952031 - Ultima modifica: venerdì 12 marzo 2010 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
Chiavi: 
kbmt kbexpertiseinter kbtshoot KB952031 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 952031
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com