Article ID: 952089 - Last Review: October 8, 2011 - Revision: 2.0

The Provisioning Engine COM+ component stops responding in Hosted Messaging and Collaboration 4.0

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SYMPTOMS

Consider the following scenario. In Microsoft Hosted Messaging and Collaboration 4.0, you submit a request to a Microsoft Provisioning Server (MPS) engine that is stopped. When you restart the server, the MPS COM+ component stops responding. In this scenario, errors may occur when requests are submitted. The server may have to be restarted so that the MPS engine can work.

CAUSE

This problem occurs because of an interoperability issue between the COM+ subsystem and the OLEAUT32.dll file when the MPS engine COM+ component starts.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released software update.

Steps to apply the hotfix

Note You must perform the steps in this section on every MPS engine server in the environment. To apply the hotfix, follow these steps:
  1. Log on to the MPS engine server as a member of the Domain Admins group.
  2. From the Provisioning Server start menu, open the Provisioning Manager MMC Snap.
  3. Expand the Provisioning Engines node.
  4. Right-click the provisioning engine that you logged on to in step 1, and then select Deactivate.
  5. From the Administrative Tools menu, open the Component Management MMC snap-in.
  6. Expand the Computers Node until you reach the My Computer node.
  7. Select the COM+ Applications node.
  8. On the right side, right-click Provisioning Engine, and then click Shutdown.
  9. In the folder where you downloaded the KB952089.msi file, double-click the KB952089.msi file, and then follow the instructions that appear on the screen to install the hotfix.
  10. When the installation is complete, return to the Provisioning Manager MMC snap-in, right-click the engine that you updated, and then select Activate.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Mapsproccntl.dll13.3.609.11721,40808-May-200811:42x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903  (http://support.microsoft.com/kb/817903/ ) New naming schema for Exchange Server software update packages

APPLIES TO
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Keywords: 
kbautohotfix kbexpertiseinter kbqfe KB952089