Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

O suporte para o Windows Vista Service Pack 1 (SP1) termina a 12 de julho de 2011. Para continuar a receber atualizações de segurança para o Windows, certifique-se de que está a executar o Windows Vista com o Service Pack 2 (SP2). Para obter mais informações, consulte esta página web da Microsoft: O suporte está a terminar para algumas versões do Windows.

Sintomas

Considere o seguinte cenário.

  • Está a executar um Windows XP Service Pack 3 (SP3), Windows Vista Service Pack 1 (SP1) ou um computador baseado no Windows 7

  • Utiliza um nome de utilizador que inclui um caracteres de caracteres de duplo byte (DBCS).

Quando tenta instalar uma aplicação que utiliza o Pacote Redistribuable Microsoft Visual C++ 2005, recebe a seguinte mensagem de erro:

Erro de sintaxe de opção de linha de comando. Tipo de comando/? Por ajuda.

Causa

Este problema ocorre porque a ferramenta win32 Cabinet Self-Extractor não consegue manusear os caracteres DBCS no nome de utilizador.

Resolução

Para que resolvamos este problema para si, vá à secção"Fixe-o para mim". Se preferir resolver este problema sozinho, vá para a secção"Deixe-me consertá-lo eu mesmo".

Corrigir automaticamente



Para corrigir este problema automaticamente, clique no botão Fix it ou link. Em seguida, clique em Executar na caixa de diálogo 'Descarregar ficheiro' e siga os passos no assistente 'Corrigir-o'.




Notas

  • A solução Fix it não funcionará se a sua conta não for uma conta de administrador.

  • Este assistente pode estar apenas em inglês. No entanto, a correção automática também funciona para versões do Windows noutros idiomas.

  • Se não estiver no computador que tem o problema, guarde a solução Fix-lo para uma pen ou um CD e, em seguida, execute-a no computador que tem o problema.


Então, vá para a secção"Isto resolveu o problema?".



Deixar-me corrigir o problema

Para resolver este problema, siga estes passos:

  1. Clique em Iniciar Botão de arranque , clique no computadorà direita e, em seguida, clique em Propriedades.

  2. Na área de definições de nome, domínio e grupo de trabalho do Computador, clique em Alterar as definições.

     Permissão de Controlo de Conta de Utilizador  Se lhe for solicitada uma palavra-passe do administrador ou para confirmação, escreva a sua palavra-passe ou clique em Continuar.

  3. Clique em Alterar Definições e, em seguida, seti o separador Avançado. Clique no botão de variáveis Ambiente

  4. Na área das variáveis do Utilizador, clique em TEMP e, em seguida, clique em Editar.

  5. Na caixa de valor variável, tipo C:\Temp e, em seguida, clique em OK duas vezes.

  6. Clique em Aplicare, em seguida, clique em OK.

  7. Siga também os passos 4 a 6 para a variável ambiente TMP.

  8. Confirme que a pasta C:\Temp existe, se não criar uma.

  9. Reinicie o computador.

  10. Tente instalar novamente a aplicação.


O problema foi corrigido?

  • Verifique se o problema foi corrigido. Se o problema estiver corrigido, terminou esta secção. Se o problema não estiver corrigido, pode contactar o suporte.

  • Agradecemos o seu feedback. Para fornecer feedback ou para relatar quaisquer problemas com esta solução, por favor deixe um comentário sobre o blog "Fix it for me" ou envie-nos um e-mail.

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×