Mensagem de erro ao tentar instalar um aplicativo em um Windows Vista SP1 ou o computador com Windows 7: "Erro de sintaxe de opção de linha de comando".

Traduções deste artigo Traduções deste artigo
ID do artigo: 952211 - Exibir os produtos aos quais esse artigo se aplica.
Suporte para Windows Vista Service Pack 1 (SP1) termina em 12 de julho de 2011. Para continuar recebendo atualizações de segurança para o Windows, verifique se que você está executando o Windows Vista com Service Pack 2 (SP2). Para obter mais informações, consulte esta página da Web da Microsoft: Suporte está sendo encerrado para algumas versões do Windows.
Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário.
  • Você está executando o Windows XP Service Pack 3 (SP3), Windows Vista Service Pack 1 (SP1) ou um computador com Windows 7 com base
  • Use um nome de usuário que inclui um caractere DBCS (conjunto) de caracteres de byte duplo.
Quando você tenta instalar um aplicativo que usa o pacote Microsoft Visual C++ 2005 Redistributable, você recebe a seguinte mensagem de erro:
Erro de sintaxe de opção de linha de comando. Digite o comando /? Para obter ajuda.

Causa

Esse problema ocorre porque a ferramenta de auto-extrator de arquivo de gabinete Win32 não dá suporte os caracteres DBCS no nome do usuário.

Resolução

Para que possamos corrigir esse problema para você, vá para a "Corrigir para mim"a seção. Se você preferir corrigir o problema sozinho, vá para a "Deixe-me a corrigir sozinho"a seção.

Corrigir para mim



Para corrigir esse problema automaticamente, clique no corrigi-lo botão ou link. Em seguida, clique em executar na caixa de diálogo Download de arquivo caixa e siga as etapas no assistente Fix it .


Corrigir o problema
Microsoft Fix it 50794


Anotações
  • A correção-solução não funcionará se a sua conta não é uma conta de administrador.
  • Este assistente pode estar apenas em inglês. No entanto, a correção automática também funciona para versões do Windows em outros idiomas.
  • Se você não estiver no computador que apresentou o problema, salve a correção-solução para uma unidade flash ou em um CD e execute-o no computador que apresentou o problema.

Em seguida, vá para a "Isso corrigiu o problema?"a seção.



Deixe-me a corrigir sozinho

Para resolver esse problema, execute as seguintes etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    Botão Iniciar
    , clique em computadore, em seguida, clique em Propriedades.
  2. Na área nome do computador, domínio e configurações de grupo de trabalho , clique em Alterar configurações.

    Recolher esta imagemExpandir esta imagem
     Permissão Controle de conta de usuário
    Se você for solicitado para uma senha de administrador ou uma confirmação, digite a senha ou clique em continuar.
  3. Clique em Alterar configurações e, em seguida, selecione a guia Avançado clique no botão variáveis de ambiente
  4. Na área variáveis de usuário , clique em TEMPe, em seguida, clique em Editar.
  5. Na caixa Variable value , digite C:\Temp.e, em seguida, clique em OK duas vezes.
  6. Clique em Aplicare, em seguida, clique em OK.
  7. Siga as etapas de 4 a 6 para a variável de ambiente de TMP .
  8. Confirmar essa pasta C:\Temp existe, se não criá-lo.
  9. Reinicie o computador.
  10. Tente instalar o aplicativo novamente.

Isso corrigiu o problema?

  • Verifique se o problema está corrigido. Se o problema tiver sido corrigido, você terá concluído esta seção. Se o problema não for corrigido, você poderá Contate o suporte.
  • Aguardamos seus comentários. Para fornecer comentários ou relatar quaisquer problemas com essa solução, deixe um comentário sobre o "Corrigir para mim"blog ou envie-em um e-mail.

Propriedades

ID do artigo: 952211 - Última revisão: segunda-feira, 11 de novembro de 2013 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Windows 7 Home Premium
  • Windows 7 Home Premium E
  • Windows 7 Home Premium N
  • Windows 7 Enterprise
  • Windows 7 Enterprise E
  • Windows 7 Enterprise N
  • Windows 7 Home Basic
  • Windows 7 Professional
  • Windows 7 Professional E
  • Windows 7 Professional N
  • Windows 7 Starter
  • Windows 7 Starter E
  • Windows 7 Starter N
  • Windows 7 Ultimate
  • Windows 7 Ultimate E
  • Windows 7 Ultimate N
  • Service Pack 1 para Windows Vista
  • Service Pack 3 para Windows XP
Palavras-chave: 
kberrmsg kb3rdpartyhardware kbexpertiseinter kbtshoot kbprb kbfixme kbmsifixme kbmt KB952211 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.
Clique aqui para ver a versão em Inglês deste artigo: 952211

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com