Article ID: 952250 - Last Review: October 7, 2008 - Revision: 1.1

You encounter a long delay for each mailbox when you run the "Move-Mailbox" or "Set-Mailbox" command on an Exchange Server 2007 computer

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SYMPTOMS

Consider the following scenario:
  • You perform an Active Directory authoritative restore on a domain controller in a large Active Directory environment.
  • You run the Move-Mailbox or Set-Mailbox command in the Exchange management shell on a computer that is running Microsoft Exchange Server 2007 Service Pack 1 (SP1).
In this scenario, you encounter a long delay for each mailbox in the Active Directory environment.

CAUSE

This issue occurs because the Recipient Update Service (RUS) in Exchange Server 2007 checks the up-to-date data for all replication-related domain controllers. In a large Active Directory environment, there are many replication-related domain controllers because of the authoritative restore process. Therefore, the RUS in Exchange Server 2007 spends several minutes unnecessarily checking the up-to-date data for all replication-related domain controllers.

RESOLUTION

To resolve this problem, install Update Rollup 4 for Exchange Server 2007 Service Pack 1 (SP1) on the Exchange server. For more information about Update Rollup 4 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic:
Description of Update Rollup 4 for Exchange Server 2007 Service Pack 1 (http://go.microsoft.com/fwlink/?LinkId=152556)
For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:
How to Obtain the Latest Service Pack or Update Rollup for Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=152570)

MORE INFORMATION

For more information about the Active Directory authoritative restore process, visit the following Web site:
http://technet2.microsoft.com/WindowsServer/en/Library/690730c7-83ce-4475-b9b4-46f76c9c7c901033.mspx?mfr=true (http://technet2.microsoft.com/WindowsServer/en/Library/690730c7-83ce-4475-b9b4-46f76c9c7c901033.mspx?mfr=true)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Service Pack 1
Keywords: 
kbhotfixrollup kbfix kbexpertiseadvanced kbqfe KB952250
 

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