Mensaje de error cuando hace clic en el botón de lista de actualizar en una cuadrícula de una vista en Microsoft Dynamics CRM 4.0: "Ordenar por columnas no coinciden con los de paginación"

Seleccione idioma Seleccione idioma
Id. de artículo: 952311 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Al hacer clic en el botón actualizar la lista en una cuadrícula de una vista que contiene un atributo personalizado de lista de expedición en Microsoft Dynamics CRM 4.0, recibirá el siguiente mensaje de error:
Error de plataforma
=====================================
Número de error: 0x80041129
Error: Ordenar por columnas no coinciden con los de la cookie de paginación.
Detalles del error: Ordenar por columnas no coinciden con los de la cookie de paginación.
Archivo de origen: No disponible
Número de línea: No disponible
Dirección URL de solicitud: http:// URL
Pila de información de seguimiento: [CrmException: Ordenar por columnas no coinciden con los de la cookie de paginación.] en Microsoft.Crm.BusinessEntities.PagingHelper._AddRepeatFiltering(OrderExpressionCollection orderCollection, FilterExpression filterExpression, Hashtable orderNameValuePairs) en Microsoft.Crm.BusinessEntities.PagingHelper.AddPagingFilters(EntityExpression entityExpression) en Microsoft.Crm.BusinessEntities.QueryProcessObject.RetrieveDataQueryAsResultXml(EntityExpression entityExpression, QueryStrategyType strategyType, ExecutionContext context) en Microsoft.Crm.BusinessEntities.QueryProcessObject.RetrieveQueryAsResultXml(EntityExpression entityExpression, QueryStrategyType strategyType, ExecutionContext context) en Microsoft.Crm.ObjectModel.SavedQueryService.Execute (String fetchXml, ExecutionContext contexto)
Error de usuario
=====================================
"Ocurrió un error. Inténtelo de nuevo esta acción. Si el problema continúa, compruebe a la comunidad de Microsoft Dynamics CRM para soluciones o póngase en contacto con el Administrador de la organización Microsoft Dynamics CRM. Póngase en contacto por último, con Microsoft Support."

Causa

Este problema se produce porque Microsoft Dynamics CRM compara un nombre de atributo incorrecto cuando Microsoft Dynamics CRM compara la cookie de paginación de la cuadrícula de expresión de orden de la consulta. Por ejemplo, si existe un atributo de lista de expedición que se denomina new_testpl , Microsoft Dynamics CRM compara el atributo new_testplname en la cookie de paginación y el atributo new_testpl en la expresión de consulta. Porque los nombres de atributo son diferentes, se produce una excepción.

Solución

Este problema se corrigió en la actualización acumulativa de rollup más reciente para Microsoft Dynamics CRM 4.0. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
949256Revisiones y actualizaciones de Microsoft Dynamics CRM 4.0

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
887283Los estándares de nomenclatura de paquete de actualización y revisiones de software de Microsoft Business Solutions CRM

Propiedades

Id. de artículo: 952311 - Última revisión: jueves, 12 de febrero de 2009 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Dynamics CRM 4.0
Palabras clave: 
kbmt kberrmsg kbexpertiseinter kbfix kbautohotfix kbmbsmigrate kbqfe kbhotfixserver KB952311 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 952311

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com