SQL Server 2005 crashes every two to three days when jobs communicate with the DB2 host by using a stand-alone data provider in Host Integration Server 2006

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Article ID: 952671 - View products that this article applies to.
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SYMPTOMS

When you use the SQL Scheduler to schedule jobs that are submitted to communicate with the DB2 host, Microsoft SQL Server 2005 crashes every two to three days. This problem occurs if the jobs are submitted to communicate with the DB2 host by using a stand-alone data provider in Microsoft Host Integration Server 2006.

CAUSE

This problem occurs because of an internal logic problem in the stand-alone data provider.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Host Integration Server 2006. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
979497 How to obtain the latest Host Integration Server 2006 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Db2oledb.dll7.0.3062.0521,03221-Nov-200818:57x86
Microsoft.hostintegration.dataaccesslibrary.dll7.0.3062.02,554,76821-Nov-200818:55x86
Microsoft.hostintegration.dataaccesstool.exe7.0.3062.0617,36021-Nov-200818:55x86
Mseidrda.dll7.0.3062.0803,65621-Nov-200818:57x86
Snanls.dll7.0.3062.0105,28821-Nov-200818:57x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 952671 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
Keywords: 
kbautohotfix kbexpertiseinter kbsurveynew kbbug kbfix kbqfe KB952671

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