Message d'erreur lorsque vous installez Windows XP Service Pack 3 RC1 ou RC2 sur un ordinateur Windows XP Service Pack 2: « STOP : 0xc0000139 {point d'entrée introuvable} »

Traductions disponibles Traductions disponibles
Numéro d'article: 952829 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Lorsque vous installez Windows XP Service Pack 3 (SP3), version finale candidate 1 (RC1) ou version finale candidate 2 (RC2) sur un Service Pack 2 (SP2) Windows XP, ordinateur, vous pouvez recevoir le message d'erreur point suivant :
Arrêt : 0xc0000139 {entrée point introuvable} le GdiGetBitmapBitsize procédure entrée point est introuvable dans la bibliothèque de liens dynamiques GDI32.dll.

Cause

Ce problème se produit si vous installez la mise à jour de sécurité 948590 (bulletin de sécurité MS08-021) avant d'installer Windows XP Service Pack 3 RC2 ou RC1. Vous pouvez rencontrer cette erreur car la version du fichier Gdi32.dll qui existe déjà sur l'ordinateur est plus récente que la version du fichier Gdi32.dll qui est inclus dans Windows XP Service Pack 3 RC1 ou RC2. En outre, la version existante du fichier Gdi32.dll est incompatible avec la version du fichier Gdi32.dll dans Windows XP Service Pack 3 RC1 ou RC2.

Pour plus d'informations sur le bulletin de sécurité MS08-021, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
948590 MS08-021 : Une vulnérabilité dans GDI peut permettre l'exécution de code à distance

Résolution

Pour résoudre ce problème, utilisez le CD-ROM Windows XP ou la disquette de démarrage pour redémarrer l'ordinateur. Ensuite, utilisez la console de récupération pour remplacer la version du fichier Gdi32.dll incompatible. Pour exécuter la console de récupération, procédez comme suit :
  1. Insérez la disquette de démarrage Windows XP dans le lecteur de disquette. Ou, insérez le CD-ROM Windows XP dans le lecteur de CD-ROM. Ensuite, redémarrez l'ordinateur.

    note Si vous êtes invité, cliquez pour sélectionner les options requises pour démarrer l'ordinateur à partir du lecteur de CD.
  2. Lorsque l'écran « Bienvenue » s'affiche, appuyez sur R pour démarrer la console de récupération.
  3. Si vous possédez un ordinateur à double démarrage ou un ordinateur à démarrage multiple, sélectionnez l'installation à laquelle vous souhaitez accéder à partir de la console de récupération.
  4. Lorsque vous êtes invité, tapez le mot de passe administrateur.

    note Appuyez sur ENTRÉE si le mot de passe administrateur est vide.
  5. À l'invite de commandes de la console de récupération, tapez les commandes suivantes. Appuyez sur ENTRÉE après chaque commande.
    ren %windir%\system32\gdi32.dll %windir%\system32\gdi32.dll.old
    copie %windir%\servicepackfiles\i386\gdi32.dll %windir%\system32\gdi32.dll
    note Ces commandes sauvegarder la version actuelle du fichier Gdi32.dll et remplacer le fichier Gdi32.dll en utilisant la version correcte.
  6. Pour quitter la console de récupération et redémarrer l'ordinateur, tapez exit à l'invite de la console de récupération et puis appuyez sur ENTRÉE.

    note Pour éviter ce problème, nous vous recommandons d'installer la version la plus récente de Windows XP SP3. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
    322389 Comment obtenir le dernier pack de service Windows XP

Propriétés

Numéro d'article: 952829 - Dernière mise à jour: lundi 14 juillet 2008 - Version: 1.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Service Pack 3
Mots-clés : 
kbmt kbprb kbexpertiseadvanced kbtshoot KB952829 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 952829
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com