Article ID: 952842 - Last Review: July 8, 2009 - Revision: 3.0

The installation of the Exchange Server 2007 Hub Transport role is unsuccessful on a Windows Server 2008-based computer

On This Page

Expand all | Collapse all

Problem description

When you try to install the Microsoft Exchange Server 2007 Hub Transport role on a Windows Server 2008-based computer, the installation is unsuccessful. Additionally, the following event error is logged in the Application log:

Event Source: MSExchangeSetup
Event ID: 1002
Task Category: Microsoft Exchange Setup
Level: Error
Keywords: Classic
Description:
Exchange Server component Hub Transport Role failed.
Error:
Error: An error occurred. error code was 2147504141 message was The property cannot be found in the cache.."

Note This problem occurs when you disable the Microsoft Internet Protocol version 6 (IPv6) settings in Local Area Connection on the Windows Server 2008-based computer.

CAUSE

This problem occurs because IPv6 is not disabled on tunnel interfaces if you disable IPv6 in Local Area Connection.

By default, IPv6 is enabled in Windows Server 2008. If you want to disable IPv6 for any reasons, you have to use Registry Editor to completely disable IPv6.

RESOLUTION

To resolve this problem, use one of the following methods:
  • Enable IPv6 in Local Area Connection on the Windows Server 2008-based computer.
  • Use Registry Editor to completely disable IPv6 on a Windows Server 2008-based computer. To have us do this for you, go to the "Fix it for me" section. If you would rather do this yourself, go to the "Let me fix it myself" section.

    Fix it for me

    To completely disable IPv6 on a Windows Server 2008-based computer automatically, click the Fix this problem link. Then, click Run in the File Download dialog box and follow the steps in this wizard.

    Fix this problem
    Microsoft Fix it 50045


    Note this wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

    Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem.

    Now go to the "Did this fix the problem?" section.

    Let me fix it myself

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
    322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

    To completely disable IPv6 on a Windows Server 2008-based computer yourself, follow these steps:
    1. Open Registry Editor.
    2. Locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
    3. In the details pane, click New, and then click DWORD (32-bit) Value.
    4. Type DisabledComponents, and then press ENTER.
    5. Double-click DisabledComponents, and then type 0xffffffff in Hexadecimal or 4294967295 in Decimal.

      Note The 0xffffffff value or the 4294967295 value disables all IPv6 components except for the IPv6 loopback interface.

Did this fix the problem?

Check whether the problem is fixed. If it is fixed, you are finished with this article. If it is not fixed, you can contact support.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Exchange setup logs

=================
[4/2/2008 9:28:39 AM] [2] Entering CBaseExchangeProtocolAtom::ScFindDefaultInstanceIdOrCreateNew
[4/2/2008 9:28:39 AM] [2] Searching for default instance
[4/2/2008 9:28:39 AM] [2] No default instance found, generating new instance id
[4/2/2008 9:28:40 AM] [2] Failed to generate new instance id
[4/2/2008 9:28:40 AM] [2]  CBaseExchangeProtocolAtom::ScFindDefaultInstanceIdOrCreateNew (f:\08.01.0085\sources\dev\admin\src\udog\setupbase\basecomp\baseprotocolatom.cxx:335)
           Error code 0X8000500D (20493): The property cannot be found in the cache.
[4/2/2008 9:28:40 AM] [2] Leaving CBaseExchangeProtocolAtom::ScFindDefaultInstanceIdOrCreateNew
[4/2/2008 9:28:40 AM] [2]  CAtomSMTP::ScAddDSObjects (f:\08.01.0085\sources\dev\admin\src\udog\exsetdata\components\server\a_smtp.cxx:256)
           Error code 0X8000500D (20493): The property cannot be found in the cache.
[4/2/2008 9:28:40 AM] [2]  CBaseAtom::ScAdd (f:\08.01.0085\sources\dev\admin\src\udog\setupbase\basecomp\baseatom.cxx:639)
           Error code 0X8000500D (20493): The property cannot be found in the cache.
[4/2/2008 9:28:40 AM] [2] Leaving CBaseAtom(SMTP Service)::ScAdd
[4/2/2008 9:28:40 AM] [2] Service = '' CBaseServiceAtom::ScAdd (f:\08.01.0085\sources\dev\admin\src\udog\setupbase\basecomp\basesvcatom.cxx:203)
           Error code 0X8000500D (20493): The property cannot be found in the cache.
[4/2/2008 9:28:40 AM] [2] Leaving CBaseServiceAtom(SMTP Service)::ScAdd
[4/2/2008 9:28:40 AM] [2] mode = 'Install' (61953) CBaseAtom::ScSetup (f:\08.01.0085\sources\dev\admin\src\udog\setupbase\basecomp\baseatom.cxx:535)
           Error code 0X8000500D (20493): The property cannot be found in the cache.
[4/2/2008 9:28:40 AM] [2]  ScSetupAtom (f:\08.01.0085\sources\dev\admin\src\udog\exsetdata\exsetds.cxx:889)
           Error code 0X8000500D (20493): The property cannot be found in the cache.
[4/2/2008 9:28:40 AM] [2] Leaving ScSetupAtom
[4/2/2008 9:28:40 AM] [2] [ERROR] An error occurred. error code was 2147504141 message was The property cannot be found in the cache.."
[4/2/2008 9:28:40 AM] [1] The following 1 error(s) occurred during task execution:
[4/2/2008 9:28:40 AM] [1] 0.  ErrorRecord: An error occurred. error code was 2147504141 message was The property cannot be found in the cache.."
[4/2/2008 9:28:40 AM] [1] 0.  ErrorRecord: Microsoft.Exchange.Management.Deployment.ExsetdataException: An error occurred. error code was 2147504141 message was The property cannot be found in the cache.."
[4/2/2008 9:28:40 AM] [1] [ERROR] An error occurred. error code was 2147504141 message was The property cannot be found in the cache.."
[4/2/2008 9:28:40 AM] [1] Setup is halting task execution because of one or more errors in a critical task.
[4/2/2008 9:28:40 AM] [1] Finished executing component tasks.
[4/2/2008 9:28:40 AM] [1] Ending processing.

REFERENCES

For more information about how to install Exchange Server 2007 SP1 prerequisites on Windows Server 2008 or on Windows Vista, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/bb691354(EXCHG.80).aspx (http://technet.microsoft.com/en-us/library/bb691354(EXCHG.80).aspx)

APPLIES TO
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbmsifixme kbfixme kbtshoot kbexpertiseinter kbprb KB952842
 

Article Translations

 

Related Support Centers