Article ID: 952855 - Last Review: February 12, 2009 - Revision: 2.0

A user who has the Administrative mode client access license can access custom entities unexpectedly in Microsoft Dynamics CRM 4.0

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SYMPTOMS

A user has the Administrative mode client access license (CAL) in Microsoft Dynamics CRM 4.0. When you log on to Microsoft Dynamics CRM as this user, you can unexpectedly access custom entities. However, you should be unable to view the custom entities.

CAUSE

This problem occurs because the Administrative mode does not examine user permissions for custom entities. The Administrative mode only examines the user permissions for default entities.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256  (http://support.microsoft.com/kb/949256/ ) Microsoft Dynamics CRM 4.0 updates and hotfixes

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates
For more information about Microsoft Business Solutions CRM software hotfix and update package terminology, click the following article number to view the article in the Microsoft Knowledge Base:
887283  (http://support.microsoft.com/kb/887283/ ) Microsoft Business Solutions CRM software hotfix and update package naming standards

APPLIES TO
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbmbsadministration kbfix kbmbsmigrate kbqfe kbhotfixserver kbautohotfix kbexpertiseinter KB952855
 

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