Article ID: 953027 - Last Review: August 18, 2008 - Revision: 2.1

Windows Vista SP1, Windows Server 2008, Windows Server 2003 SP2, and Windows XP SP3 are not listed as supported platforms for software distribution, update management, or desired configuration management in Systems Management Server 2003

On This Page

Expand all | Collapse all

SYMPTOMS

In Microsoft Systems Management Server 2003, the following products are not listed as supported platforms for software distribution, software update management, or desired configuration management.
  • Windows Vista Service Pack 1 (SP1)
  • Windows Server 2008
  • Windows Server 2003 Service Pack 2 (SP2)
  • Windows XP Service Pack 3 (SP3)

CAUSE

This problem occurs because these platforms were not included in Systems Management Server 2003 as supported platforms for software distribution or for software update deployment.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Systems Management Server 2003 Service Pack 3 installed before you apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Systems Management Server 2003 Service Pack 3
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Baserc.dll2.50.4253.312061,44031-Jul-200719:35x86
Update.sqlNot Applicable26,44731-Jul-200719:35Not Applicable
Installation of this hotfix is required on primary sites, on secondary sites, and on remote admin consoles.

After you apply this hotfix, follow these steps on the SMS site database server:
  1. Stop the following services:
    • SMS_SITE_COMPONENT_MANAGER
    • SMS_EXECUTIVE
  2. Find the Update.sql script in the following folder:
    Drive :\SMS\Logs\KB953027
    In this step, the Drive placeholder represents the drive on which SMS 2003 is installed.
  3. Open the Update.sql script in a Microsoft SQL Server query tool, and then run this script against the SMS database. To do this, follow these steps:
    1. Copy the Update.sql file to the SMS 2003 database server.
    2. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.
    3. Connect to the SQL server.
    4. On the Query menu, click Change Database.
    5. Click the name of the SMS database, and then click OK.
    6. On the File menu, click Open.
    7. Open the SMS\Logs\KB953027 folder, click Update.sql, and then click Open.
    8. On the Query menu, click Execute.
  4. Start the following services:
    • SMS_SITE_COMPONENT_MANAGER
    • SMS_EXECUTIVE

WORKAROUND

To work around this problem, click to select the This program can run on any platform check box for software distribution program configurations. Then, click to select the All Windows Platforms check box for configuration item configurations.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

SMS uses a WMI Query Language (WQL) query to determine whether a given computer should accept programs or advertisements for execution. Unlike other service packs, such as Windows XP Service Pack 3 (SP3), Vista Service Pack 1 (SP1) introduced a new build number that prevented the System Center Configuration Manager (SCCM) 2003 SP3 WQL query logic for the "All x86 Windows Vista" or "All x64 Windows Vista" supported platforms. The SQL script within the hotfix updates the WQL query so that new service packs for Vista will be within scope of the "All x86 Windows Vista" or "All x64 Windows Vista" supported platforms. However, because Windows Vista SP1 clients may have already rejected the program in the past, you must make a change to the program for Windows Vista SP1 clients to obtain a new policy and run programs that were previously rejected. One such program change would be to add a space within the comment field.

The following platforms are supported after you apply this hotfix:
  • Windows Vista SP1, x86-based versions
  • Windows Vista SP1, x64-based versions
  • Windows Server 2008, x86-based versions
  • Windows Server 2008, x64-based versions
  • Windows Server 2008, Itanium-based versions
  • Windows XP Professional Service Pack 3, x86-based versions
  • Windows XP Professional Service Pack 3, x64-based versions
  • Windows Server 2003 SP2, x86-based versions
  • Windows Server 2003 SP2, x64-based versions
  • Windows Server 2003 SP2, Itanium-based version
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB953027
 

Article Translations

 

Related Support Centers