Article ID: 953156 - Last Review: October 8, 2011 - Revision: 3.0

CPU usage increases to 100 percent on the site server after you add at least 1,000 IP address range boundaries on the central primary site for the child primary site in System Center Configuration Manager 2007

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SYMPTOMS

Consider the following scenario:
  • You set up a central primary site and a child primary site in a Microsoft System Center Configuration Manager 2007 environment.
  • On the central primary site, you add at least 1,000 IP address range boundaries for the child primary site.
In this scenario, the site boundaries that you added are not updated on the child primary site. Additionally, the CPU usage on the site server of the child primary site increases to 100 percent.

CAUSE

Hierarchy Manager uses the Active Directory Service Interfaces (ADSI) interface to query IP address range boundaries from the Active Directory directory service. However, an incorrect parameter causes an endless loop in the query function call. This behavior causes high CPU usage. Hierarchy Manager cannot process the site control (.ct2) file that is sent from the primary site to update the site hierarchy.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
System Center Configuration Manager 2007 SP2
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File nameFile versionFile sizeDateTimePlatform
Hman.dll4.0.6487.2165248,68001-Feb-201014:20x86
System Center Configuration Manager 2007, x86
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File nameFile versionFile sizeDateTimePlatform
Hman.dll4.0.5931.139231,35231-Dec-200721:10x86
System Center Configuration Manager 2007, x64
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File nameFile versionFile sizeDateTimePlatform
Hman.dll4.0.5931.139231,35231-Dec-200721:10x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft System Center Configuration Manager 2007
Keywords: 
kbautohotfix kbexpertiseinter kbbug kbfix kbqfe KB953156