ID do artigo: 953196 - Última revisão: segunda-feira, 10 de novembro de 2008 - Revisão: 1.0

CORRECÇÃO: In Designer WPF para o Visual Studio 2008, IntelliSense para XAML pode parar de funcionar depois de instalar o SDK do Windows ou MSDN

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

No criador de Windows Presentation Foundation (WPF) para o Microsoft Visual Studio 2008, você pode usar o Microsoft IntelliSense para XAML (Extensible Application Markup Language). No entanto, o IntelliSense para XAML pode parar de funcionar depois de instalar o Microsoft Windows Software Development Kit (SDK) ou o Microsoft Developer Network (MSDN). Quando esse problema ocorre, o valor de registro (padrão) em uma das seguintes chaves do Registro está vazio:
  • Em um computador x 86:
    HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32
  • Em um computador x 64:
    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

Causa

Esse problema ocorre porque o valor de registro (padrão) na chave do Registro
InProcServer32
é redefinido incorretamente após a instalação do Document Explorer.

Resolução

Um hotfix com suporte foi disponibilizada pela Microsoft. No entanto, destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Para resolver esse problema, contate o Microsoft Customer Atendimento para obter o hotfix. Para obter uma lista completa de telefones do serviço de suporte a clientes da Microsoft e informações sobre os custos de suporte, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Pré-requisitos

Não há nenhum pré-requisito.

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Textmgrp.dll9.0.21022.12876,80024 De junho de 200806: 39x 86

Como Contornar

Para contornar este problema, use um dos seguintes métodos.

Método 1: Reparar Visual Studio 2008

Windows Vista e Windows Server 2008

  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    Start button
    e, em seguida tipo appwiz.cpl na caixa Iniciar pesquisa .
  2. Na lista programas , clique com o botão direito do mouse appwiz.cpl e, em seguida, clique em Executar como administrador .

    Recolher esta imagemExpandir esta imagem
    User Account Control permission
    Se você for solicitada uma senha de administrador ou confirmação, digite a senha ou forneça uma confirmação.
  3. Na lista de programas instalados, localize o Visual Studio 2008 e, em seguida, clique em Alterar .
  4. Clique em Reparar .

Windows XP e Windows Server 2003

  1. Clique em Iniciar , clique em Executar , digite appwiz.cpl na caixa Abrir e, em seguida, clique em OK .
  2. Na lista de programas instalados, localize o Visual Studio 2008 e, em seguida, clique em Alterar .
  3. Clique em Reparar .

Método 2: Registrar o arquivo TextMgrP.dll manualmente

Windows Vista e Windows Server 2008

  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    Start button
    e, em seguida, digite cmd na caixa Iniciar pesquisa .
  2. Na lista programas , clique com o botão direito do mouse em cmd e, em seguida, clique em Executar como administrador .

    Recolher esta imagemExpandir esta imagem
    User Account Control permission
    Se você for solicitada uma senha de administrador ou confirmação, digite a senha ou forneça uma confirmação.
  3. No prompt de comando, digite o comando apropriado e, em seguida, pressione ENTER:
    • Em um computador x 86, digite o seguinte comando:
      regsvr32 "%CommonProgramFiles%\Microsoft Shared\MSEnv\TextMgrP.dll"
    • Em um computador x 64, digite o seguinte comando:
      regsvr32 "% CommonProgramFiles(X86) %\Microsoft Shared\MSEnv\TextMgrP.dll"

Windows XP e Windows Server 2003

  1. Clique em Iniciar , clique em Executar , digite cmd na caixa Abrir e, em seguida, clique em OK .
  2. No prompt de comando, digite o comando apropriado e, em seguida, pressione ENTER:
    • Em um computador x 86, digite o seguinte comando:
      regsvr32 "%CommonProgramFiles%\Microsoft Shared\MSEnv\TextMgrP.dll"
    • Em um computador x 64, digite o seguinte comando:
      regsvr32 "% CommonProgramFiles(X86) %\Microsoft Shared\MSEnv\TextMgrP.dll"

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Visual Studio 2008 Team Suite
  • Microsoft Visual Studio 2008 Team Foundation Server
  • Microsoft Visual Studio 2008 Team System Test Load Agent
  • Microsoft Visual Studio 2008 Team Edition for Database Professionals
  • Microsoft Visual Studio 2008 Team Edition for Software Architects
  • Microsoft Visual Studio 2008 Team Edition for Software Developers
  • Microsoft Visual Studio 2008 Team Edition for Software Testers
  • Microsoft Visual Studio 2008 Tools for Applications Software Development Kit
  • Microsoft Visual Studio 2008 Standard Edition
  • Microsoft Visual Studio 2008 Professional Edition
Palavras-chave: 
kbmt kbhotfixserver kbexpertiseadvanced kbqfe KB953196 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 953196  (http://support.microsoft.com/kb/953196/en-us/ )