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The DeviceType registry entry value is truncated when the Microsoft Storport driver is installed on a computer that is running Windows Server 2008 or Windows Vista

Article ID:953390
Last Review:June 6, 2008
Revision:1.1
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SYMPTOMS

The Microsoft Storport driver (Storport.sys) is installed on a computer that is running Windows Server 2008 or Windows Vista. Then, you notice that the value of the DeviceType registry entry for storage devices is truncated to half of its length.

Note The DeviceType registry entry is located under the following registry subkey:
HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\Scsi Port <x>\Scsi Bus <x>\Target Id <x>\Logical Unit Id <x>

In this subkey, <x> is a placeholder for a one-digit number.
For example, the value of the DeviceType registry entry may be truncated to "MediumChang" when the registry entry that is expected is "MediumChangerPeripheral."

Therefore, applications may function incorrectly when they retrieve the device type information from the DeviceType registry entry.

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CAUSE

This problem occurs because the Storport.sys driver incorrectly calculates the string size of the DeviceType registry entry.

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RESOLUTION

Hotfix information

Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2008, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6001.22190123,96030-May-200805:58x86
Windows Server 2008, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6001.22190377,91230-May-200806:25IA-64
Windows Server 2008, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6001.22190162,87230-May-200806:42x64

Windows Vista

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6000.20845120,37630-May-200805:51x86
Windows Vista with Service Pack 1, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6001.22190123,96030-May-200805:58x86
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6000.20845135,73630-May-200806:07x64
Windows Vista with Service Pack 1, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6001.22190162,87230-May-200806:42x64

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/LN/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Windows Server 2008 Standard
Windows Server 2008 Enterprise
Windows Server 2008 Datacenter
Windows Server 2008 Datacenter without Hyper-V
Windows Server 2008 Enterprise without Hyper-V
Windows Server 2008 for Itanium-Based Systems
Windows Server 2008 Standard without Hyper-V
Windows Web Server 2008
Windows Vista Ultimate
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Enterprise
Windows Vista Business
Windows Vista Business 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Enterprise 64-bit Edition

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Keywords: 
kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB953390

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