Help and Support

Article ID: 953469 - Last Review: July 12, 2008 - Revision: 3.0

Description of Update Rollup 7 for Exchange Server 2007

On This Page

Expand all | Collapse all

SUMMARY

Microsoft has released Update Rollup 7 for Microsoft Exchange Server 2007. This article contains the following information about the update rollup:
  • The issues that the update rollup fixes
  • How to obtain the update rollup
  • The prerequisites for applying the update rollup

INTRODUCTION

Issues that the update rollup fixes

Update Rollup 7 for Exchange Server 2007 includes fixes for the issues that are described in Microsoft security bulletin MS08-039. The security bulletin contains all the relevant information about the security update. To view the complete security bulletin, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/bulletin/ms08-039.mspx (http://www.microsoft.com/technet/security/bulletin/ms08-039.mspx)

MORE INFORMATION

Update rollup information

This update rollup does not apply to Microsoft Exchange Server 2007 Service Pack 1 (SP1). The series of update rollup packages for Exchange Server 2007 is independent of the corresponding series of update rollups for Exchange Server 2007 SP1.

For a list of update rollups that apply to Exchange Server 2007 SP1, see the "Update rollups for Exchange Server 2007 Service Pack 1" section in the following article in the Microsoft Knowledge Base:
937052  (http://support.microsoft.com/kb/937052/ ) How to obtain the latest update rollup for Exchange 2007
To install Update Rollup 7 for Exchange Server 2007, visit the following Microsoft Update Web site:
http://update.microsoft.com (http://update.microsoft.com)
Note Microsoft Update does not detect update rollups for Exchange Server 2007 on clustered Exchange Server 2007 systems.

As an administrator, you may want to deploy Update Rollup 7 for Exchange Server 2007 to multiple computers that are running Exchange Server 2007. Or, you may want to deploy Update Rollup 7 for Exchange Server 2007 to clustered servers that are running Exchange Server 2007. In this case, you can download the update rollup from the Microsoft Download Center.

The following file is available for download from the Microsoft Download Center:

Collapse this imageExpand this image
Download
Download the Update Rollup 7 for Exchange Server 2007 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=086A2A13-A1DE-4B1D-BD12-B148BFD2DAFA&displaylang=en)

Release Date: July 8, 2008

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Note Certain Exchange Server 2007 managed code services may not start after you install this update rollup. This is true if the services cannot access the following Microsoft Web site:
http://crl.microsoft.com/pki/crl/products/CodeSigPCA.crl (http://crl.microsoft.com/pki/crl/products/CodeSigPCA.crl)
For more information about how to resolve or to work around this issue, click the following article number to view the article in the Microsoft Knowledge Base:
944752  (http://support.microsoft.com/kb/944752/ ) Exchange 2007 managed code services do not start after you install an update rollup for Exchange 2007
For more information about the servicing model for Exchange Server 2007, click the following article number to view the article in the Microsoft Knowledge Base:
937194  (http://support.microsoft.com/kb/937194/ ) The product service strategy for Exchange Server 2007

Update replacement information

Update Rollup 7 for Exchange Server 2007 is a cumulative update.

This update rollup replaces the following update rollups:
930809  (http://support.microsoft.com/kb/930809/ ) Description of Update Rollup 1 for Exchange Server 2007
935490  (http://support.microsoft.com/kb/935490/ ) Description of Update Rollup 2 for Exchange 2007
935999  (http://support.microsoft.com/kb/935999/ ) Description of Update Rollup 3 for Exchange Server 2007
940006  (http://support.microsoft.com/kb/940006/ ) Description of Update Rollup 4 for Exchange Server 2007
941421  (http://support.microsoft.com/kb/941421/ ) Description of Update Rollup 5 for Exchange Server 2007
942846  (http://support.microsoft.com/kb/942846/ ) Description of Update Rollup 6 for Exchange Server 2007

Prerequisites

The following list contains the prerequisites for Update Rollup 7 for Exchange Server 2007:
  • You must install Exchange Server 2007 on the computer before you apply this update rollup.
  • You must remove all interim updates for Exchange Server 2007 before you apply this update rollup.

Restart requirement

The required services are automatically stopped and then restarted when you apply this update rollup.

Removal information

To remove Update Rollup 7 for Exchange Server 2007, use the Add or Remove Programs feature in Control Panel.

Known issues

  • Consider the following scenario. You are a CAS Proxy Deployment Guidance customer. You deploy CAS-CAS proxying. In this scenario, after you apply Update Rollup 3 for Exchange Server 2007, communication to the non-Internet-facing Client Access Servers may stop.

    This problem may occur if you are a CAS Proxy Deployment Guidance customer, and you apply the update rollup to the Internet-facing Client Access servers first.

    When you deploy CAS-CAS proxying, apply the update rollup to the Internet-facing Client Access servers before you apply the update rollup to the non-Internet-facing Client Access servers. For other Exchange Server 2007 configurations, the order in which you apply the update rollup to the servers is not important.

    For more information about CAS-CAS proxying, visit the following Microsoft Web site:
    http://technet.microsoft.com/en-us/library/bb310763.aspx (http://technet.microsoft.com/en-us/library/bb310763.aspx)
  • In some scenarios, you may be prompted to uninstall an interim update when you install this update rollup. We recommend that you uninstall any interim updates before you install the update rollup. However, not all interim updates are included in the next update rollup. This depends on the timing of the update rollup and the release of the interim update.
    For more information about a complete list of interim updates that are included in this rollup update and for a more detailed explanation of the Microsoft Exchange 2007 servicing model, click the following article number to view the article in the Microsoft Knowledge Base:
    937194  (http://support.microsoft.com/kb/937194/ ) The product service strategy for Exchange Server 2007
Certain Exchange Server services are disabled if you use Microsoft Update to deploy the update rollup or if you deploy the update rollup in silent mode. This known issue occurs only if a file that is updated by the update rollup is being used. This section contains more information about this issue.
Symptoms

You use Microsoft Update to apply Update Rollup 7 for Exchange Server 2007. Or, you apply the update rollup in silent mode. When you do this, certain services in Exchange Server 2007 are stopped and are disabled. Additionally, events that resemble the following events are logged in the Application log:

Type: Error
Source: MsiInstaller
Category: None
Event ID: 11306
Description:
Product: Microsoft Exchange Server -- Error 1306. Another application has exclusive access to the file 'PathOfFile'. Please shut down all other applications, then click Retry.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Data: 0000: 7b 32 34 42 32 43 31 36 {24B2C16 0008: 34 2d 44 45 36 36 2d 34 4-DE66-4 0010: 34 46 45 2d 42 34 36 38 4FE-B468 0018: 2d 41 34 36 44 39 44 35 -A46D9D5 0020: 45 36 42 33 31 7d E6B31}

Type: Error
Source: MsiInstaller
Category: None
Event ID: 1023
Description:
Product: Microsoft Exchange Server - Update 'Update Rollup 7 for Exchange Server 2007 (KB953469)' could not be installed. Error code 1603. Additional information is available in the log file Drive:\FileName.log.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Data: 0000: 7b 32 34 42 32 43 31 36 {24B2C16 0008: 34 2d 44 45 36 36 2d 34 4-DE66-4 0010: 34 46 45 2d 42 34 36 38 4FE-B468 0018: 2d 41 34 36 44 39 44 35 -A46D9D5 0020: 45 36 42 33 31 7d 20 7b E6B31} { 0028: 44 43 46 35 41 46 45 32 DCF5AFE2 0030: 2d 45 38 30 41 2d 34 32 -E80A-42 0038: 46 42 2d 41 36 30 44 2d FB-A60D- 0040: 41 33 42 37 35 45 38 45 A3B75E8E 0048: 43 33 39 34 7d 20 31 36 C394} 16 0050: 30 33 03

Type: Information
Source: MsiInstaller
Category: None
Event ID: 11729
Description:
Product: Microsoft Exchange Server -- Configuration failed.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Data: 0000: 7b 32 34 42 32 43 31 36 {24B2C16 0008: 34 2d 44 45 36 36 2d 34 4-DE66-4 0010: 34 46 45 2d 42 34 36 38 4FE-B468 0018: 2d 41 34 36 44 39 44 35 -A46D9D5 0020: 45 36 42 33 31 7d E6B31}

Additionally, if you used Microsoft Update to apply the update, you receive an error message that resembles the following error message:
Error Code: 0x80070643
Cause

This issue occurs if a silent installation of the update rollup encounters a "File in use" scenario. In this scenario, a file that is updated by the update rollup is being used.
Workaround
To work around this issue, view the Application log events that are mentioned in the "Symptoms" section to determine which file is being used. Then, make sure that the file is not being used when you install the update rollup.

Additionally, you must recover the original state of the Exchange Server services. To do this, use one of the following methods:
  • If this is the first time that you have experienced this issue, run the ServiceControl.ps1 AfterPatch command from the Exchange Management Shell.
  • If this is not the first time that you have experienced this issue, use the Services tool to manually configure the Startup type setting of the services. Perform this procedure before you install the update rollup.
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbbug kbfix kbexpertiseinter atdownload KB953469

Article Translations

 

Related Support Centers