Active Directory 内のユーザー名を変更すると、Windows Vista または Windows XP を実行しているコンピューターで、フォルダー リダイレクト プロセスの失敗します。

文書翻訳 文書翻訳
文書番号: 953529
すべて展開する | すべて折りたたむ

目次

現象

管理者は、Active Directory ディレクトリ サービス内のユーザーのユーザー名を変更します。これを行うと、そのユーザーのフォルダー リダイレクト プロセス Windows Vista または Windows XP を実行しているコンピューター上で失敗します。

ただし、フォルダー リダイレクト プロセスはユーザーは、名前の変更する前にログオンしていないコンピューター上で動作します。

メモ フォルダー リダイレクトは、ユーザーが初めてコンピューターにログオンするときに実装されています。

次の条件に該当する場合この問題が発生します。
  • フォルダー リダイレクトのパスにユーザー名が含まれています。たとえば、次のようなリダイレクトされたフォルダーのパスを使用します。
    \\サーバー名\共有名\%ユーザー名%\
  • 名前の変更後、最初をユーザーは、名前の変更前にログオンする Windows XP と Windows Vista を実行しているコンピューターにログオンします。
さらに、次のイベントがアプリケーション ログに記録されます。

イベント ID: 107
ユーザー: ドメイン\New_user_name
説明:[マイ ドキュメント] フォルダーのリダイレクト操作に失敗しました。リダイレクトされるフォルダーを構成します。 \\Server_Name\Share_Name\User_Name\My_Documents するには \\Server_Name\Share_Name\New_User_Name\My_Documents.次のエラーが発生しました。ファイルが既に存在する場合は、ファイルを作成できません。

原因

この問題をユーザー前にログオンしていないコンピューターで、新しいユーザー名を使用して、最初に、ユーザー ログオンすると、新しいフォルダーが作成されるために発生します。

したがって、ユーザーの彼または彼女以前に名前の変更する前にログオンするコンピューターにログオンすると、ユーザー プロファイル用の既存のフォルダーは、新しいユーザー名を変更できません。このような状況で失敗するのには、フォルダー リダイレクト プロセスが発生します。

解決方法

この問題を解決するのには、影響を受けるユーザーのプロファイルをユーザー名の変更する前にログオンする、コンピューターを削除してください。これを行うには、次の方法のいずれかを使用します。

重要です ユーザー プロファイルには、ユーザー固有の設定、データ、およびデジタル証明書が含まれます。それを削除する前に、ユーザー プロファイルのバックアップ コピーを作成することをお勧めします。ユーザー証明書をエクスポートする方法の詳細については、次のマイクロソフト Web サイトを参照してください。
http://technet2.microsoft.com/windowsserver/en/library/5f06e6e3-22dc-460a-9ea3-33d6f6aa72871033.mspx?mfr=true

方法 1: プロファイルを手動で削除します。

Windows Vista

  1. 管理者としてコンピューターにログオンします。
  2. クリックしてください。 開始
    元に戻す画像を拡大する
     [スタート] ボタン
    を右クリックして コンピューター、し プロパティ.

    元に戻す画像を拡大する
     ユーザー アカウント制御の許可
    管理者のパスワードまたは確認を求められたら、パスワードを入力またはをクリックしてください 続行.
  3. ナビゲーション ウィンドウをクリックします。 [システムの詳細設定.
  4. 下にあります。 ユーザー プロファイルをクリックして 設定.
  5. 対象となるユーザーをクリックし、 削除、し [はい].
  6. クリックしてください。 [OK] ダイアログ ボックスを閉じますを 2 回します。

Windows XP

  1. 管理者としてコンピューターにログオンします。
  2. クリックしてください。 開始を右クリックして マイ コンピューター、し プロパティ.
  3. で、 高度な タブで、クリックしてください 設定 下にあります。 ユーザー プロファイル.
  4. 対象となるユーザーをクリックし、 削除、し [はい].
  5. クリックしてください。 [OK] ダイアログ ボックスを閉じますを 2 回します。

方法 2: は、Delprof.exe ユーティリティを使用して、プロファイルを削除する.

ローカルまたはリモートでのプロファイルを削除するのには、Delprof.exe ユーティリティを使用できます。

これを行う方法の詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
315411Windows 2000 では、ユーザー プロファイルの削除のユーティリティ (Delprof.exe) を使用してユーザー プロファイルを削除する方法

プロパティ

文書番号: 953529 - 最終更新日: 2011年8月11日 - リビジョン: 3.0
キーワード:?
kbtshoot kblogin kbprb kbexpertiseadvanced kbuserprofile kbmt KB953529 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:953529
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com