Niepowodzenia procesu przekierowania folderu na komputerze z systemem Windows Vista lub Windows XP, po zmianie nazwy użytkownika w usłudze Active Directory

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 953529 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Jako administrator możesz zmienić nazwę użytkownika dla użytkownika w usłudze katalogowej Active Directory. Po wykonaniu tej czynności na komputerze, na którym jest uruchomiony system Windows Vista lub Windows XP kończy się niepowodzeniem procesu przekierowania folderu dla danego użytkownika.

Jednak proces przekierowania folderu nadal działa na wszystkich komputerach, na których użytkownik nie zalogował przed zmianą nazwy.

Uwaga Przekierowanie folderu jest zaimplementowana, gdy użytkownik loguje się do komputera po raz pierwszy.

Ten problem występuje, gdy są spełnione następujące warunki:
  • Ścieżka przekierowania folderu obejmują nazwę użytkownika. Na przykład użyj ścieżki przekierowanego folderu, podobną do następującej ścieżki:
    \\Nazwa_serwera\Nazwa_udziału\%Nazwa_użytkownika%\
  • Po zmianie nazwy użytkownika najpierw loguje się do komputera z systemem Windows Vista lub Windows XP, na którym użytkownik nigdy nie zalogował przed zmianą nazwy.
Ponadto następujące zdarzenie jest rejestrowane w dzienniku aplikacji:

Identyfikator zdarzenia: 107
Użytkownik: Domeny\New_user_name
Opis: Nie można wykonać przekierowania folderu Moje dokumenty. Folder jest skonfigurowany do przekierowane z \\Server_Name\Share_Name\User_Name\My_Documents Aby \\Server_Name\Share_Name\New_User_Name\My_Documents. Wystąpił następujący błąd: Nie można utworzyć pliku, gdy ten plik już istnieje.

Przyczyna

Ten problem występuje, ponieważ nowy folder jest tworzony, gdy użytkownik loguje się po raz pierwszy przy użyciu nowej nazwy użytkownika na dowolnym komputerze, na którym użytkownik nie zalogował przed.

W związku z tym kiedy użytkownik loguje się komputerze, na którym on lub ona wcześniej zalogowany przed zmianą nazwy, istniejący folder profilu użytkownika nie można zmienić nazwy na nową nazwę użytkownika. Warunek ten powoduje niepowodzenie operacji przekierowania folderu.

Rozwiązanie

Aby rozwiązać ten problem, należy usunąć profil użytkownika podlegającego usterce na komputerach, na których użytkownik zalogowany przed zmianą nazwy. Aby to zrobić, użyj jednej z następujących metod.

Ważne Profil użytkownika zawiera ustawienia specyficzne dla użytkownika, danych i certyfikaty cyfrowe. Zaleca się, aby utworzyć kopię zapasową profilu użytkownika przed usunięciem. Aby uzyskać więcej informacji na temat eksportowania certyfikatów użytkowników odwiedź następującą witrynę Microsoft TechNet w sieci Web:
http://technet2.microsoft.com/WindowsServer/en/Library/5f06e6e3-22dc-460a-9ea3-33d6f6aa72871033.mspx?mfr=true

Metoda 1: Ręcznie usunąć profil

System Windows Vista

  1. Zaloguj się do komputera jako administrator.
  2. Kliknij przycisk Start
    Zwiń ten obrazekRozwiń ten obrazek
     Przycisk Start
    , kliknij prawym przyciskiem myszy Komputer, a następnie kliknij przycisk Właściwości.

    Zwiń ten obrazekRozwiń ten obrazek
     Uprawnienie Kontrola konta użytkownika
    Jeśli zostanie wyświetlony monit o hasło administratora lub potwierdzenie, wpisz hasło lub kliknij przycisk W dalszym ciągu.
  3. W okienku nawigacji kliknij Zaawansowane ustawienia systemu.
  4. W obszarze Profile użytkowników, kliknij przycisk Ustawienia.
  5. Kliknij użytkownika, którego dotyczy problem, kliknij przycisk Usuń, a następnie kliknij przycisk Tak.
  6. Kliknij przycisk OK dwa razy, aby zamknąć okno dialogowe.

System Windows XP

  1. Zaloguj się do komputera jako administrator.
  2. Kliknij przycisk Start, kliknij prawym przyciskiem myszy Mój komputer, a następnie kliknij przycisk Właściwości.
  3. Na Zaawansowane Kliknij pozycję Ustawienia w obszarze Profile użytkowników.
  4. Kliknij użytkownika, którego dotyczy problem, kliknij przycisk Usuń, a następnie kliknij przycisk Tak.
  5. Kliknij przycisk OK dwa razy, aby zamknąć okno dialogowe.

Metoda 2: Usuwanie profilu przy użyciu narzędzia Delprof.exe

Narzędzie Delprof.exe usunąć profile lokalne lub zdalne.

Aby uzyskać więcej informacji na temat jak to zrobić kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
315411Jak usunąć profile użytkownika przy użyciu narzędzia do usuwania profilu użytkownika (Delprof.exe) w systemie Windows 2000

Właściwości

Numer ID artykułu: 953529 - Ostatnia weryfikacja: 25 czerwca 2011 - Weryfikacja: 2.0
Informacje zawarte w tym artykule dotyczą:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Microsoft Windows XP Professional
Słowa kluczowe: 
kbprb kbexpertiseadvanced kblogin kbuserprofile kbtshoot kbmt KB953529 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:953529

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com