Um fluxo de trabalho não retoma automaticamente quando uma actividade de atraso é activada no Windows SharePoint Services 3.0

Traduções de Artigos Traduções de Artigos
Artigo: 953630 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Um fluxo de trabalho que descarrega quando é accionada uma actividade de atraso não retoma automaticamente, mesmo depois da hora agendada tiver decorrido no Microsoft Windows SharePoint Services 3.0. O estado do fluxo de trabalho apresentada na página de estado de fluxo de trabalho do SharePoint permanecerá ? em curso".

Causa

Este problema pode ocorrer devido das seguintes causas:

Causa 1

A correcção descrita no artigo da base de dados de conhecimento da Microsoft 932394 não está instalada no computador.

Causa 2

Por vezes, um fluxo de trabalho descarrega antes de um evento de temporizador está agendado para continuar o fluxo de trabalho. Se um evento de temporizador não está agendado, o fluxo de trabalho nunca será retomada.

Causa 3

Ocorre um problema com o serviço de temporizador do SharePoint. Pode verificar se o problema testando outras funcionalidades do serviço de temporizador. Por exemplo, testa recepção de correio electrónico para criar um item de lista.

Causa 4

O temporizador do SharePoint não está configurado para executar a hora correcta. Actividade de atraso no fluxos de trabalho é processada pelo serviço de temporizador do SharePoint e retomar a Fluxos de trabalho de acordo com a agenda da tarefa de temporizador de fluxo de trabalho. Por predefinição, a tarefa de temporizador está configurada para ser executado a cada 5 minutos. Por exemplo, podem retomar fluxos de trabalho estão configurados para retomar dentro de 5 minutos após 9 minutos e 59 segundos.

Causa 5

A assemblagem de fluxo de trabalho na cache de assemblagem global (GAC) é substituída. Este problema ocorre quando actualizar a assemblagem de fluxo de trabalho e substituir uma assemblagem de fluxo de trabalho existente. Neste caso, o processo de temporizador utiliza a versão antiga da definição de fluxo de trabalho. O fluxo de trabalho não retoma uma vez que a versão antiga da assemblagem de fluxo de trabalho é substituída e já não existe.

Normalmente, fluxo de trabalho na GAC é substituído nas seguintes circunstâncias:
  • Utiliza o GACUtil ferramenta para copiar a assemblagem.
  • Manualmente copiar da assemblagem, utilizando O Explorador do Windows.
  • Pode utilizar o Visual Studio Tools para a função de implementação de fluxo de trabalho VSTO (Microsoft Office System) está incluída no Microsoft Visual Studio 2008.

Causa 6

O estado do fluxo de trabalho é apresentado no SharePoint Services permanece ? em curso ? Apesar de não retoma o fluxo de trabalho.

Causa 7

  • Fluxos de trabalho contém ciclos nunca parar. Por exemplo, podem conter fluxos de trabalho ao ciclos que não incrementar os respectivos contadores.
  • Replicador actividades no fluxo de trabalho não tem a propriedade InitialChildData definida.

Resolução

Resolução para a causa 1

Para resolver este problema, siga estes passos:
  1. Instale a correcção descrita no seguinte artigo da base de dados de conhecimento da Microsoft:
    932394Um temporizador não retoma o funcionamento após o recarregamento um fluxo de trabalho no Microsoft Windows Workflow Foundation

    Ou, pode instalar o Microsoft .NET Framework 3 Service Pack 1 (SP1) ou o .NET Framework 3.5. Para obter mais informações sobre o .NET Framework 3 SP1, visite o seguinte Web site da Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=EC2CA85D-B255-4425-9E65-1E88A0BDB72A&displaylang=en
    Para obter mais informações sobre o .NET Framework 3.5, visite o seguinte Web site da Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
  2. Repor os serviços de informação Internet (IIS).
  3. Reinicie o serviço de temporizador do SharePoint.

Resolução para a causa 2

Instale a actualização Windows SharePoint Services 3.0 que é descrita no seguinte artigo da base de dados de conhecimento da Microsoft:
953749Problemas corrigidos no Windows SharePoint Services 3.0, a actualização de infra-estrutura do Windows SharePoint Services 3.0

A actualização de infra-estrutura do Windows SharePoint Services 3.0 resolve este problema ao agendar um evento do temporizador.

Resolução para a causa 3

Pode utilizar os seguintes métodos para resolver problemas relacionados com o serviço de temporizador de:
  • Reinicie o serviço de temporizador do SharePoint.
  • Utilize o programa de monitorização (Taskmon.exe) de tarefas para verificar que o serviço de temporizador do SharePoint (Owstimer.exe) está em execução.
  • Verifique se os ficheiros de registo unificado registo de serviço (ULS) contêm entradas de erro do serviço de temporizador e, em seguida, resolver o problema em conformidade.
  • Certifique-se de que o programa antivírus não está a causar os problemas do serviço de temporizador.

    Para obter mais informações sobre detecção antivírus no Windows SharePoint Services 3.0 e no Office SharePoint Server 2007, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    952167Podem ter pastas a serem excluídos da detecção antivírus quando utiliza um programa antivírus nível dos ficheiros no Windows SharePoint Services 3.0 ou no SharePoint Server 2007

Resolução para causa 4

Para contornar este problema, execute o seguinte comando para definir o intervalo correcto para a tarefa de temporizador de fluxo de trabalho e reinicie o serviço de temporizador do SharePoint:
Stsadm ?o setproperty ?pn fluxo de trabalho-trabalho ?pv interval for running the workflow timer job

Resolução para a causa 5

Reinicie o serviço de temporizador do SharePoint.

Nota Esta resolução se aplica a apenas recentemente instâncias de fluxo de trabalho criado. Que não é possível corrigir as instâncias de fluxo de trabalho existente que já são afectadas. Pode utilizar um número de versão para cada assemblagem é criada para controlar as instâncias de fluxo de trabalho nova e antiga.

Resolução para causa 6

Verificar ficheiros de registo de mensagens de erro unificado registo de serviço (ULS) e, em seguida, resolver o problema em conformidade. Normalmente, este problema ocorre se o fluxo de trabalho não processa uma excepção e falha.

Resolução para a causa 7

Certifique-se problemas de construção de ciclo nas definições de fluxo de trabalho. Certifique-se de que a propriedade InitialChildData em actividades de replicação está associada a um objecto de dados.

Propriedades

Artigo: 953630 - Última revisão: 15 de julho de 2008 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows SharePoint Services 3.0
Palavras-chave: 
kbmt kbexpertiseadvanced kbtshoot KB953630 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 953630

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com