Article ID: 953796 - Last Review: May 30, 2008 - Revision: 1.0

Internet Explorer experiences a script error if Avaya Webdialer is installed

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Source: Microsoft Support

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RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Result



In Internet Explorer 6 or Internet Explorer 7, if Avaya WebDialer is installed, you may experience script error similar to the followings:

Internet Explorer Script Error

         ! An error has occurred in the script on this page.

   Line:  2
   Char:  7
   Error: Invalid character
   Code:  0
   URL:   http://www.domain.com/ (http://www.domain.com/)

          Do you want to continue running scripts on this page?

Yes  No

Cause

This issue occurs because of a problem with Avaya Webdialer IP Agent.

Resolution



To resolve this issue, contact Avaya for further assistance.

https://support.avaya.com/main/supportcentral/supportcentral.do?PAGE=Home (https://support.avaya.com/main/supportcentral/supportcentral.do?PAGE=Home)

Workaround:

Avaya has provided the following methods to work around this issue.

Method 1: Unregister the IP Agent Internet Explorer component. 

1. Launch the Command Prompt.

2. In the Command Prompt, type the command below, and press Enter.

     regsvr32 /u "C:\Program Files\Avaya\Avaya IP Agent\WebDialer.dll"

3. Exit the Command Prompt.

Method 2: Disable the IP Agent Internet Explorer component.

1. In Internet Explorer, click Tools>Manage Add-ons>Enable or disable Add-ons.

2. Select "Add-ons currently loaded in Internet Explorer" from the "Show" drop down box.

3. Highlight "WebDialerBHO Class" and select "Disable".

4. Close Internet Explorer, if you have multiple Internet Explorer windows open, close all of them.

5. Reopen Internet Explorer.

More Information



For more information, please refer to the article below on Avaya Web site. The article ID is PSN # 844U.

PSN # 844U - Internet Explorer script errors are displayed when using IP Agent (https://support.avaya.com/japple/css/japple?temp.documentID=291530&temp.productID=162774&temp.bucketID=162024&PAGE=Document)

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APPLIES TO
  • Windows Internet Explorer 7
  • Microsoft Internet Explorer 6.0
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