Información acerca de cómo trabajar con archivos de formato XML abierto en Microsoft Office 2004 para Mac

Seleccione idioma Seleccione idioma
Id. de artículo: 953823 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

INTRODUCCIÓN

Importante: Office 2004 para Mac ha llegado al final de su ciclo de vida de soporte técnico, por lo que Microsoft ya no proporcionará soporte técnico asistido ni actualizaciones. Se recomienda actualizar a Office 2011 para Mac para tener una versión compatible de Office. Para obtener información acerca del final del soporte técnico de Office 2004 para Mac, visite el sitio Microsoft Support Lifecycle.


Si tiene instalada la actualización 11.5.0 de Microsoft Office 2004 para Mac y el convertidor de formato de archivos XML abiertos de Microsoft Office para Mac, puede utilizar aplicaciones de Office 2004 para abrir y guardar archivos en los formatos XML abiertos que se introdujeron en 2007 Microsoft Office system para Windows y en Microsoft Office 2008 para Mac.

Nota: para comprobar que su sistema operativo Mac satisface estos requisitos mínimos, haga clic en Acerca de este Mac en el menú de Apple.

Tiene que descargar los dos paquetes en su Mac.
  • Para descargar el paquete de actualización 11.5.0 de Microsoft Office 2004 para Mac, visite el siguiente sitio web del Centro de descarga de Microsoft:
    Contraer esta imagenAmpliar esta imagen
    Descargar
    Descargue ahora el paquete de la actualización 11.5.0 de Microsoft Office 2004 para Mac.
    Requisitos del sistema: Apple Mac OS X 10.2.8 (Jaguar) o una versión posterior de Mac OS
  • Para descargar el paquete de actualización del Convertidor de archivos con formatos XML abiertos para Mac, visite el siguiente sitio web del Centro de descarga de Microsoft:
    Contraer esta imagenAmpliar esta imagen
    Descargar
    Descargue ahora el paquete del Convertidor de archivos con formato XML abiertos para Mac.
    Importante Para abrir los documentos convertidos, debe tener instalado en su equipo Office 2004 11.4.0 o versiones posteriores u Office v. X 10.1.9 o posterior. Sin embargo, se recomienda instalar la actualización 11.5.1 de Office 2004 o una actualización posterior de Office 2004 para Mac.

    Requisitos del sistema: Mac OS X versión 10.4.9 (Tiger) o una versión posterior de Mac OS

Más información

Formatos de archivo admitidos

Los siguientes tipos de archivo con formato XML abierto se pueden abrir y guardar en Office 2004 para Mac cuando están instalados la actualización 11.5.0 de Office 2004 para Mac y el Convertidor de archivos con formatos XML abiertos:
  • Documento de Word 2008 (*.docx)
  • Documento habilitado para macros de Word 2008 (.docm)
  • Libro de Excel 2008 (.xlsx)
  • Libro binario de Excel 2008 (.xlsb)
  • Libro habilitado para macros de Excel 2008 (.xlsm)
  • Plantilla de Excel 2008 (.xltx)
  • Plantilla habilitada para macros de Excel 2008 (.xltm)
  • Complemento de Excel 2008 (.xlam)
  • Presentación de PowerPoint 2008 (.pptx)
  • Presentación habilitada para macros de PowerPoint 2008 (.pptm)
  • Plantilla de PowerPoint 2008 (.potx)
  • Plantilla habilitada para macros de PowerPoint 2008 (.potm)
  • Presentación con diapositivas de PowerPoint 2008 (.ppsx)
  • Presentación con diapositivas habilitada para macros de PowerPoint 2008 (.ppsm)

Archivos de compatibilidad del convertidor

Cuando están instalados la actualización 11.5.0 de Office 2004 para Mac y el Convertidor de archivos con formatos XML abiertos para Mac, Office 2004 para Mac reconoce los archivos de compatibilidad del convertidor en la carpeta /Library/Application Support/Microsoft/Office Converter Support. Se requieren los siguientes archivos de compatibilidad del convertidor:
  • MFConverter.bundle
  • MicrosoftChartPlugin.framework
  • MicrosoftComponentPlugin.framework
  • MicrosoftOffice.framework
  • MicrosoftOLE.framework
  • MicrosoftOLEAutomation.framework
  • MicrosoftOleo.framework
  • MSXML.framework
  • OfficeArt.framework
  • XML abierto para gráficos.app
  • XML abierto para Excel.app
  • XML abierto para Excel.framework
  • XML abierto para Word.app
  • XML abierto para Word.framework
  • pptfc.app
  • SmartArt.framework
Microsoft Office 2008 para Mac también utiliza los archivos de compatibilidad del convertidor. Por lo tanto, no debe quitar estos archivos del equipo si decide quitar Office 2004 o el Convertidor de XML abierto.

Existen actualizaciones para los archivos de compatibilidad del convertidor en Microsoft AutoUpdate. Para buscar actualizaciones para los archivos de compatibilidad del convertidor, abra la aplicación de convertidor de XML abierto. Después, en el menú Ayuda, haga clic en Buscar actualizaciones.

Importante No puede utilizar versiones beta del Convertidor de XML abierto con Office 2004 11.5.0 o versiones posteriores de Office 2004. Si tiene una versión beta del convertidor instalada en su equipo, descargue e instale la versión 1.0 o una posterior de dicha aplicación. Para ello, visite el siguiente sitio web de Microsoft:
http://www.microsoft.com/spain/mac/default.mspx

Fuentes

Si Microsoft Office 2004 para Mac está instalado en su equipo, las siguientes fuentes se instalan en la carpeta /Library/Fonts/Microsoft o en la carpeta /User/nombre de usuario/Library/Fonts/Microsoft al instalar el Convertidor de archivos con formatos XML abiertos para Mac:
  • Cambria
  • Calibri
  • Consolas
  • Constantia
  • Corbel
  • Candara
Estas fuentes mejoran la compatibilidad y fidelidad de los documentos cuando abre documentos que se crearon en 2007 Microsoft Office system para Windows y Microsoft Office 2008 para Mac.

Problemas conocidos de trabajar con formatos de archivo XML abierto en Word 2004

Puede que se encuentre con los siguientes problemas al utilizar Word 2004 para trabajar con un documento de Word que tiene un formato XML abierto:
  • No se conservan los objetos del Editor de ecuaciones de Word 2007.
  • Los nuevos diseños y formatos de documentos que están disponibles en Word 2008 para Mac o Word 2007 para Windows no se muestran correctamente en los archivos convertidos.
  • Los objetos HTML, como cuadros de lista y cuadros de texto, se truncan en los archivos convertidos.
  • No se pueden convertir las plantillas de Word 2008 (.dotx) y plantillas habilitadas para macros (.dotm) de Word 2008.
  • Los documentos protegidos mediante contraseña o con Information Rights Management (IRM) no se pueden convertir.
  • Las viñetas de imagen se podrían convertir en viñetas estándar.
  • Los campos de bibliografía y cita se convierten en texto y no se actualizan automáticamente en los archivos convertidos.
  • Puede que los colores de las marcas de revisión del Control de cambios no se conserven.
  • El contenido que se ha movido con Control de cambios activado se convierte en inserciones y eliminaciones.
  • Las imágenes que se han vuelto a colorear recuperan el color original.
  • Los estilos de línea de la imagen vuelven al estilo de línea original.
  • Las anotaciones manuscritas digitales se convierten en imágenes.
  • Los gráficos normales y SmartArt se convierten en imágenes.
  • No se conservan las marcas de agua que contienen fuentes Hiragana.
  • La sustitución de las fuentes se produce cuando el texto horizontal que utiliza la fuente Meiryo se cambia a texto vertical en un archivo convertido.
  • Las advertencias y los errores relacionados con la conversión de formato XML abierto siempre aparecen en inglés.
  • No puede abrir ni editar los objetos que se hayan creado con el Editor de ecuaciones en los archivos convertidos.
  • Los documentos con formato XML abierto guardados en Word 2004 no conservan los estilos de formato rápido cuando se abren en Word 2007.
  • No puede guardar varios documentos con formato XML abierto al mismo tiempo en Word 2004.
  • El contenido del documento no se muestra correctamente porque este puede incluir un gráfico no compatible. Los documentos con formato XML abierto que se guardaron en Word 2004 se guardan en modo de compatibilidad. Por lo tanto, el contenido creado en Word 2007 para Windows o Word 2008 para Mac podría no aparecer o no comportarse como se esperaba cuando abre el documento en esas aplicaciones. Para restaurar el contenido, abra el documento en Word 2008, haga doble clic en el gráfico para editarlo y, a continuación, cuando se le pida, seleccione el gráfico. Tras la conversión, cambie de nuevo a Word y vuelva a guardar el documento.
  • Si edita un gráfico SmartArt en Word 2004, su fondo podría volverse negro.
  • Los gráficos SmartArt en línea se convierten inesperadamente en imágenes cuando se utiliza Word 2004 para guardar un documento con formato XML abierto.
  • Las presentaciones de PowerPoint 2007, los gráficos y las hojas de Excel 2007 y los gráficos y las hojas de Excel 2008 incrustados en documentos con formato XML abierto no se pueden editar en Word 2004.
  • La opción Enviar a correo del menú Archivo de Word 2004 envía documentos con el formato de documento de Word (.doc). Esto se produce incluso si el archivo que va a enviar tiene el formato XML abierto.
  • Cuando abre un documento con formato XML abierto, el indicador de progreso de Word 2004 no proporciona una medida precisa del progreso.
  • Si guarda un documento con formato XML abierto que no contiene una macro en el formato de documento habilitado para macros de Word 2008 (.docm), aparece un mensaje de error de "Archivo no encontrado". Sin embargo, puede pasar por alto este mensaje de forma segura.
  • Tenga en cuenta la siguiente situación:
    1. Abre un documento de Microsoft Office Word que utiliza la extensión de nombre de archivo .docm.
    2. Este documento de Office Word no contiene una macro o código de Visual Basic.
    3. Abre el Editor de Visual Basic mediante el submenú Macro del menú Herramientas.
    En esta situación, el Editor de Visual Basic se abrirá un proyecto disponible para el documento de Office Word.

    Para resolver este problema, guarde el documento en formato de documento de Word (.docx), cierre el documento y ábralo de nuevo y, a continuación, abra el Editor de Visual Basic.
  • Tenga en cuenta la siguiente situación:
    1. Los usuarios de Mac OS X 10.5 (Leopard) abren un documento con formato XML abierto.
    2. Este documento se almacena en un volumen de red.
    3. Los usuarios se conectan al volumen de red mediante el protocolo SMB.
    En esta situación, el documento se abre como de sólo lectura en Word 2004.

Problemas conocidos de trabajar con formatos de archivo XML abierto en Excel 2004

Puede que se encuentre con los siguientes problemas al utilizar Excel 2004 para trabajar con un libro de Excel que tiene el formato XML abierto:
  • Los libros protegidos mediante contraseña o con Information Rights Management (IRM) no se pueden convertir.
  • Los datos que sobrepasan la fila 65.526 o la columna 256 no se conservan. Las fórmulas que hacen referencia a datos en esta región devuelven el valor de error "#REF!".
  • Varias reglas de formato condicional en una celda no se conservan. Excel detiene la evaluación después de que se evalúa y muestra la primera condición.
  • Las nuevas funciones de Excel 2008 no se conservan. Estas funciones devuelven el valor de error #NAME? en lugar de los resultados calculados.
  • Las fórmulas con más de 29 argumentos definidos por el usuario no se conservan. Estas fórmulas pasan a tener el valor de error "#VALUE!".
  • Los controles ActiveX no inicializados no se conservan.
  • Las fórmulas que contienen referencias a tablas de otros libros no se conservan. Estas referencias pasan a tener el valor de error "#REF!".
  • Las fórmulas que contienen más de 30 argumentos en una celda no se conservan. Estas fórmulas pasan a tener el valor de error "#VALUE!".
  • Los tipos de formato condicional en un rango no adyacente no se conservan.
  • Los informes de tabla dinámica con más de 8.000 elementos no se pueden convertir.
  • Las fórmulas que superan el límite de longitud interna (1.800 caracteres) no se conservan. Estas fórmulas pasan a tener el valor de error "#VALUE!".
  • Las fórmulas que superan el límite de nivel de anidamiento de 7 niveles no se conservan. Estas fórmulas pasan a tener el valor de error "#VALUE!".
  • Las fechas de los formatos de calendario no admitidos pasan a tener inesperadamente el formato de calendario gregoriano.
  • Los formatos de celda única que superan el límite interno (4.050 caracteres) no se conservan.
  • El formato condicional para la opción Aplicar formato a toda la fila no se conserva.
  • Las fórmulas de validación de fecha que tienen más de 255 caracteres no se conservan.
  • Las celdas con más de tres formatos condicionales solo muestran las tres primeras condiciones.
  • Los efectos de Excel 2008 que se aplican a los objetos no se conservan.
  • Los formatos de fuente única que exceden los límites internos no se conservan.
  • Las fórmulas que contienen más de 40 operandos no se conservan. Estas fórmulas pasan a tener el valor de error "#VALUE!".
  • Los siguientes filtros de datos no se conservan:
    • personalizado
    • basado en iconos
    • basado en color
    • grupo de fechas
    • diez mejores
    • color de la fuente
    • basado en barra de datos
  • No se conservan más de dos criterios de clasificación.
  • No se conserva la configuración específica de Windows para la publicación web automatizada.
  • No se conserva más de un filtro en una ordenación.
  • Los gráficos SmartArt se convierten en imágenes.
  • Los documentos de Word 2008, los libros de Excel 2008 y las presentaciones de PowerPoint 2008 vinculados o incrustados no se pueden abrir ni editar desde archivos convertidos.
  • No puede guardar varios libros con formato XML abierto al mismo tiempo en Excel 2004.

Problemas conocidos de trabajar con formatos de archivo XML abierto en PowerPoint 2004

Puede que se encuentre con los siguientes problemas al utilizar PowerPoint 2004 para trabajar con una presentación de PowerPoint que tiene un formato XML abierto:
  • Las presentaciones protegidas mediante contraseña o con Information Rights Management (IRM) no se pueden convertir.
  • Los subrayados dobles se convierten en subrayados sencillos.
  • La configuración de espaciado de caracteres personalizada no se conserva.
  • La configuración de mosaico no se conserva en las presentaciones convertidas si una imagen en mosaico se ha utilizado como fondo de diapositiva.
  • Las presentaciones de PowerPoint que contienen objetos con efectos 3D pueden tardar mucho tiempo en convertirse.
  • Las fechas apiladas en japonés no se muestran correctamente en los archivos convertidos.
  • Los gráficos SmartArt se convierten en imágenes.
  • Las listas con viñetas que tienen más de cinco niveles de profundidad se convierten en imágenes.
  • El contenido que se convierte en imágenes contiene fuentes sustitutorias si su equipo no tiene instaladas las fuentes de la presentación original.
  • Las sombras suaves se convierten en sombras fuertes.
  • Las nuevas diapositivas que se agregan a un archivo convertido tienen un diseño en blanco en lugar de un diseño de lista con viñetas.
  • No puede guardar varias presentaciones con formato XML abierto al mismo tiempo en PowerPoint 2004.
  • Los documentos de Word 2008, los libros de Excel 2008 y las presentaciones de PowerPoint 2008 incrustados no se pueden abrir ni editar desde archivos convertidos.
  • Al convertir plantillas de PowerPoint 2008 (.potx) y plantillas habilitadas para macros de PowerPoint 2008 (.potm), el cuadro de diálogo Guardar como no se abre cuando quiere guardar un archivo. Sin embargo, puede hacer clic en la opción Guardar como del menú Archivo para abrir el cuadro de diálogo Guardar como.
  • Los gráficos que se crean en PowerPoint 2007 para Windows o PowerPoint 2008 para Mac podrían no aparecer o no comportarse como se espera si guarda una presentación PowerPoint 2004 y luego abre el documento en PowerPoint 2007 o PowerPoint 2008. Para restaurar el contenido, abra el documento en PowerPoint 2008, haga doble clic en el gráfico para editarlo y, cuando se le pida, elija convertir el gráfico. Tras la conversión, cambie de nuevo a PowerPoint y vuelva a guardar el documento.
  • Los gráficos que se crearon en PowerPoint 2007 para Windows o en PowerPoint 2008 para Mac aparecerán como imágenes cuando se vean en PowerPoint 2004.
  • Las presentaciones habilitadas para macros no se pueden guardar en un formato de archivo no habilitado para macros en PowerPoint 2004. Además, este problema se produce incluso si quita todas las macros de la presentación.
  • PowerPoint 2004 podría agregar varias extensiones de nombre de archivo al nombre de archivo. Por ejemplo, el nombre de archivo puede parecerse a "miarchivo.pptx.pptm". Este problema se produce cuando abre una presentación que utiliza un formato no habilitado para macros, agrega una macro a la presentación y, luego, guarda la presentación en un formato habilitado para macros. Para solucionar este problema, elimine la extensión de nombre de archivo habilitado para macros del nombre de archivo en el cuadro de diálogo Guardar como antes de guardar el archivo.
  • Si PowerPoint 2004 deja de responder al convertir una presentación con formato XML abierto, debe reiniciar el equipo o usar la utilidad Monitor de actividad de la carpeta /Applications/Utilities para cerrar el proceso Pptfc.app antes de abrir o guardar de nuevo presentaciones en formato XML abierto.

Más información

Tema relacionado con las actualizaciones más recientes que puede instalar

Haga clic en los siguientes vínculos para buscar más opciones si no puede solucionar el problema con la información de este artículo: Los productos de terceros que analiza este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, con respecto al rendimiento o la confiabilidad de estos productos.

Propiedades

Id. de artículo: 953823 - Última revisión: miércoles, 7 de mayo de 2014 - Versión: 13.0
La información de este artículo se refiere a:
  • Microsoft Office 2004 for Mac Professional Edition
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office 2004 for Mac Student and Teacher Edition
  • Microsoft Entourage 2004 for Mac
  • Microsoft Excel 2004 for Mac
  • Microsoft PowerPoint 2004 for Mac
  • Microsoft Word 2004 for Mac
Palabras clave: 
dftsdahomeportal kbexpertisebeginner kbinfo KB953823

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com