Tietoja avoimessa XML-muodossa olevien tiedostojen käsittelemisestä Microsoft Office 2004 for Macissa

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 953823 - Näytä tuotteet, joita tämä artikkeli koskee.
Laajenna kaikki | Kutista kaikki

Tällä sivulla

JOHDANTO

Tärkeää: Office 2004 for Macin tuki on päättynyt, eikä Microsoft toimita sille enää ohjattua tukea eikä päivityksiä. Suosittelemme päivitystä Office 2011 for Maciin, jotta saat käyttöösi tuetun Office-version. Lisätietoja Office 2004 for Macin tuen päättymisestä on Microsoft Support Lifecycle -sivustossa.


Jos olet asentanut Microsoft Office 2004 for Mac 11.5.0 -päivityksen ja Microsoft Office Open XML File Format Converter for Macin, voit avata ja tallentaa Windowsin 2007 Microsoft Office systemin ja Microsoft Office 2008 for Macin avoimessa XML-muodossa olevia tiedostoja Office 2004 -sovelluksissa.

Huomautus Voit varmistaa, että Mac-käyttöjärjestelmä on näiden vähimmäisvaatimusten mukainen, valitsemalla OmenavalikostaTietoja tästä Macista.

Mac-tietokoneeseen on ladattava seuraavat kaksi pakettia.
  • Voit ladata Microsoft Office 2004 for Mac 11.5.0 -päivityspaketin käymällä seuraavassa Microsoft Download Center -sivustossa:
    Kutista tämä kuvaLaajenna tämä kuva
    Lataa
    Lataa Microsoft Office 2004 for Mac 11.5.0 -päivityksen paketti nyt.
    Järjestelmävaatimus: Apple Mac OS X 10.2.8 (Jaguar) tai uudempi Mac OS -versio
  • Voit ladata Open XML File Format Converter for Mac -päivityspaketin käymällä seuraavassa Microsoft Download Center -verkkosivustossa:
    Kutista tämä kuvaLaajenna tämä kuva
    Lataa
    Lataa Open XML File Format Converter for Mac -paketti nyt.
    Tärkeää Muunnettujen asiakirjojen avaaminen edellyttää, että tietokoneeseen on asennettu Office 2004 11.4.0 tai uudempi tai Office v. X 10.1.9 tai uudempi. Microsoft kuitenkin suosittelee, että asennat Office 2004 for Macin Office 2004 11.5.1 -päivityksen tai uudemman.

    Järjestelmävaatimus: Mac OS X 10.4.9 (Tiger) tai uudempi Mac OS -versio

Enemmän tietoa

Tuetut tiedostomuodot

Seuraavia avoimen XML-muodon tiedostotyyppejä voidaan avata ja tallentaa Office 2004 for Macissa, kun Office 2004 for Mac 11.5.0 -päivitys ja Open XML File Format Converter for Mac on asennettu:
  • Word 2008 -asiakirja (*.docx)
  • Makroja käyttävä Word 2008 -asiakirja (.docm)
  • Excel 2008 -työkirja (.xlsx)
  • Excel 2008 -työkirja (binaarinen) (.xlsb)
  • Excel 2008 -työkirja (makrot käytössä) (.xlsm)
  • Excel 2008 -malli (.xltx)
  • Excel 2008 -malli (makrot käytössä) (.xltm)
  • Excel 2008 -apuohjelma (.xlam)
  • PowerPoint 2008 -esitys (.pptx)
  • PowerPoint 2008 -esitys (makrot käytössä) (.pptm)
  • PowerPoint 2008 -malli (.potx)
  • PowerPoint 2008 -malli (makrot käytössä) (.potm)
  • PowerPoint 2008 -diaesitys (.ppsx)
  • PowerPoint 2008 -diaesitys (makrot käytössä) (.ppsm)

Muuntimen tukitiedostot

Kun Office 2004 for Mac 11.5.0 -päivitys ja Open XML File Format Converter for Mac ovat asennettuina, Office 2004 for Mac tunnistaa /Library/Application Support/Microsoft/Office Converter Support -kansiossa olevat muuntimen tukitiedostot. Seuraavat muuntimen tukitiedostot vaaditaan:
  • MFConverter.bundle
  • MicrosoftChartPlugin.framework
  • MicrosoftComponentPlugin.framework
  • MicrosoftOffice.framework
  • MicrosoftOLE.framework
  • MicrosoftOLEAutomation.framework
  • MicrosoftOleo.framework
  • MSXML.framework
  • OfficeArt.framework
  • Open XML for Charts.app
  • Open XML for Excel.app
  • Open XML for Excel.framework
  • Open XML for Word.app
  • Open XML for Word.framework
  • Pptfc.app
  • SmartArt.framework
Myös Microsoft Office 2008 for Mac käyttää muuntimen tukitiedostoja. Tämän vuoksi näitä tiedostoja ei pidä poistaa tietokoneesta, jos Office 2004 tai Open XML Converter poistetaan.

Muuntimen tukitiedostojen päivitykset ovat saatavana Microsoft AutoUpdaten avulla. Voit tarkistaa muuntimen tukitiedostojen päivitykset avaamalla Open XML Converter -sovelluksen. Valitse sitten Ohje-valikosta Tarkista päivitykset.

Tärkeää Open XML Converterin beetaversioita ei voi käyttää Office 2004 11.5.0:n tai Office 2004:n uudempien versioiden kanssa. Jos tietokoneessa on asennettuna muuntimen beetaversio, lataa ja asenna Open XML Converterin versio 1.0 tai uudempi versio. Voit tehdä tämän käymällä seuraavassa Microsoftin verkkosivustossa:
http://www.microsoft.com/finland/mac/default.mspx

Fontit

Jos tietokoneessa on asennettuna Microsoft Office 2004 for Mac, seuraavat fontit asennetaan kansioon /Library/Fonts/Microsoft tai kansioon /User/käyttäjänimi/Library/Fonts/Microsoft, kun Open XML File Format Converter for Mac asennetaan:
  • Cambria
  • Calibri
  • Consolas
  • Constantia
  • Corbel
  • Candara
Nämä fontit parantavat asiakirjojen yhteensopivuutta ja näyttämistä tarkoitetulla tavalla, kun Windowsin 2007 Microsoft Office systemillä ja Microsoft Office 2008 for Macilla avatut asiakirjat avataan.

Tunnettuja ongelmia, joita voi ilmetä käsiteltäessä avoimessa XML-muodossa olevia tiedostoja Word 2004:ssä

Seuraavia ongelmia voi ilmetä, kun avoimessa XML-muodossa olevaa Word-asiakirjaa käsitellään Word 2004:n avulla:
  • Word 2007:n Kaava-objekteja ei säilytetä.
  • Word 2008 for Macissa tai Windowsin Word 2007:ssä käytettävissä olevat uudet asiakirjojen asettelut ja muotoilut eivät näy muunnetuissa tiedostoissa oikein.
  • HTML-objektit, kuten luetteloruudut tai tekstikehykset, katkaistaan muunnetuissa tiedostoissa.
  • Word 2008 -malleja (.dotx) ja makroja käyttäviä Word 2008 -malleja (.dotm) ei voi muuntaa.
  • Salasanalla tai sisältöoikeuksien hallinnan avulla suojattuja asiakirjoja ei voi muuntaa.
  • Kuvaluettelomerkit saatetaan muuntaa tavallisiksi luettelomerkeiksi.
  • Lähdeluettelo- ja lainauskentät muunnetaan tekstiksi, eikä niitä päivitetä muunnetuissa tiedostoissa automaattisesti.
  • Muutosten jäljityksen muokkausmerkintävärejä ei ehkä säilytetä.
  • Muutosten jäljityksen ollessa käytössä siirretty sisältö muunnetaan lisäyksiksi ja poistoiksi.
  • Kuvat, joiden värejä on muutettu, muunnetaan takaisin käyttämään alkuperäisiä värejä.
  • Kuvaviivatyylit muunnetaan alkuperäisiksi viivatyyleiksi.
  • Digitaalinen käsinkirjoitus muunnetaan kuviksi.
  • Kaaviot ja SmartArt-grafiikat muunnetaan kuviksi.
  • Hiragana-fontteja sisältäviä vesileimoja ei säilytetä.
  • Fontti korvataan, kun Meiryo-fonttia käyttävä vaakasuuntainen teksti muutetaan pystysuuntaiseksi tekstiksi muunnetussa tiedostossa.
  • Avoimen XML-muodon muuntamiseen liittyvät varoitukset ja virheet näkyvät aina englanninkielisinä.
  • Muunnetuissa tiedostoissa olevia, Kaavaeditorilla luotuja objekteja ei voi avata tai muokata.
  • Word 2004:ssä tallennetut avointa XML-muotoa käyttävät asiakirjat eivät säilytä pikamuotoilutyylejä, kun ne avataan Word 2007:ssä.
  • Useita avointa XML-muotoa käyttäviä asiakirjoja ei voi tallentaa samanaikaisesti Word 2004:ssä.
  • Asiakirjojen sisältöä ei näytetä oikein, koska sisällössä saattaa olla epäyhteensopiva kaavio. Word 2004:ssä tallennetut avointa XML-muotoa käyttävät asiakirjat tallennetaan yhteensopivuustilassa. Siksi Windowsin Word 2007:ssä tai Word 2008 for Macissa luotu sisältö ei välttämättä näy tai toimi odotetulla tavalla, kun asiakirja avataan kyseisissä sovelluksissa. Voit palauttaa sisällön avaamalla asiakirjan Word 2008:ssa ja muokkaamalla kaaviota kaksoisnapsauttamalla sitä. Kun näyttöön tulee kehote, valitse kaavio. Vaihda takaisin Wordiin muuntamisen jälkeen ja tallenna sitten asiakirja uudelleen.
  • Jos muokkaat SmartArt-grafiikkaa Word 2004:ssä, joidenkin SmartArt-grafiikoiden tausta saattaa muuttua mustaksi.
  • Tekstiin sitoutuvat SmartArt-grafiikat muunnetaan odottamatta kuviksi, kun asiakirja tallennetaan Word 2004:n avulla avoimeen XML-muotoon.
  • Avoimessa XML-muodossa olevissa asiakirjoissa olevia upotettuja PowerPoint 2007 -esityksiä, Excel 2007 -kaaviota ja -taulukoita sekä Excel 2008 -kaavioita ja taulukoita ei voi muokata Word 2004:ssä.
  • Word 2004:n Tiedosto-valikon Lähetä sähköpostin vastaanottajalle -vaihtoehto lähettää asiakirjat Word-asiakirja (.doc) -muodossa. Tämä tapahtuu, vaikka lähetettävä tiedosto olisi avoimessa XML-muodossa.
  • Kun avaat avoimessa XML-muodossa olevan asiakirjan, Word 2004:n edistymisen ilmaisin ei näytä edistymistä oikein.
  • Jos tallennat avoimessa XML-muodossa olevan asiakirjan, joka ei sisällä makroa, makroja käyttäväksi Word 2008 -asiakirjaksi (.docm), näyttöön tulee virhesanoma siitä, että tiedostoa ei löydy. Voit kuitenkin ohittaa tämän sanoman turvallisesti.
  • Oletetaan seuraava tilanne:
    1. Avaat Microsoft Office Word -asiakirjan, jonka tiedostotunniste on .docm.
    2. Office Word -asiakirja ei sisällä makroa eikä Visual Basic -koodia.
    3. Avaat Visual Basic Editorin Työkalut-valikon Makro-alivalikosta.
    Tässä tilanteessa Visual Basic Editor avautuu niin, että siinä ei ole Office Word -asiakirjalle käytettävää projektia.

    Voit ratkaista tämän ongelman tallentamalla asiakirjan Word-asiakirja (.docx) -muodossa, sulkemalla asiakirjan, avaamalla asiakirjan uudelleen ja avaamalla sitten Visual Basic Editorin.
  • Oletetaan seuraava tilanne:
    1. Mac OS X 10.5 (Leopard) -käyttäjä avaa avointa XML-muotoa käyttävän asiakirjan.
    2. Tämä asiakirja on tallennettu verkkoasemaan.
    3. Käyttäjä muodostaa yhteyden verkkoasemaan SMB-protokollan avulla.
    Tässä tilanteessa asiakirja avataan Word 2004:ssä vain luku -tilassa.

Tunnettuja ongelmia, joita voi ilmetä käsiteltäessä avoimessa XML-muodossa olevia tiedostoja Excel 2004:ssä

Seuraavia ongelmia voi ilmetä, kun avoimessa XML-muodossa olevaa Excel-työkirjaa käsitellään Excel 2004:n avulla:
  • Salasanalla tai sisältöoikeuksien hallinnan avulla suojattuja työkirjoja ei voi muuntaa.
  • Rivin 65 526 tai sarakkeen 256 jälkeisiä tietoja ei säilytetä. Kyseisessä alueessa oleviin tietoihin viittaava kaava palauttaa "#VIITTAUS!"-virhearvon.
  • Solun useita ehdollisia muotoilusääntöjä ei säilytetä. Excel lopettaa käsittelyn sen jälkeen, kun ensimmäinen ehto on käsitelty ja näytetty.
  • Excel 2008:n uusia funktioita ei säilytetä. Kyseiset funktiot palauttavat #NIMI?-virhearvon laskettujen tulosten sijaan.
  • Yli 29 käyttäjän määrittämää argumenttia sisältäviä kaavoja ei säilytetä. Kyseiset kaavat muunnetaan "#ARVO!"-virhearvoksi.
  • Alustamattomia ActiveX-ohjausobjekteja ei säilytetä.
  • Muissa työkirjoissa oleviin taulukkoihin viittauksia sisältäviä kaavoja ei säilytetä. Kyseiset viittaukset muunnetaan "#VIITTAUS!"-virhearvoksi.
  • Yli 30 argumenttia solussa sisältäviä kaavoja ei säilytetä. Kyseiset kaavat muunnetaan "#ARVO!"-virhearvoksi.
  • Ei-peräkkäisessä alueessa olevia ehdollisia muotoilutyyppejä ei säilytetä.
  • Yli 8 000 kohdetta sisältäviä pivot-taulukkoraportteja ei voi muuntaa.
  • Sisäisen pituusrajan (1 800 merkkiä) ylittäviä kaavoja ei säilytetä. Kyseiset kaavat muunnetaan "#ARVO!"-virhearvoksi.
  • Upotustasorajan (7 tasoa) ylittäviä kaavoja ei säilytetä. Kyseiset kaavat muunnetaan "#ARVO!"-virhearvoksi.
  • Ei-tuettujen kalenterimuotojen päivämäärät muunnetaan odottamatta gregoriaanisen kalenterimuodon mukaiseksi.
  • Sisäisen rajan (4 050 merkkiä) ylittäviä yksilöiviä solumuotoiluja ei säilytetä.
  • Muotoile koko rivi -asetuksen ehdollista muotoilua ei säilytetä.
  • Yli 255 merkkiä sisältäviä päivämäärien tarkistuskaavoja ei säilytetä.
  • Solut, joissa on yli kolme ehdollista muotoilua, näyttävät vain ensimmäiset kolme ehdollista muotoilua.
  • Objekteissa käytettäviä Excel 2008 -tehosteita ei säilytetä.
  • Sisäiset rajat ylittäviä yksilöiviä fonttimuotoiluja ei säilytetä.
  • Yli 40 operandia sisältäviä kaavoja ei säilytetä. Kyseiset kaavat muunnetaan "#ARVO!"-virhearvoksi.
  • Seuraavia tietosuodattimia ei säilytetä:
    • mukautetut
    • kuvakepohjaiset
    • väripohjaiset
    • päivämääräryhmä
    • suosituimmat 10
    • kirjasinväri
    • tietopalkkipohjaiset
  • Useampaa kuin kahta lajitteluperustetta ei säilytetä.
  • Automaattisen WWW-julkaisun Windows-asetuksia ei säilytetä.
  • Lajittelussa käytettävää useampaa kuin yhtä suodatinta ei säilytetä.
  • SmartArt-grafiikat muunnetaan kuviksi.
  • Linkitettyjä tai upotettuja Word 2008 -asiakirjoja, Excel 2008 -työkirjoja ja PowerPoint 2008 -esityksiä ei voi avata tai muokata muunnetuista tiedostoista.
  • Useita avointa XML-muotoa käyttäviä työkirjoja ei voi tallentaa samanaikaisesti Word 2004:ssä.

Tunnettuja ongelmia, joita voi ilmetä käsiteltäessä avoimessa XML-muodossa olevia tiedostoja PowerPoint 2004:ssä

Seuraavia ongelmia voi ilmetä, kun avoimessa XML-muodossa olevaa PowerPoint-esitystä käsitellään PowerPoint 2004:n avulla:
  • Salasanalla tai sisältöoikeuksien hallinnan avulla suojattuja esityksiä ei voi muuntaa.
  • Kaksoisalleviivaukset muunnetaan yksinkertaisiksi alleviivauksiksi.
  • Mukautettuja merkkiväliasetuksia ei säilytetä.
  • Vierekkäisyysasetuksia ei säilytetä muunnetuissa esityksissä, jos vierekkäin aseteltua kuvaa käytettiin dian taustana.
  • Kolmiulotteisia tehosteita käyttäviä objekteja sisältävien PowerPoint-esitysten muuntaminen saattaa kestää kauan.
  • Pinottuja japanilaisia päivämääriä ei näytetä muunnetuissa tiedostoissa oikein.
  • SmartArt-grafiikat muunnetaan kuviksi.
  • Yli viisi tasoa syvät luettelomerkkejä käyttävät luettelot muunnetaan kuviksi.
  • Kuviksi muunnettu sisältö sisältää korvattuja fontteja, jos tietokoneessa ei ole asennettuna alkuperäisen esityksen käyttämiä fontteja.
  • Pehmeät varjostukset muunnetaan koviksi varjostuksiksi.
  • Muunnettuun tiedostoon lisätyt uudet diat ovat tyhjässä asettelussa luettelomerkkejä käyttävän asettelun sijaan.
  • Useita avointa XML-muotoa käyttäviä esityksiä ei voi tallentaa samanaikaisesti PowerPoint 2004:ssä.
  • Upotettuja Word 2008 -asiakirjoja, Excel 2008 -työkirjoja ja PowerPoint 2008 -esityksiä ei voi avata tai muokata muunnetuista tiedostoista.
  • Kun PowerPoint 2008 -mallit (.potx) ja PowerPoint 2008 -mallit (makrot käytössä) (.potm) muunnetaan, Tallenna nimellä -valintaikkuna ei avaudu, kun tiedosto tallennetaan. Voit kuitenkin avata Tallenna nimellä -valintaikkunan valitsemalla Tiedosto-valikosta Tallenna nimellä.
  • Windowsin PowerPoint 2007:ssä tai PowerPoint 2008 for Macissa luodut kaaviot eivät välttämättä näy tai toimi odotetulla tavalla, jos esitys tallennetaan PowerPoint 2004:ssä ja tiedosto avataan sitten PowerPoint 2007:ssä tai PowerPoint 2008:ssa. Voit palauttaa sisällön avaamalla tiedoston PowerPoint 2008:ssa ja muokkaamalla kaaviota kaksoisnapsauttamalla sitä. Kun näyttöön tulee kehote, valitse kaavion muokkaaminen. Vaihda takaisin PowerPointiin muuntamisen jälkeen ja tallenna sitten asiakirja uudelleen.
  • Windowsin PowerPoint 2007:ssä tai PowerPoint 2008 for Macissa luodut kaaviot näkyvät kuvina, kun niitä tarkastellaan PowerPoint 2004:ssä.
  • Makroja käyttäviä esityksiä ei voi tallentaa PowerPoint 2004:ssä tiedostomuotoon, joka ei käytä makroja. Tämä ongelma ilmenee, vaikka kaikki esityksen makrot poistettaisiin.
  • PowerPoint 2004 saattaa lisätä useita tiedostotunnisteita tiedostonimeen. Tiedoston nimi saattaa esimerkiksi muistuttaa nimeä "Omatiedosto.pptx.pptm." Tämä ongelma ilmenee, kun avataan esitys, joka ei käytä makroja tukevaa muotoa, esitykseen lisätään makro ja esitys tallennetaan sitten makroja käyttävässä muodossa. Voit ratkaista tämän ongelman poistamalla ennen tiedoston tallentamista Tallenna nimellä -valintaikkunassa tiedostonimen tiedostotunnisteen, joka viittaa makroja käyttämättömään tiedostoon.
  • Jos PowerPoint 2004 lopettaa vastaamisen muuntaessaan avointa XML-muotoa käyttävän esityksen, tietokone on käynnistettävä uudelleen tai Pptfc.app-prosessi on suljettava käyttämällä /Applications/Utilities-kansion Activity Monitor -apuohjelmaa, ennen kuin avointa XML-muotoa käyttäviä esityksiä voidaan jälleen avata tai tallentaa.

Enemmän tietoa

Asennettaviin uusimpiin päivityksiin liittyvä ohjeaihe

Napsauttamalla seuraavia linkkejä voit löytää lisää vaihtoehtoja, jos tämän artikkelin tiedot eivät ratkaise ongelmaasi: Tässä artikkelissa käsitellyt muiden valmistajien tuotteet ovat Microsoftista riippumattomien yritysten valmistamia. Microsoft ei anna näiden tuotteiden suorituskykyä tai luotettavuutta koskevaa takuuta.

Ominaisuudet

Artikkelin tunnus: 953823 - Viimeisin tarkistus: 7. toukokuuta 2014 - Versio: 2.0
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Office 2004 for Mac Professional Edition
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office 2004 for Mac Student and Teacher Edition
  • Microsoft Entourage 2004 for Mac
  • Microsoft Excel 2004 for Mac
  • Microsoft PowerPoint 2004 for Mac
  • Microsoft Word 2004 for Mac
Hakusanat: 
dftsdahomeportal kbexpertisebeginner kbinfo KB953823

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com