Informazioni su come lavorare con file in formato Open XML in Microsoft Office 2004 per Mac

Traduzione articoli Traduzione articoli
Identificativo articolo: 953823 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

INTRODUZIONE

Importante: Office 2004 per Mac ha raggiunto la fine del ciclo di vita del supporto e non riceve pi¨ supporto assistito o aggiornamenti da Microsoft. Si consiglia di eseguire l'aggiornamento a Office 2011 per Mac per disporre di una versione supportata di Office. Per ulteriori informazioni relative alla fine del supporto di Office 2004 per Mac, visitare il sito sul ciclo di vita del supporto Microsoft.


Se Ŕ stato installato l'aggiornamento di Microsoft Office 2004 per Mac 11.5.0 e del convertitore di file in formato Open XML per Mac di Microsoft Office, Ŕ possibile utilizzare le applicazioni di Office 2004 per aprire e salvare i file nel formato Open XML introdotto in Office 2007 per Windows e in Microsoft Office 2008 per Mac.

Nota Per verificare se il sistema operativo Mac soddisfa i requisiti minimi, fare clic su Informazioni su Mac nel menu Apple.

╚ necessario scaricare i seguenti due pacchetti sul Mac.
  • Per scaricare il pacchetto di aggiornamento di Microsoft Office 2004 per Mac 11.5.0, visitare l'area Download Microsoft al seguente indirizzo:
    Riduci l'immagineEspandi l'immagine
    Download
    Download dell'aggiornamento Microsoft Office 2004 per Mac 11.5.0.
    Requisiti di sistema: Apple Mac OS X 10.2.8 (Jaguar) o una versione successiva di Mac OS
  • Per scaricare il pacchetto di aggiornamento relativo al convertitore di file in formato Open XML per Mac, visitare l'area Download Microsoft al seguente indirizzo:
    Riduci l'immagineEspandi l'immagine
    Download
    Download del programma di conversione del formato file Open XML per Mac.
    Importante Per aprire i documenti convertiti, Ŕ necessario che sul computer sia installato Office 2004 11.4.0 o versioni successivi oppure Office v. X 10.1.9 o versioni successive. Tuttavia, si consiglia di installare l'aggiornamento di Office 2004 11.5.1 o un aggiornamento successivo relativo a Office 2004 per Mac.

    Requisiti di sistema: Mac OS X versione 10.4.9 (Tiger) o una versione successiva di Mac OS

Informazioni

Formati di file supportati

I seguenti tipi di file in formato Open XML possono essere aperti e salvati in Office 2004 per Mac quando si installa l'aggiornamento Office 2004 per Mac 11.5.0 e il convertitore di formato file Open XML per Mac:
  • Documento di Word 2008 (.docx)
  • Documento con attivazione macro di Word 2008 (.docm)
  • Cartella di lavoro di Excel 2008 (.xlsx)
  • Cartella di lavoro binaria di Excel 2008 (.xlsb)
  • Cartella di lavoro con attivazione macro di Excel 2008 (.xlsm)
  • Modello di Excel 2008 (.xltx)
  • Modello con attivazione macro di Excel 2008 (.xltm)
  • Componente aggiuntivo di Excel 2008 (.xlam)
  • Presentazione standard di PowerPoint 2008 (.pptx)
  • Presentazione standard di PowerPoint 2008 con attivazione macro (.pptm)
  • Modello di PowerPoint 2008 (.potx)
  • Modello di PowerPoint 2008 con attivazione macro (.potm)
  • Solo presentazione di PowerPoint 2008 (.ppsx)
  • Solo presentazione di PowerPoint 2008 con attivazione macro (.ppsm)

File di supporto del convertitore

Quando sono installati sia l'aggiornamento Office 2004 per Mac 11.5.0 e il convertitore di formato file Open XML per Mac, Office 2004 per Mac riconosce i file di supporto del convertitore nella cartella /Library/Application Support/Microsoft/Office Converter Support. Sono necessari i seguenti file di supporto del convertitore:
  • MFConverter.bundle
  • MicrosoftChartPlugin.framework
  • MicrosoftComponentPlugin.framework
  • MicrosoftOffice.framework
  • MicrosoftOLE.framework
  • MicrosoftOLEAutomation.framework
  • MicrosoftOleo.framework
  • MSXML.framework
  • OfficeArt.framework
  • Open XML per Charts.app
  • Open XML per Excel.app
  • Open XML per Excel.framework
  • Open XML per Word.app
  • Open XML per Word.framework
  • pptfc.app
  • SmartArt.framework
Anche in Microsoft Office 2008 per Mac vengono utilizzati i file di supporto del convertitore. Di conseguenza, non rimuovere questi file dal computer se si decide di disinstallare Office 2004 o il convertitore Open XML.

Gli aggiornamenti per i file di supporto del convertitore sono disponibili tramite Microsoft AutoUpdate. Per verificare la disponibilitÓ di aggiornamenti dei file di supporto del convertitore, aprire l'applicazione. Scegliere Controlla aggiornamenti dal menu ?.

Importante Non Ŕ possibile utilizzare le versioni beta del convertitore Open XML con Office 2004 11.5.0 con versioni successive di Office 2004. Se sul computer Ŕ installata una versione beta del convertitore, scaricare e installare la versione 1.0 o una versione successiva del convertitore Open XML. A questo scopo, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/italy/products/mac/

Tipi di carattere

Se sul computer Ŕ installato Microsoft Office 2004 per Mac, i seguenti tipi di carattere vengono installati nella cartella /Library/Fonts/Microsoft folder o in quella /User/nome utente/Library/Fonts/Microsoft quando si installa il convertitore di formato file Open XML per Mac.
  • Cambria
  • Calibri
  • Consolas
  • Constantia
  • Corbel
  • Candara
Tali tipi di carattere migliorano la compatibilitÓ e la fedeltÓ dei documenti, quando vengono aperti documenti creati con il sistema Microsoft Office 2007 per Windows e Microsoft Office 2008 per Mac.

Problemi noti relativi all'utilizzo dei file in formato Open XML in Word 2004

╚ possibile riscontrare gli errori riportati di seguito quando si utilizza Word 2004 per lavorare a un documento di Word nel formato Open XML:
  • Gli oggetti Equation di Word 2007 non vengono mantenuti.
  • I layout e la formattazione dei nuovi documenti disponibili in Word 2008 per Mac o Word 2007 per Windows non vengono visualizzati correttamente come file convertiti.
  • Gli oggetti HTML, ad esempio le caselle di elenco e di testo, vengono troncati come file convertiti.
  • I modelli di Word 2008 (.dotx) e i modelli di Word 2008 con attivazione macro (.dotm) non possono essere convertiti.
  • I documenti protetti da password o da Information Rights Management (IRM) non possono essere convertiti.
  • I punti elenco immagine possono essere convertiti in punti elenco standard.
  • I campi relativi alla bibliografia e alle citazioni vengono convertiti in testo e non vengono aggiornati automaticamente in file convertiti.
  • I colori dei segni di revisione potrebbero non essere mantenuti.
  • I contenuti spostati con la funzione Rileva modifiche attivata, vengono convertiti in inserimenti ed eliminazioni.
  • Vengono ripristinati i colori originali delle immagini ricolorate.
  • Gli stili di linea dell'immagine vengono convertiti nello stile di linea originale.
  • Le annotazioni a penna digitale vengono convertite in immagini.
  • I grafici e gli elementi grafici SmartArt vengono convertiti in immagini.
  • Le filigrane contenenti i tipi di carattere Hiragana non vengono mantenute.
  • La sostituzione dei tipi di carattere si verifica quando un testo orizzontale che utilizza il tipo di carattere Meiryo viene modificato in testo verticale quando viene convertito.
  • Gli avvisi e gli errori relativi alla conversione del formato Open XML vengono sempre visualizzati in lingua inglese.
  • Non Ŕ possibile aprire o modificare oggetti creati tramite Equation Editor, presenti nei file convertiti.
  • I documenti in formato Open XML che sono salvati in Word 2004 non mantengono lo stile di formattazione veloce quando vengono aperti in Word 2007.
  • Non Ŕ possibile salvare pi¨ documenti in formato Open XML contemporaneamente in Word 2004.
  • Il contenuto dei documenti non viene visualizzato correttamente poichÚ potrebbe includere un grafico non compatibile. I documenti in formato Open XML vengono salvati in modalitÓ compatibilitÓ in Word 2004. Di conseguenza, i contenuti creati in Word 2007 per Windows o Word 2008 per Mac potrebbero non essere visualizzati o potrebbero comportarsi in modo imprevisto quando si apre il documento con queste applicazioni. Per ripristinare i contenuti, aprire il documento in Word 2008, fare doppio clic sul grafico per modificarli. Successivamente, quando viene richiesto, selezionare il grafico. Al termine della conversione, tornare a Word e salvare di nuovo il documento.
  • Se si modifica un grafico SmartArt in Word 2004, lo sfondo di alcuni grafici SmartArt potrebbe diventare nero.
  • I grafici SmartArt incorporati vengono convertiti in immagini in modo imprevisto quando si utilizza Word 2004 per salvare un documento nel formato Open XML.
  • Le presentazioni di PowerPoint 2007 incorporate, i grafici e i fogli di Excel 2007 e 2008 presenti nei documenti in formato Open XML non possono essere modificati in Word 2004.
  • L'opzione Invia a posta elettronica nel menu File di Word 2004 consente di inviare documenti nel formato Word (.doc). Ci˛ si verifica anche se il file che si sta inviando Ŕ in formato Open XML.
  • Quando si apre un documento in formato Open XML, l'indicatore dell'avanzamento in Word 2004 non fornisce una misurazione accurata di tale avanzamento.
  • Se si salva un documento in formato Open XML che non contiene una macro nel formato di documento di Word con attivazione macro (.docm), viene visualizzato il messaggio di errore "File non trovato". Tuttavia, tale messaggio pu˛ essere ignorato.
  • Considerare lo scenario seguente:
    1. Si apre un documento di Microsoft Office Word che utilizza l'estensione del nome file .docm.
    2. Tale documento di Office Word non contiene una macro o un codice di Visual Basic.
    3. Si apre Visual Basic Editor utilizzando il sottomenu Macro del menu Strumenti.
    In questo scenario, Visual Basic Editor viene aperto senza un progetto disponibile per il documento di Office Word.

    Per risolvere il problema, salvare il documento nel formato dei documenti di Word (.docx), chiudere e riaprire il documento, quindi aprire Visual Basic Editor.
  • Considerare lo scenario seguente:
    1. Gli utenti di Mac OS X 10.5 (Leopard) aprono un documento in formato Open XML.
    2. Questo documento Ŕ memorizzato su un volume di rete.
    3. Gli utenti si connettono al volume di rete utilizzando il protocollo SMB
    In questo scenario, il documento viene aperto in sola lettura in Word 2004.

Problemi noti relativi all'utilizzo dei file in formato Open XML in Excel 2004

╚ possibile riscontrare gli errori riportati di seguito quando si utilizza Excel 2004 per lavorare a una cartella di lavoro di Excel nel formato Open XML:
  • Le cartelle di lavoro protette da password o da Information Rights Management (IRM) non possono essere convertite.
  • Tutti i dati che si estendono oltre la riga 65.526 o la colonna 256 non vengono mantenuti. Tutte le formule che fanno riferimento ai dati di questa area restituiscono il valore di errore "#REF!".
  • Pi¨ regole di formattazione condizionale in una cella non vengono mantenute. Excel interrompe la valutazione dopo che la prima condizione viene valutata e visualizzata.
  • Le nuove funzionalitÓ di Excel 2008 non vengono mantenute. Queste funzionalitÓ restituiscono il valore di errore #NAME? anzichÚ i risultati calcolati.
  • Le formule con pi¨ di 29 argomenti definiti dall'utente non vengono mantenute. Tali formule vengono convertite nel valore di errore "#VALUE"!.
  • I controlli ActiveX non inizializzati non vengono mantenuti.
  • Le formule contenenti riferimenti a tabelle di altre cartelle di lavoro non vengono mantenute. Tali riferimenti vengono convertiti nel valore di errore "#REF!".
  • Le formule che contengono pi¨ di 30 argomenti in una cella non vengono mantenute. Tali formule vengono convertite nel valore di errore "#VALUE"!.
  • I tipi di formattazione condizionale di un intervallo non adiacente non vengono mantenuti.
  • I rapporti di tabella pivot con pi¨ di 8.000 elementi non possono essere convertiti.
  • Le formule che superano il limite di lunghezza interna (1.800 caratteri) non vengono mantenute. Tali formule vengono convertite nel valore di errore "#VALUE"!.
  • Le formule che superano il limite di livello di nidificazione pari a 7 livelli non vengono mantenute. Tali formule vengono convertite nel valore di errore "#VALUE"!.
  • Le date in formati di calendario non supportati vengono convertite nel formato del calendario gregoriano in modo imprevisto.
  • I formati di cella univoci che superano il limite interno (4.050 caratteri) non vengono mantenuti.
  • La formattazione condizionale per l'opzione Formatta riga intera non viene mantenuta.
  • Non vengono mantenute le formule di convalida della data con pi¨ di 255 caratteri.
  • Nelle celle con pi¨ di tre formati condizionali, vengono visualizzate soltanto le prime tre condizioni.
  • Gli effetti di Excel 2008 applicati agli oggetti non vengono mantenuti.
  • I formati di carattere univoci che eccedono i limiti interni non vengono mantenuti.
  • Le formule che contengono pi¨ di 40 operandi non vengono mantenute. Tali formule vengono convertite nel valore di errore "#VALUE"!.
  • I seguenti filtri per i dati non vengono mantenuti:
    • file personalizzato
    • basati sull'icona
    • basati sul colore
    • dati gruppo
    • primi 10
    • colore carattere
    • dati basati su barra
  • Pi¨ di due criteri di ordinamento non vengono mantenuti.
  • Le impostazioni di Windows specifiche per la pubblicazione automatica sul Web non vengono conservate.
  • Pi¨ di un filtro in un ordinamento non viene mantenuto.
  • Gli elementi grafici SmartArt vengono convertiti in immagini.
  • I documenti di Word 2008 collegati o incorporati, le cartelle di lavoro di Excel 2008 e le presentazioni di PowerPoint 2008 non possono essere aperte o modificate dai file convertiti.
  • Non Ŕ possibile salvare pi¨ cartelle di lavoro in formato Open XML contemporaneamente in Excel 2004.

Problemi noti relativi all'utilizzo dei file in formato Open XML in PowerPoint 2004

╚ possibile riscontrare gli errori riportati di seguito quando si utilizza PowerPoint 2004 per lavorare a una presentazione di PowerPoint nel formato Open XML:
  • Le presentazioni protette da password o da Information Rights Management (IRM) non possono essere convertite.
  • La doppia sottolineatura viene convertita in sottolineatura singola.
  • Le impostazioni personalizzate relative alla spaziatura tra caratteri non vengono mantenute.
  • Le impostazioni di affiancamento non vengono mantenute nelle presentazioni convertite nel caso in cui sia stata utilizzata un'immagine affiancata come sfondo della diapositiva.
  • Le presentazioni di PowerPoint che contengono oggetti con effetti 3D potrebbero richiedere un tempo di conversione maggiore.
  • Le date giapponesi in pila non sono non visualizzate correttamente nei file convertiti.
  • Gli elementi grafici SmartArt vengono convertiti in immagini.
  • Gli elenchi puntati con pi¨ di cinque livelli vengono convertiti in immagini.
  • I contenuti convertiti in immagini contengono tipi di carattere sostitutivi nel caso in cui sul computer non siano installati i tipi di carattere della presentazione originale.
  • Le ombreggiature sfumate vengono convertite in ombreggiature con sfumatura minore.
  • Le nuove diapositive che vengono aggiunte a un file convertito dispongono di un layout vuoto invece di quello a elenco puntato.
  • Non Ŕ possibile salvare pi¨ presentazioni in formato Open XML contemporaneamente in PowerPoint 2004.
  • I documenti di Word 2008 incorporati, le cartelle di lavoro di Excel 2008 e le presentazioni di PowerPoint 2008 non possono essere aperte o modificate dai file convertiti.
  • Quando i modelli di PowerPoint 2008 (.potx) e i modelli di PowerPoint 2008 con attivazione macro (.potm) vengono convertiti, non viene visualizzata la finestra di dialogo Salva con nome quando si salva un file. Tuttavia, Ŕ possibile selezionare l'opzione Salva con nome dal menu File per aprire la finestra di dialogo Salva con nome.
  • I grafici creati con PowerPoint 2007 per Windows o PowerPoint 2008 per Mac potrebbero non essere visualizzati o potrebbero comportarsi in modo imprevisto se si salva una presentazione di PowerPoint 2004 e si apre il documento in PowerPoint 2007 o in PowerPoint 2008. Per ripristinare il contenuto, aprire il documento in PowerPoint 2008, fare doppio clic sul grafico da modificare e quando viene richiesto selezionare l'opzione per convertire il grafico. Al termine della conversione, tornare a PowerPoint e salvare di nuovo il documento.
  • I grafici creati con PowerPoint 2007 per Windows o con PowerPoint 2008 per Mac vengono visualizzati come immagini in PowerPoint 2004.
  • Le presentazioni con attivazione macro non possono essere salvate in un formato di file privo di attivazione macro in PowerPoint 2004. Inoltre, il problema si verifica anche quando si rimuovono tutte le macro della presentazioni.
  • In PowerPoint 2004 potrebbero essere aggiungere pi¨ estensioni di file al nome del file. Ad esempio, il nome del file potrebbe essere analogo a "myfile.pptx.pptm." Questo problema si verifica quando si apre una presentazione che utilizza un formato privo di attivazione macro, si aggiunge una macro e si salva la presentazione in un formato con attivazione macro. Per risolvere il problema, eliminare l'estensione di nome file priva di attivazione macro dal nome del file nella finestra di dialogo Salva con nome prima di salvare il file.
  • Se PowerPoint 2004 si blocca durante la conversione di una presentazione in formato Open XML, Ŕ necessario riavviare il computer o utilizzare l'utilitÓ Activity Monitor disponibile nella cartella /Applications/Utilities per chiudere il processo Pptfc.app prima di poter aprire o salvare di nuovo una presentazione in formato Open XML.

Informazioni

Argomenti correlati agli aggiornamenti pi¨ recenti che Ŕ possibile installare

Se questo articolo non consente di risolvere il problema, fare clic sui collegamenti seguenti per trovare ulteriori opzioni: I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilitÓ di tali prodotti.

ProprietÓ

Identificativo articolo: 953823 - Ultima modifica: lunedý 17 marzo 2014 - Revisione: 5.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Office 2004 for Mac Professional Edition
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office 2004 for Mac Student and Teacher Edition
  • Microsoft Entourage 2004 for Mac
  • Microsoft Excel 2004 for Mac
  • Microsoft PowerPoint 2004 for Mac
  • Microsoft Word 2004 for Mac
Chiavi:á
dftsdahomeportal kbexpertisebeginner kbinfo KB953823
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com