Article ID: 953823 - View products that this article applies to.
Expand all | Collapse all

On This Page

INTRODUCTION

Important: Office 2004 for Mac has reached the end of its support lifecycle, and no longer receives assisted support or updates from Microsoft. We recommend upgrading to Office 2011 for Mac to have a supported version of Office. For more information about the end of support for Office 2004 for Mac, see the Microsoft Support Lifecycle site.


If you have installed the Microsoft Office 2004 for Mac 11.5.0 Update and the Microsoft Office Open XML File Format Converter for Mac, you can use Office 2004 applications to open and save files in the Open XML Formats that were introduced in the 2007 Microsoft Office system for Windows and in Microsoft Office 2008 for Mac.

Note To verify that your Mac operating system meets these minimum requirements, click About This Mac on the Apple menu.

You have to download the following two packages on your Mac.
  • To download Microsoft Office 2004 for Mac 11.5.0 Update package, visit the following Microsoft Download Center Web site:
    Collapse this imageExpand this image
    Download
    Download the Microsoft Office 2004 for Mac 11.5.0 Update package now.
    System requirement: Apple Mac OS X 10.2.8 (Jaguar) or a later version of Mac OS
  • To download Open XML File Format Converter for Mac Update package, visit the following Microsoft Download Center Web site:
    Collapse this imageExpand this image
    Download
    Download the Open XML File Format Converter for Mac package now.
    Important To open converted documents, you must have Office 2004 11.4.0 or later versions, or Office v. X 10.1.9 or later versions installed on your computer. However, we recommend that you install the Office 2004 11.5.1 Update or a later update for Office 2004 for Mac.

    System requirement: Mac OS X version 10.4.9 (Tiger) or a later version of Mac OS

More information

Supported file formats

The following Open XML Format file types can be opened and saved in Office 2004 for Mac when the Office 2004 for Mac 11.5.0 Update and the Open XML File Format Converter for Mac are installed:
  • Word 2008 Document (.docx)
  • Word 2008 Macro-Enabled Document (.docm)
  • Excel 2008 Workbook (.xlsx)
  • Excel 2008 Binary Workbook (.xlsb)
  • Excel 2008 Macro-Enabled Workbook (.xlsm)
  • Excel 2008 Template (.xltx)
  • Excel 2008 Macro-Enabled Template (.xltm)
  • Excel 2008 Add-in (.xlam)
  • PowerPoint 2008 Presentation (.pptx)
  • PowerPoint 2008 Macro-Enabled Presentation (.pptm)
  • PowerPoint 2008 Template (.potx)
  • PowerPoint 2008 Macro-Enabled Template (.potm)
  • PowerPoint 2008 Show (.ppsx)
  • PowerPoint 2008 Macro-Enabled Show (.ppsm)

Converter support files

When the Office 2004 for Mac 11.5.0 Update and the Open XML File Format Converter for Mac are installed, Office 2004 for Mac recognizes converter support files in the /Library/Application Support/Microsoft/Office Converter Support folder. The following converter support files are required:
  • MFConverter.bundle
  • MicrosoftChartPlugin.framework
  • MicrosoftComponentPlugin.framework
  • MicrosoftOffice.framework
  • MicrosoftOLE.framework
  • MicrosoftOLEAutomation.framework
  • MicrosoftOleo.framework
  • MSXML.framework
  • OfficeArt.framework
  • Open XML for Charts.app
  • Open XML for Excel.app
  • Open XML for Excel.framework
  • Open XML for Word.app
  • Open XML for Word.framework
  • pptfc.app
  • SmartArt.framework
Microsoft Office 2008 for Mac also uses the converter support files. Therefore, you should not remove these file from your computer if you decide to remove Office 2004 or the Open XML Converter.

Updates for converter support files are available from Microsoft AutoUpdate. To check for updates to converter support files, open the Open XML Converter application. Then, click Check for Updates on the Help menu.

Important You cannot use beta versions of the Open XML Converter with Office 2004 11.5.0 or later versions of Office 2004. If you have a beta version of the converter installed on your computer, download and install version 1.0 or a later version of the Open XML Converter. To do this, visit the following Microsoft Web site:
http://www.microsoft.com/mac

Fonts

If Microsoft Office 2004 for Mac is installed on your computer, the following fonts are installed to the /Library/Fonts/Microsoft folder or to the /User/username/Library/Fonts/Microsoft folder when you install the Open XML File Format Converter for Mac:
  • Cambria
  • Calibri
  • Consolas
  • Constantia
  • Corbel
  • Candara
These fonts improve document compatibility and document fidelity when you open documents that were created in the 2007 Microsoft Office system for Windows and Microsoft Office 2008 for Mac.

Known issues for working with Open XML Format files in Word 2004

You might encounter the following issues when you use Word 2004 to work with a Word document that is in Open XML Format:
  • Word 2007 Equation objects are not preserved.
  • New document layouts and formatting that are available in Word 2008 for Mac or Word 2007 for Windows do not display correctly in converted files.
  • HTML objects, such as list boxes and text boxes, are truncated in converted files.
  • Word 2008 Templates (.dotx) and Word 2008 Macro-Enabled Templates (.dotm) cannot be converted.
  • Documents that are protected by a password or by Information Rights Management (IRM) cannot be converted.
  • Picture bullets might be converted to standard bullets.
  • Bibliography and citation fields are converted to text and do not update automatically in converted files.
  • Track Changes revision mark colors might not be preserved.
  • Content that was moved with Track Changes turned on is converted to insertions and deletions.
  • Re-colored pictures are converted to the original color.
  • Picture line styles are converted to the original line style.
  • Digital ink annotations are converted to pictures.
  • Charts and SmartArt graphics are converted to pictures.
  • Watermarks that contain Hiragana fonts are not preserved.
  • Font substitution occurs when horizontal text that uses the Meiryo font is changed to vertical text in a converted file.
  • Warnings and errors that are related to Open XML conversion always appear in English.
  • You cannot open or edit objects that are created by using Equation Editor in converted files.
  • Open XML Format documents that are saved in Word 2004 do not keep Quick Format styles when they are opened in Word 2007.
  • You cannot save multiple Open XML Format documents at the same time in Word 2004.
  • The document content is not correctly displayed because this content may include an incompatible chart. Open XML Format documents that are saved in Word 2004 are saved in compatibility mode. Therefore, content that is created in Word 2007 for Windows or Word 2008 for Mac might not appear or behave as expected when you open the document in those applications. To restore the content, open the document in Word 2008, double-click the chart to edit it.Then, when you are prompted, selectthe chart. After the conversion, switch back to Word, and then resave the document.
  • If you edit a SmartArt graphic in Word 2004, the background for some SmartArt graphics might change to black.
  • Inline SmartArt graphics are unexpectedly converted to pictures when you use Word 2004 to save a document in Open XML Format.
  • Embedded PowerPoint 2007 presentations, Excel 2007 charts and sheets, and Excel 2008 charts and sheets in Open XML Format documents cannot be edited in Word 2004.
  • The Send To Mail option on the File menu in Word 2004 sends documents in the Word Document (.doc) format. This occurs even if the file that you are sending is in Open XML Format.
  • When you open an Open XML Format document, the progress indicator in Word 2004 does not provide an accurate measure of progress.
  • If you save an Open XML Format document that does not contain a macro in the Word 2008 Macro-Enabled Document (.docm) format, you receive a "File not found" error message. However, you can safely ignore this message.
  • Consider the following scenario:
    1. You open a Microsoft Office Word document that uses the .docm file name extension.
    2. This Office Word document does not contain a macro or Visual Basic code.
    3. You open Visual Basic Editor by using the Macro submenu on the Tools menu.
    In this scenario, Visual Basic Editor will open without a project available for the Office Word document.

    To resolve this issue, save the document in Word Document (.docx) format, close and reopen the document, and then open Visual Basic Editor.I
  • Consider the following scenario:
    1. Mac OS X 10.5 (Leopard) users open an Open XML Format document.
    2. This document is stored on a network volume.
    3. Users connect to the network volume by using the SMB protocol
    In this scenario, the document opens as read-only in Word 2004.

Known issues for working with Open XML Format files in Excel 2004

You might encounter the following issues when you use Excel 2004 to work with an Excel workbook that is in Open XML Format:
  • Workbooks that are protected by a password or by Information Rights Management (IRM) cannot be converted.
  • Any data that extends beyond row 65,526 or column 256 is not preserved. Any formula that references data in this region returns the "#REF!" error value.
  • Multiple conditional formatting rules in a cell are not preserved. Excel stops the evaluation after the first condition is evaluated and displayed.
  • New functions in Excel 2008 are not preserved. These functions return the #NAME? error value instead of calculated results.
  • Formulas with more than 29 user-defined arguments are not preserved. These formulas are converted to the "#VALUE!" error value.
  • Uninitialized ActiveX controls are not preserved.
  • Formulas that contain references to tables in other workbooks are not preserved. These references are converted to the "#REF!" error value.
  • Formulas that contain more than 30 arguments in a cell are not preserved. These formulas are converted to the "#VALUE!" error value.
  • Conditional formatting types in a nonadjacent range are not preserved.
  • PivotTable reports that have more than 8,000 items cannot be converted.
  • Formulas that exceed the internal length limit (1,800 characters) are not preserved. These formulas are converted to the "#VALUE!" error value.
  • Formulas that exceed the nesting level limit of 7 levels are not preserved. These formulas are converted to the "#VALUE!" error value.
  • Dates in unsupported calendar formats are unexpectedly converted to the Gregorian calendar format.
  • Unique cell formats that exceed the internal limit (4,050 characters) are not preserved.
  • Conditional formatting for the Format entire row option is not preserved.
  • Date validation formulas that have more than 255 characters are not preserved.
  • Cells with more than three conditional formats display only the first three conditions.
  • Excel 2008 effects that are applied to objects are not preserved.
  • Unique font formats that exceed internal limits are not preserved.
  • Formulas that contain more than 40 operands are not preserved. These formulas are converted to the "#VALUE!" error value.
  • The following data filters are not preserved:
    • custom
    • icon-based
    • color-based
    • date group
    • top 10
    • font color
    • data bar-based
  • More than two sorting criteria are not preserved.
  • Windows-specific settings for automated Web publishing are not preserved.
  • More than one filter on a sort is not preserved.
  • SmartArt graphics are converted to pictures.
  • Linked or embedded Word 2008 documents, Excel 2008 workbooks, and PowerPoint 2008 presentations cannot be opened or edited from converted files.
  • You cannot save multiple Open XML Format workbooks at the same time in Excel 2004.

Known issues for working with Open XML Format files in PowerPoint 2004

You might encounter the following issues when you use PowerPoint 2004 to work with a PowerPoint presentation that is in the Open XML Format:
  • Presentations that are protected by a password or by Information Rights Management cannot be converted.
  • Double underlines are converted to single underlines.
  • Custom character spacing settings are not preserved.
  • Tile settings are not preserved in converted presentations if a tiled picture was used as a slide background.
  • PowerPoint presentations which contain objects that have 3-D effects might take a long time to convert.
  • Stacked Japanese dates do not display correctly in converted files.
  • SmartArt graphics are converted to pictures.
  • Bulleted lists that are more than five levels deep are converted to pictures.
  • Content that is converted to pictures contains substitute fonts if your computer does not have the fonts from the original presentation installed.
  • Soft shadows are converted to hard shadows.
  • New slides that are added to a converted file have a blank layout instead of a bulleted list layout.
  • You cannot save multiple Open XML Format presentations at the same time in PowerPoint 2004.
  • Embedded Word 2008 documents, Excel 2008 workbooks, and PowerPoint 2008 presentations cannot be opened or edited from converted files.
  • When PowerPoint 2008 Templates (.potx) and PowerPoint 2008 Macro-Enabled Templates (.potm) are converted, the Save As dialog box does not open when you save a file. However, you can click the Save As option on the File menu to open the Save As dialog box.
  • Charts that are created in PowerPoint 2007 for Windows or PowerPoint 2008 for Mac might not appear or may not behave as expected if you save a presentation in PowerPoint 2004 and then open the document in PowerPoint 2007 or in PowerPoint 2008. To restore the content, open the document in PowerPoint 2008, double-click the chart to edit it, and when you are prompted, chose to convert the chart. After the conversion, switch back to PowerPoint, and then resave the document.
  • Charts that were created in PowerPoint 2007 for Windows or in PowerPoint 2008 for Mac will appear as pictures when they are viewed in PowerPoint 2004.
  • Macro-enabled presentations cannot be saved in a non-macro-enabled file format in PowerPoint 2004. Additionally, this problem occurs even if you remove all the macros in the presentation.
  • PowerPoint 2004 might add multiple file name extensions to the file name. For example, the file name may resemble "myfile.pptx.pptm." This issue occurs when you open a presentation that uses a non-macro-enabled format, you add a macro to the presentation, and then you save the presentation in a macro-enabled format. To resolve this issue, delete the non-macro-enabled file name extension from the file name in the Save As dialog box before you save the file.
  • If PowerPoint 2004 stops responding when it converts an Open XML Format presentation, you must restart your computer or use the Activity Monitor utility in the /Applications/Utilities folder to close the Pptfc.app process before you can open or save Open XML Format presentations again.

More information

Related Topic for the latest updates that you can install

Click the following links to find more options if this article cannot resolve your problem: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 953823 - Last Review: June 14, 2013 - Revision: 4.0
Applies to
  • Microsoft Office 2004 for Mac Professional Edition
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office 2004 for Mac Student and Teacher Edition
  • Microsoft Entourage 2004 for Mac
  • Microsoft Excel 2004 for Mac
  • Microsoft PowerPoint 2004 for Mac
  • Microsoft Word 2004 for Mac
Keywords: 
dftsdahomeportal kbexpertisebeginner kbinfo KB953823

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com