FIX: When you run a common language runtime (CLR) application on an x64 computer that is running the .NET Framework 2.0 Service Pack 1, you may receive an access violation in the mscorwks!SetAsyncResultProperties object

Article translations Article translations
Article ID: 953990 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

On an x64 computer that is running the .NET Framework 2.0 Service Pack 1 (SP1), you run a common language runtime (CLR) application, such as Microsoft Office Communication Server. When you do this, you may receive an access violation in the mscorwks!SetAsyncResultProperties object. This problem occurs when the HttpListenerRequest.BeginGetClientCertificate method and other overlapped operations are performed at the same time in the application. For example, an overlapped operation could be the call of the Socket.BeginReceive method.

CAUSE

This problem occurs because an HttpListener component releases some OverlappedData objects to the CLR cache before the completion packets for the overlapped operations are processed.

RESOLUTION

Service pack information

To resolve this problem, obtain the Microsoft .NET Framework 3.5 Service Pack 1. The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download the Dotnetfx35setup.exe package now.
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To download this hotfix from the MSDN Code Gallery, visit the following Microsoft Web site:
http://code.msdn.microsoft.com/KB953990

Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support

Prerequisites

You must have the .NET Framework 2.0 SP1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
x86 versions of Windows Server 2000, Windows Server 2003 and Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.dll2.0.50727.18372,985,98412-Jun-200804:04
x64 versions of Windows Server 2000, Windows Server 2003, and Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.dll2.0.50727.18372,985,98412-Jun-200803:34
System.dll2.0.50727.18372,985,98412-Jun-200804:04
IA-64 versions of Windows Server 2000, Windows Server 2003, and Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.dll2.0.50727.18372,985,98412-Jun-200803:34
System.dll2.0.50727.18372,985,98412-Jun-200804:04
x64 versions for Windows Vista SP1, Windows Server 2008, and Windows Server Core
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.dll2.0.50727.30533,149,82427-Jul-200818:02
System.dll2.0.50727.18432,985,98419-Aug-200822:16
More information about x64 versions for Windows Vista SP1, Windows Server 2008, and Windows Server Core
Collapse this tableExpand this table
File nameAmd64_netfx-system_b03f5f7f11d50a3a_6.0.6001.22249_none_d408ce935ad10ad9.manifest
File versionNot Applicable
File size12-Jun-2008,177
Date (UTC)22-Aug-2008
Time (UTC)05:30
File nameMsil_system_b77a5c561934e089_6.0.6001.22249_none_c3c5594d759cdf04.manifest
File versionNot Applicable
File size10,999
Date (UTC)22-Aug-2008
Time (UTC)04:21
File namePackage_for_kb953990_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size11,928
Date (UTC)22-Aug-2008
Time (UTC)20:14
File namePackage_for_kb953990_client~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,440
Date (UTC)22-Aug-2008
Time (UTC)20:14
File namePackage_for_kb953990_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size15,480
Date (UTC)22-Aug-2008
Time (UTC)20:14
File namePackage_for_kb953990_sc~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,432
Date (UTC)22-Aug-2008
Time (UTC)20:14
File namePackage_for_kb953990_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size15,963
Date (UTC)22-Aug-2008
Time (UTC)20:14
File namePackage_for_kb953990_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,440
Date (UTC)22-Aug-2008
Time (UTC)20:14

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 953990 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft .NET Framework 2.0
Keywords: 
kbfix kbexpertiseadvanced kbsurveynew kbqfe KB953990

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com