Artigo: 954069 - Última revisão: terça-feira, 28 de Abril de 2009 - Revisão: 1.0

Windows Media Encoder 9 falha quando mudar a entrada e saída visualizadores e alterar repetidamente recursos

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando muda de visualizadores de saída e visualizadores entrados repetidamente numa sessão de codificador do Windows Media Encoder 9, ocorre uma corrupção de memória. Além disso, a aplicação de codificador falha. Este problema ocorre se alternar entre origens diferentes quando muda de visualizadores de entrada e de visualizadores de saída.

Causa

Este problema ocorre porque o ponteiro de origem não está definido como NULL quando o Visualizador de visualização muda de saída para entrada. Quando muda a origem, a memória para o ponto pode ficar inválida. Quando a memória é lido ou escrita, ocorre uma corrupção de memória.

Resolução

Informações sobre a correcção

Os ficheiros seguintes estão disponíveis para transferência a partir do Centro de transferências da Microsoft:

para x 86 versões
Reduzir esta imagemExpandir esta imagem
Download
Download the 954069 package now. (http://download.microsoft.com/download/5/0/e/50e5e589-eba9-4ed9-8e6c-2ed9122d9104/windowsmedia11-kb954069-x86-intl.exe)

para versões baseadas em 64 x
Reduzir esta imagemExpandir esta imagem
Download
Download the 954069 package now. (http://download.microsoft.com/download/5/0/e/50e5e589-eba9-4ed9-8e6c-2ed9122d9104/windowsmedia11-kb954069-x64-intl.exe)

Pré-requisitos

Tem de ter o Windows Media Format 11 SDK instalado para aplicar esta correcção.

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Para x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempo
Wmvencod.dll11.0.5721.52531,575,42424-Jul-200813: 50
Para versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempo
Wmvencod.dll11.0.5721.52531,887,74424-Jul-200809: 58

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Media Player 9 Series
Palavras-chave: 
kbmt atdownload kbsurveynew kbbug kbfix kbqfe kbpubtypekc KB954069 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 954069  (http://support.microsoft.com/kb/954069/en-us/ )