ID do artigo: 954091 - Última revisão: quinta-feira, 3 de julho de 2008 - Revisão: 1.0

Não consegue aceder as pastas compartilhadas DFS corretas de um cliente DFS baseado em Windows Server 2003 depois dos destinos do link estão atualizados

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Você implantar um ambiente de sistema de arquivos distribuídos (DFS) usando um design cascaded do DFS.
  • Configurar alguns links DFS que apontam para algumas pastas compartilhadas.
  • Atualizar as pastas compartilhadas para o qual o DFS links ponto.
Nesse cenário, você não poderá acessar as pastas compartilhadas corretas de um computador cliente com Windows Server 2003. Além disso, esse problema desaparece depois que você reinicie o computador cliente.

Causa

Esse problema ocorre porque o cliente DFS armazena em cache as informações de destino do vínculo no computador cliente. No entanto, depois que um destino de link for atualizado, o cliente DFS não obter as informações do link atualizado de destino da raiz DFS. Portanto, o cliente DFS não é possível acessar a pasta compartilhada correta.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows Server 2003 Service Pack 1 (SP1) ou Windows Server 2003 Service Pack 2 (SP2) instalado. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003 com Service Pack 1, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mup.sys5.2.3790.3156100.86412 De junho de 200810: 10x 86
Windows Server 2003 com Service Pack 2, x 86-based versões
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mup.sys5.2.3790.4312103,42412 De junho de 200813: 08x 86
Windows Server 2003 com Service Pack 1, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mup.sys5.2.3790.3156311,80813 De junho de 200805: 37IA-64
Windows Server 2003 com Service Pack 2, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mup.sys5.2.3790.4312312,32013 De junho de 200806: 58IA-64
Windows Server 2003 com Service Pack 1, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mup.sys5.2.3790.3156179,71213 De junho de 200805: 38x 64
Windows Server 2003 com Service Pack 2, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mup.sys5.2.3790.4312180,22413 De junho de 200806: 56x 64
Windows XP x 64 Edition com Service Pack 1
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mup.sys5.2.3790.3156179,71213 De junho de 200805: 38x 64
Windows XP x 64 Edition com Service Pack 2
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mup.sys5.2.3790.4312180,22413 De junho de 200806: 56x 64

Como Contornar

Para contornar esse problema, execute o seguinte comando para atualizar o cache DFS no computador cliente baseado no Windows Server 2003:
Dfsutil /pktflush
Observação Para executar este comando, você deve ter ferramentas de suporte do Windows Server 2003 instalado. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
926027  (http://support.microsoft.com/kb/926027/ ) As atualizações para a ferramentas de suporte do Windows Server 2003 estão incluídas no Windows Server 2003 Service Pack 2

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Se você tiver que criar mais de 5.000 links em um namespace DFS baseado em domínio, você pode criar vários namespaces DFS que estão em conformidade com o tamanho recomendado. Em seguida, você pode vincular esses espaços para nome. Esse método é conhecido como um design DFS cascaded e interlinks de links que são chamados de ponto para outro espaço para nome.

Para obter mais informações sobre o DFS, visite o seguinte site:
http://technet2.microsoft.com/windowsserver/en/library/20ffb860-f802-455c-9ca2-5194f79a9eb41033.mspx (http://technet2.microsoft.com/windowsserver/en/library/20ffb860-f802-455c-9ca2-5194f79a9eb41033.mspx)
945222 Hotfix está disponível para resolver o mesmo problema no Windows clientes DFS baseado em XP Service Pack 2.

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
945222  (http://support.microsoft.com/kb/945222/ ) Em um computador baseado no Windows XP Service Pack 2, você não pode acessar o compartilhamento DFS correto depois informações sobre o destino de link são atualizadas
Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

Suporte técnico para versões com base em 64 x do Microsoft Windows

Se o hardware veio com uma edição x 64 do Microsoft Windows instalada, o fabricante do hardware fornecerá suporte técnico e assistência para a edição x 64 do Windows. Nesse caso, o fabricante do hardware fornece suporte porque uma edição x 64 do Windows foi incluída com o hardware. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows do usando componentes exclusivos. Componentes exclusivos podem incluir drivers de dispositivo específico ou podem incluir configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se você precisar de ajuda técnica com uma edição x 64 do Windows. No entanto, talvez você precise entrar em contato com o fabricante diretamente. O fabricante do seu melhor é qualificado para suportar o software que o fabricante do seu instalado no hardware. Se você comprou uma edição x 64 do Windows, como um Windows Server 2003 x 64 edition separadamente, contate a Microsoft para obter suporte técnico.

Para informações de produto sobre o Windows XP Professional x 64 Edition, visite o seguinte site:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Para informações de produto sobre versões com base em 64 x do Windows Server 2003, visite o seguinte site:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kbmt kbwinserv2003postsp2fix kbexpertiseinter kbautohotfix kbbug kbfix kbhotfixserver kbqfe KB954091 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 954091  (http://support.microsoft.com/kb/954091/en-us/ )