All Test commands that are related to the Client Access Server fail when you run the commands on an Exchange 2007 server in a disjoint namespace

Article translations Article translations
Article ID: 954213 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

You have deployed a computer that is running Microsoft Exchange Server 2007 in a disjoint namespace. However, when you run the Test-ActiveSyncConnectivity command in Exchange Management Shell, the command returns the following error message:
Could not find or log on with user <DNS_DOMAIN_FQDN>\CAS_<GUID>. If this task is being run without credentials, please log in as a Domain Administrator, run the Scripts\new-TestCasConnectivityUser.ps1 to verify that the user exists on the mailbox server <server name>
You receive this error message even though Exchange ActiveSync works. Additionally, all the Test-* commands that are related to the Client Access server fail and generate a similar error message. Also, when you use the Exchange Management Pack in Microsoft Operations Manager (MOM), it will fail for the same reason.

Note If you use the get-mailbox command to check the CAS_<GUID> mailbox, you may see that the mailbox exists on the Exchange server.

CAUSE

This issue occurs when a test user is automatically created after you run the Test-ActiveSyncConnectivity command on the Client Access server. When the user is created, the UserPrincipalName property will be set with the domain name of the Mailbox server. The current behavior is that the Exchange server assumes that Mailbox server's domain name is always an Active Directory directory service domain name and uses the UserPrincipalName property as part of a "domain\user" format. However, the Active Directory domain name does not apply in a disjoint namespace scenario.

RESOLUTION

To resolve this problem, install Update Rollup 7 for Exchange 2007 Service Pack 1. For more information about Update Rollup 7 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic:
Description of Update Rollup 7 for Exchange Server 2007 Service Pack 1
For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:
How to Obtain the Latest Service Pack or Update Rollup for Exchange 2007

MORE INFORMATION

For more information about disjoint namespace scenarios, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/bb676377(EXCHG.80).aspx

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 954213 - Last Review: March 18, 2009 - Revision: 1.1
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 1, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbexpertiseinter kbsurveynew kbhotfixrollup kbqfe KB954213

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com