Le périphérique VMBus ne charge pas sur une machine virtuelle qui s'exécute sur un ordinateur Windows Server 2008 avec Hyper-V installé

Traductions disponibles Traductions disponibles
Numéro d'article: 954282 - Voir les produits auxquels s'applique cet article
La prise en charge de Windows Vista Service Pack 1 (SP1) se termine le 12 juillet 2011. Pour continuer à recevoir des mises à jour de sécurité pour Windows, assurez-vous que vous utilisez Windows Vista Service Pack 2 (SP2). Pour plus d'informations, reportez-vous à cette page web Microsoft : Prise en charge se termine pour certaines versions de Windows.
Agrandir tout | Réduire tout

Symptômes

Envisagez le scénario suivant.
  • Vous avez un ordinateur Windows Server 2008 avec Hyper-V installé.
  • Vous créez un ordinateur virtuel sur l'ordinateur Windows Server 2008.
  • Vous créez la machine virtuelle à partir d'une image de disque dur virtuel (fichier .vhd) qui a été créée à l'aide de Microsoft Virtual Server 2005 ou Microsoft Virtual PC 2007.
Dans ce scénario, le VMBus Dispositif de Services d'intégration ne charge pas. Lorsque vous ouvrez le Gestionnaire de périphériques sur l'ordinateur virtuel, un triangle jaune contenant un point d'exclamation apparaît en regard VMBus. Lorsque vous double-cliquez sur VMBus, le Propriétés VMBus boîte de dialogue affiche l'un des messages suivants :
Ce périphérique ne peut pas trouver suffisamment de ressources libres qu'il peut utiliser. (Code 12).
Ce périphérique ne peut pas démarrer. (Code 10).

Cause

Ce problème se produit car la couche d'abstraction matérielle (HAL) n'est pas automatiquement mis à jour dans Windows Server 2008. (Cela est également vrai dans Windows Vista.)

Lorsqu'un ordinateur virtuel est créé à l'aide de Virtual Server ou Virtual PC, le Advanced Configuration and Power Interface (ACPI) couche d'abstraction matérielle est utilisée. Les Services d'intégration nécessite un Programmable Interrupt contrôleur APIC (Advanced) couche HAL à charger le VMBus périphérique correctement.

Résolution

Pour résoudre ce problème, procédez comme suit :
  1. Démarrez l'ordinateur virtuel.
  2. Cliquez sur Démarrer, cliquez sur Exécuter, type Msconfig.exe, puis cliquez sur OK.
  3. Dans le Configuration du système boîte de dialogue, cliquez sur le Démarrage onglet, puis cliquez sur Options avancées.
  4. Dans le Options avancées de démarrage boîte de dialogue, sélectionnez la Détecter les HAL case à cocher, puis cliquez sur OK.
  5. Cliquez sur Oui Pour redémarrer l'ordinateur virtuel.
  6. Après le redémarrage de l'ordinateur virtuel, ouvrez le Gestionnaire de périphériques et puis vérifiez que tous les périphériques de Services d'intégration sont installés.
  7. Dans le Gestionnaire de périphériques, développez Ordinateur, puis vérifiez qu'une couche HAL PC basé sur l'APIC est répertoriée. Pour les machines virtuelles, cet élément apparaît sous la forme de x 86 APIC PC à base x 86. Pour x 64 machines virtuelles, cet élément apparaît sous la forme APIC PC 64 bits.
Remarque : Vous pouvez effacer le Détecter les HAL case à cocher que vous avez sélectionné à l'étape 4. Si le Détecter les HAL case à cocher est activée, l'ordinateur virtuel est légèrement plus de temps à démarrer.

Plus d'informations

Pour plus d'informations sur la technologie Hyper-V, visitez le site Web de Microsoft à l'adresse suivante :
http://technet2.Microsoft.com/windowsserver2008/en/Library/c513e254-adf1-400e-8fcb-c1aec8a029311033.mspx?mfr=true

Propriétés

Numéro d'article: 954282 - Dernière mise à jour: lundi 18 février 2013 - Version: 4.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Vista Professionnel
  • Windows Vista Entreprise
  • Windows Vista Édition Familiale Basique
  • Windows Vista Home Basic Beta
  • Windows Vista Édition Familiale Basique N
  • Windows Vista Édition Familiale Premium
  • Windows Vista Service Pack 1
  • Windows Vista Starter
  • Windows Vista Édition Intégrale
Mots-clés : 
kbexpertiseadvanced kbtshoot kbprb kbmt KB954282 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 954282
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com