HYPER-V がインストールされている Windows Server 2008 ベースのコンピューターで実行されている仮想マシン上のときにデバイスが読み込まれない

文書翻訳 文書翻訳
文書番号: 954282
Windows Vista Service Pack 1 (SP1)、2011 年 7 月 12日、終了をサポートしてください。Windows 用のセキュリティ更新プログラムを受信を続行するには、Service Pack 2 (SP2) で Windows Vista を実行しているかどうかを確認します。詳細についてには、このマイクロソフト web サイトを参照してください。 Windows の一部のバージョンのサポート終了します。.
すべて展開する | すべて折りたたむ

現象

次のシナリオを検討してください。
  • HYPER-V がインストールされている Windows Server 2008 ベースのコンピューターは、あります。
  • Windows Server 2008 ベースのコンピューター上に仮想マシンを作成します。
  • Microsoft Virtual Server 2005 または Microsoft のバーチャル PC 2007 を使用して作成したバーチャル ハード ディスク イメージ (.vhd ファイル) からは、バーチャル マシンを作成します。
このシナリオでは、 ときに 統合サービス デバイスは読み込まれません。バーチャル ・ マシンでデバイス マネージャーを開くと、感嘆符がある黄色の三角形がオフになってください。 ときに.ダブルクリックすると ときに、、 ときにプロパティ ダイアログ ボックスは、次のメッセージのいずれかが表示されます。
このデバイスが使用できる空きリソースが見つかりません。(コード 12)。
このデバイスを開始できません。(コード 10)。

原因

この問題は、Windows Server 2008 では、ハードウェア アブストラクション レイヤー (HAL) に自動的に更新されないために発生します。(これも Windows Vista の場合は true です)。

仮想サーバーまたは仮想 PC を使用して、仮想マシンが作成されると、高度な構成および電源インターフェイス (ACPI) HAL が使用されます。統合サービスを高度なプログラミング可能な割り込みコント ローラー (APIC) を読み込めません HAL 必要とする、 ときに デバイスが正しくします。

解決方法

この問題を解決するには、次の手順を実行します。
  1. バーチャル マシンを起動します。
  2. クリックしてください。 開始をクリックして 実行、タイプ Msconfig.exe、し [OK].
  3. で、 システムの構成 ダイアログ ボックスをクリックして、 ブート タブをクリックし 高度なオプション.
  4. で、 高度なオプションのブート ダイアログ ボックスをオンにし、 HAL を検出します。 チェック ボックスをオンにしをクリックしてください [OK].
  5. クリックしてください。 [はい] バーチャル マシンを再起動します。
  6. 仮想マシンの再起動後、デバイス マネージャーを開くし、すべての統合サービス デバイスがインストールされていることを確認します。
  7. デバイス マネージャーでを展開します。 コンピューター、し、APIC ベースの PC HAL が表示されていることを確認します。X86 として仮想マシン、この項目が表示されます X86-ベース PC x APIC.X64 として仮想マシン、この項目が表示されます X64-ベース PC x APIC.
メモ クリアすることができます、 HAL を検出します。 手順 4 で選択したチェック ボックスします。場合は、 HAL を検出します。 チェック ボックスを選択すると、バーチャル マシンを開始するのには、少し時間がかかります。

詳細

HYPER-V テクノロジの詳細については、次のマイクロソフト Web サイトを参照してください。
http://technet2.microsoft.com/windowsserver2008/en/library/c513e254-adf1-400e-8fcb-c1aec8a029311033.mspx?mfr=true

プロパティ

文書番号: 954282 - 最終更新日: 2011年8月11日 - リビジョン: 4.0
キーワード:?
kbtshoot kbprb kbexpertiseadvanced kbmt KB954282 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:954282
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com