O dispositivo VMBus não é carregado em uma máquina virtual em execução em um computador com Windows Server 2008 que tem instalado o Hyper-V

Traduções deste artigo Traduções deste artigo
ID do artigo: 954282 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário.
  • Você tiver um computador baseado no Windows Server 2008 com Hyper-V instalado.
  • Criar uma máquina virtual no computador com Windows Server 2008.
  • Você cria a máquina virtual a partir de uma imagem de disco rígido virtual (arquivo .vhd) que foi criada usando o Microsoft Virtual Server 2005 ou o Microsoft Virtual PC 2007.
Nesse cenário, o dispositivo de Integration Services VMBus não carrega. Quando você abre o Gerenciador de dispositivos na máquina virtual, um triângulo amarelo tenha um ponto de exclamação aparece ao lado VMBus . Quando você clica duas vezes em VMBus , a caixa de diálogo Propriedades de VMBus exibe uma das seguintes mensagens:
Este dispositivo não encontrou recursos livres suficientes pode usar. (Código 12).
Não é possível iniciar este dispositivo. (Código 10).

Causa

Esse problema ocorre porque o hardware abstraction layer (HAL) não é atualizado automaticamente no Windows Server 2008. (Essa opção também é true no Windows Vista).

Quando uma máquina virtual é criada usando o Virtual PC ou servidor virtual, o Advanced Configuration and Power Interface (ACPI) HAL é usado. O Integration Services exigem um avançado programável interrupção controlador (APIC) HAL para carregar o dispositivo VMBus corretamente.

Resolução

Para resolver esse problema, execute essas etapas:
  1. Inicie a máquina virtual.
  2. Clique em Iniciar , clique em Executar , digite msconfig.exe e, em seguida, clique em OK .
  3. Na caixa de diálogo Configuração do sistema , clique na guia inicialização e, em seguida, clique em Opções avançadas .
  4. Na caixa de diálogo Opções avançadas de inicialização , clique para selecionar a caixa de seleção Detectar HAL e, em seguida, clique em OK .
  5. Clique em Sim para reiniciar a máquina virtual.
  6. Depois que a máquina virtual for reiniciada, abra Gerenciador de dispositivos e, em seguida, verifique se todos os dispositivos de Integration Services estão instalados.
  7. No Gerenciador de dispositivos, expanda computador e, em seguida, verifique se uma HAL de PC com base em APIC está listada. Para x 86 máquinas virtuais, este item serão listadas como APIC x 86-based PC . Para x 64 máquinas virtuais, este item serão listadas como APIC x 64-based PC .
Observação Você pode desmarcar a caixa de seleção Detectar HAL que você selecionou na etapa 4. Se a caixa de seleção Detectar HAL é marcada, a máquina virtual demora um pouco mais para iniciar.

Mais Informações

Para obter mais informações sobre a tecnologia Hyper-V, visite o seguinte site:
http://technet2.microsoft.com/windowsserver2008/en/library/c513e254-adf1-400e-8fcb-c1aec8a029311033.mspx?mfr=true

Propriedades

ID do artigo: 954282 - Última revisão: sábado, 14 de fevereiro de 2009 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Basic Beta
  • Windows Vista Home Basic N
  • Windows Vista Home Premium
  • Service Pack 1 para Windows Vista
  • Windows Vista Starter
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbexpertiseadvanced kbtshoot kbprb KB954282 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 954282

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com