Le service Routeur de messagerie n’a pas pu exécuter le service main’erreur de thread d’arrière-plan lors du démarrage du service de routeur de messagerie Microsoft Dynamics CRM

Cet article fournit une solution au problème selon lequel lorsque vous démarrez le service de routeur de messagerie Microsoft Dynamics CRM, vous pouvez recevoir Le service Routeur de messagerie n’a pas pu exécuter le service main erreur de thread en arrière-plan.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 954522

Symptômes

Lorsque vous essayez de démarrer le service de routeur de messagerie Microsoft Dynamics CRM dans Microsoft Dynamics CRM, l’événement Error suivant est enregistré dans le journal des applications :

Le service Routeur de messagerie n’a pas pu exécuter le service main thread d’arrière-plan

Cause

Ce problème se produit parce que le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml est endommagé.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Supprimez le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml.

    Remarque

    • Par défaut, le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml se trouve dans le dossier suivant :C :\Program Files\Microsoft CRM Email\Service.
    • Par défaut, le dossier Service est un dossier masqué. Pour afficher ce dossier, vous devez modifier les paramètres de Windows Explorer afin d’afficher les fichiers masqués et les dossiers masqués.
  2. Redémarrez le service de routeur de messagerie Microsoft Dynamics CRM.

    Le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml est recréé.

Si Microsoft Dynamics CRM utilisateurs sont configurés pour utiliser le routeur Email, et non une boîte aux lettres de transfert, pour les e-mails entrants, il est possible que les e-mails supprimés reviennent à Microsoft Dynamics CRM après l’implémentation de cette résolution. Si un e-mail n’a pas été supprimé de la boîte aux lettres de l’utilisateur, le routeur Email peut trouver l’e-mail d’un utilisateur dans sa boîte de réception, ne pas le trouver dans Microsoft Dynamics CRM et le créer à nouveau dans Microsoft Dynamics CRM. Pour éviter cela, l’e-mail doit également être supprimé de la boîte aux lettres de l’utilisateur avec Microsoft Dynamics CRM.

Pour éviter cette situation, effectuez régulièrement une sauvegarde des fichiers suivants et stockez-les sur le bureau du même serveur.

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml

Si le Configuration Manager du routeur Microsoft Dynamics CRM Email échoue au lancement ou si le service Microsoft Dynamics CRM Email Router ne parvient pas à démarrer, remplacez les deux fichiers ci-dessus dans C :\Program Files\ Microsoft CRM Email\Service. Redémarrez le service Microsoft Dynamics CRM Email Router, puis lancez le Configuration Manager routeur Microsoft Dynamics CRM Email. Si la sauvegarde de ces fichiers est la plus récente, elle dispose de la configuration complète du routeur Email.

References

Pour plus d’informations, consultez Erreur Email gestionnaire de configuration n’a pas pu lire les informations de configuration se produit lorsque vous lancez le Configuration Manager routeur Microsoft Dynamics CRM Email.