Événement d'erreur lorsque vous essayez de démarrer le Service Microsoft Dynamics CRM E-mail Router dans Microsoft Dynamics CRM 4.0: «le service de routeur de messagerie n'a pas pu exécuter le thread d'arrière-plan principal de service»

Traductions disponibles Traductions disponibles
Numéro d'article: 954522 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Lorsque vous essayez de démarrer le Service Microsoft Dynamics CRM E-mail Router dans Microsoft Dynamics CRM 4.0, l'événement d'erreur suivant est enregistré dans le journal applications :

Le service de routeur de messagerie n'a pas pu exécuter le thread d'arrière-plan principal de service.
Le service E-mail Router ne peut pas continuer et va maintenant s'arrêter.
System.Configuration.ConfigurationErrorsException : Le service de routeur de messagerie ne peut pas accéder à système état fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml. Le fichier est peut-être manquant ou n'est peut-être pas accessible. Le service E-mail Router ne peut pas continuer et va maintenant s'arrêter. ---> System.Xml.XmlException : l'élément racine est manquant.
à System.Xml.XmlTextReaderImpl.Throw (exception e)
à System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo (String res)
à System.Xml.XmlTextReaderImpl.ParseDocumentContent()
à System.Xml.XmlTextReaderImpl.Read()
à System.Xml.XmlLoader.Load (doc de XmlDocument, lecteur XmlReader, preserveWhitespace Boolean)
à System.Xml.XmlDocument.Load (lecteur XmlReader)
à System.Xml.XmlDocument.Load (String filename)
à Microsoft.Crm.Tools.Email.Providers.ConfigFileReaderctor (String filePath, ServiceLogger serviceLogger)
à Microsoft.Crm.Tools.Email.Providers.SystemState.Initialize (ServiceLogger serviceLogger)
à Microsoft.Crm.Tools.Email.Providers.SystemStatector (ServiceLogger serviceLogger)
à Microsoft.Crm.Tools.Email.Agent.ServiceCore.InitializeSystemConfiguration()
---Fin de la trace de pile d'exception interne---
à Microsoft.Crm.Tools.Email.Agent.ServiceCore.InitializeSystemConfiguration()
à Microsoft.Crm.Tools.Email.Agent.ServiceCore.ExecuteService()

Pour plus d'informations, consultez Aide et support à http://go.microsoft.com/fwlink/events.as

Cause

Ce problème se produit car le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml est endommagé.

Résolution

Pour résoudre ce problème, procédez comme suit :
  1. Supprimez le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml.

    Notes
    • Par défaut, le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml est dans le dossier suivant :
      C:\Program Files\Microsoft CRM Email\Service
    • Par défaut, le dossier service est un dossier masqué. Pour afficher ce dossier, vous devez modifier les paramètres de l'Explorateur Windows pour afficher les fichiers cachés et les dossiers masqués.
  2. Redémarrez le Service Microsoft Dynamics CRM E-mail Router.

    Le fichier Microsoft.Crm.Tools.EmailAgent.SystemState.xml est recréé.

Si les utilisateurs de Microsoft Dynamics CRM sont définies à utiliser le routeur de messagerie et pas un plan Mailbox, pour le courrier électronique entrant, il est possible d'e-mails supprimés retourner à Microsoft Dynamics CRM après l'implémentation de cette résolution. Si un e-mail n'a pas été supprimé la boîte aux lettres de l'utilisateur, le routeur de messagerie pourrait trouver e-mail d'un utilisateur dans leur boîte de réception, pas le trouver dans Microsoft Dynamics CRM et créer l'e-mail dans Microsoft Dynamics CRM à nouveau. Pour éviter cela, l'e-mail est également conseillé de les supprimer de boîte aux lettres de l'utilisateur avec Microsoft Dynamics CRM.

Pour éviter cette situation, il convient de régulièrement d'en effectuer une sauvegarde des fichiers suivants et de les stocker sur le bureau du même serveur.
  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml

Si le Gestionnaire de configuration de Microsoft Dynamics CRM E-mail Router échoue au lancement ou le service de Microsoft Dynamics CRM E-mail Router ne parvient pas à démarrer, remplacer les fichiers de 2 ci-dessus dans C:\Program Files\Microsoft CRM Email\Service. Redémarrez le service de Microsoft Dynamics CRM E-mail Router, puis lancez le Gestionnaire de configuration de Microsoft Dynamics CRM E-mail Router. Si la sauvegarde de ces fichiers est plus récente, elle aura la configuration complète d'E-mail Router.

Références

2012555Erreur du Gestionnaire de configuration E-mail n'a pas pu lire les informations de configuration se produit lorsque vous lancez le Gestionnaire de configuration de Microsoft Dynamics CRM E-mail Router

Propriétés

Numéro d'article: 954522 - Dernière mise à jour: mardi 26 janvier 2010 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Dynamics CRM 4.0
Mots-clés : 
kbmt kbmbsemail kberrmsg kbtshoot kbmbsmigrate kbbug kbexpertiseinter KB954522 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 954522
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com