Tjänsten E-postrouter kunde inte köra tjänstens huvudtrådsfel i bakgrunden när Microsoft Dynamics CRM routertjänst för e-post startades

Den här artikeln innehåller en lösning på problemet att när du startar Microsoft Dynamics CRM routertjänsten för e-post kan du få routertjänsten för e-post som inte kunde köra huvudtrådsfelet för tjänsten.

Gäller för: Microsoft Dynamics CRM 2011
Ursprungligt KB-nummer: 954522

Symptom

När du försöker starta Microsoft Dynamics CRM routertjänst för e-post i Microsoft Dynamics CRM loggas följande felhändelse i programloggen:

Det gick inte att köra tjänstens huvudbakgrundstråd för e-postrouter

Orsak

Det här problemet beror på att den Microsoft.Crm.Tools.EmailAgent.SystemState.xml filen är skadad.

Lösning

Följ de här stegen för att lösa problemet:

  1. Ta bort Microsoft.Crm.Tools.EmailAgent.SystemState.xml-filen.

    Obs!

    • Som standard finns den Microsoft.Crm.Tools.EmailAgent.SystemState.xml filen i följande mapp:C:\Program Files\Microsoft CRM Email\Service.
    • Som standard är mappen Service en dold mapp. Om du vill se den här mappen måste du ändra inställningarna för Utforskaren så att dolda filer och dolda mappar visas.
  2. Starta om routertjänsten Microsoft Dynamics CRM e-post.

    Filen Microsoft.Crm.Tools.EmailAgent.SystemState.xml återskapas.

Om Microsoft Dynamics CRM användare är inställda på att använda Email Router, och inte en vidarebefordrad postlåda, för inkommande e-post, finns det en möjlighet att borttagna e-postmeddelanden återgår till Microsoft Dynamics CRM efter att den här lösningen har implementerats. Om ett e-postmeddelande inte har tagits bort från användarens postlåda kan Email Router hitta en användares e-post i inkorgen, inte hitta den i Microsoft Dynamics CRM och skapa e-postmeddelandet i Microsoft Dynamics CRM igen. För att undvika detta bör e-postmeddelandet också tas bort från användarens postlåda tillsammans med Microsoft Dynamics CRM.

Undvik den här situationen genom att regelbundet säkerhetskopiera följande filer och lagra dem på skrivbordet på samma server.

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml

Om Microsoft Dynamics CRM Email Router-Configuration Manager misslyckas vid start eller om tjänsten Microsoft Dynamics CRM Email Router inte startar ersätter du ovanstående två filer i C:\Program Files\ Microsoft CRM Email\Service. Starta om tjänsten Microsoft Dynamics CRM Email Router och starta sedan Microsoft Dynamics CRM Email Router-Configuration Manager. Om säkerhetskopian av dessa filer är senaste har den den fullständiga konfigurationen av Email Router.

Referenser

Mer information finns i Fel Email configuration manager inte kunde läsa konfigurationsinformation inträffar när du startar Microsoft Dynamics CRM Email Router-Configuration Manager.