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Article ID: 954684 - Last Review: November 20, 2008 - Revision: 1.0

You cannot use an Outlook 2007 client to display or download an attachment when you access a message that includes an inline attachment from Exchange Server 2007

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SYMPTOMS

Consider the following scenario. A MIME-encoded message that includes an inline attachment arrives in Microsoft Exchange Server 2007. You try to access the message from a Microsoft Office Outlook 2007 client. In this scenario, the attachment is hidden, and it is unavailable for download. If you use Microsoft Office Outlook Web Access to view the same message, the inline attachment is still hidden. However, the inline attachment is available for download in Outlook Web Access, and you can click the message and view it.

CAUSE

This issue occurs when Exchange Server 2007 does not validate whether there is a reference to the inline attachment. If the inline attachment is not referenced, the inline attachment is hidden.

RESOLUTION

To resolve this problem, install Update Rollup 5 for Exchange Server 2007 Service Pack 1.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
953467  (http://support.microsoft.com/kb/953467/ ) Description of Update Rollup 5 for Exchange Server 2007 Service Pack 1
After you install Update Rollup 5 for Exchange Server 2007 Service Pack 1, you must add a new entry in the Edgetransport.exe.config XML file to enable the hotfix on the Edge server role or on the Hub Transport server role. To do this, follow these steps:
  1. Stop the Exchange Transport service.
  2. Locate the EdgeTransport.exe.config file. This file is located in the following path:
    <drive> :\Program Files\Microsoft\Exchange Server\Bin\
  3. In the EdgeTransport.exe.config file, add the following entry between the <appSettings> element and the </appSettings> element:
    <add key="TreatInlineDispositionAsAttachment" value="true" /> 
    
  4. Restart the Transport service.
Notes
  • If the TreatInlineDispositionAsAttachment option does not exist or if the option is set to "false," the behavior is the same as the behavior that is mentioned in the "Symptoms" section.
  • If the TreatInlineDispositionAsAttachment option is set to "true," the inline attachment that is not referenced is available for download.

MORE INFORMATION

For more information about a similar issue that is specific to Outlook 2003, click the following article number to view the article in the Microsoft Knowledge Base:
930468   (http://support.microsoft.com/kb/930468/ ) The attachment is not displayed when you use Outlook 2003 to open an e-mail message that contains an attachment
For more information about RFC2183, visit the following Web site:
http://www.faqs.org/rfcs/rfc2183.html (http://www.faqs.org/rfcs/rfc2183.html)
For more information about RFC2387, visit the following Web site:
http://www.faqs.org/rfcs/rfc2387.html (http://www.faqs.org/rfcs/rfc2387.html)
If the value of the Filename parameter is not present, or the value of the Filename parameter is blank, the message is still marked as hidden even though you have already installed the hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 1, when used with:
    • Microsoft Exchange Server 2007 Standard Edition
    • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbexpertiseadvanced kbhotfixrollup kbqfe KB954684

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