FIX: You cannot use the mouse to resize a control if you open many forms in Visual Studio 2005 or in Visual Studio 2008 on a computer that is running the .NET Framework 2.0 SP1

Article translations Article translations
Article ID: 954832 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You create a project in Microsoft Visual Studio 2005 or in Microsoft Visual Studio 2008 on a computer that is running the Microsoft .NET Framework 2.0 Service Pack 1 (SP1).
  • You add a form in the project and then put a control on the form.
  • You add another 36 forms in the project and then open 36 forms on the IDE.
When you drag the mouse to resize the control, it responds slowly. When you open the 37th form and then try to resize it, you notice that you cannot drag the mouse. Also, if you hover the mouse over the control, the control is not resized as expected.

Note After you close the form, you can resize it.

CAUSE

This problem occurs because Visual Studio runs out the kernel stack for the mouse hook. This is caused by the design of the mouse hook implementation.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the .NET Framework 3.5 Service Pack 1 (SP1). To obtain the .NET Framework 3.5 SP1, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=a8f5654f-088e-40b2-bbdb-a83353618b38&displaylang=en

Hotfix Information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have the .NET Framework 2.0 SP1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

x86 versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.design.dll2.0.50727.18425,046,27224 -Jun-200800:13x86

x64 versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.design.dll2.0.50727.18425,046,27223 -Jun-200823:53x64
System.design.dll2.0.50727.18425,046,27224-Jun- 200800:13x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 954832 - Last Review: December 29, 2008 - Revision: 1.0
APPLIES TO
  • Microsoft .NET Framework 2.0 Service Pack 1 (x86)
Keywords: 
kbsurveynew kbhotfixserver kbqfe KB954832

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com