Error message when you try to set the value of the "Regular Time Interval" property of an application pool to zero in IIS 7.0: "Property value is not valid"

Article translations Article translations
Article ID: 954871 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

In Internet Information Services (IIS) 7.0, you try to set the value of the Regular Time Interval (in minutes) property to zero in the Advanced Settings window of an application pool. However, you receive the following error message:
Property value is not valid.

CAUSE

This problem occurs when the value of the Regular Time Interval (in minutes) property is less than the value of the Idle Time-out (in minutes) property. The value of the Idle Time-out (in minutes) property must be less than the value of the Regular Time Interval (in minutes) property.

WORKAROUND

To work around this problem, disable the Regular Time Interval (in minutes) property. To do this, use one of the following methods.

Method 1

  1. Open IIS Manager.
  2. In the Connections pane, expand the server node, and then click Application Pools.
  3. Select the application pool for which you want to change the settings, and then click Recycling in the Actions pane.
  4. Click to clear the Regular time intervals (in minutes) check box.
  5. Click Next, and then follow the instructions to complete the wizard.

Method 2

  1. In the Start Search box, type command prompt, right-click Command Prompt, and then click Run as administrator.
  2. In the Administrator: Command Prompt window, type a command that resembles the following, and then press ENTER:
    cd \windows\system32\inetsrv
  3. Type the following command, and then press ENTER:
    appcmd set apppool /apppool.name:[DefaultAppPool]/recycling.periodicRestart.time:00:00:00
    Note The placeholder [DefaultAppPool] represents the name of the application pool that you want to edit.

Properties

Article ID: 954871 - Last Review: February 20, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Internet Information Services 7.0
Keywords: 
kbtshoot kberrmsg kbprb KB954871

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com