Article ID: 954948 - Last Review: October 8, 2011 - Revision: 2.0

The audit collection service (ACS) fails when the ACS is configured for a grooming retention policy that is greater than 256 days in System Center Operations Manager 2007 Service Pack 1

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SYMPTOMS

When an audit collection service (ACS) is configured for a grooming retention policy that is greater than 256 days in Microsoft System Center Operations Manager 2007 Service Pack 1, the ACS service cannot insert events into the ACS database.

In addition, event messages that resemble the following messages are logged in the System Center Operations Manager 2007 event log.

Event message 1
Event Type: Error
Event Source: AdtServer
Event Category: None
Event ID: 4680
Date: <date>
Time: <time>
User: NT AUTHORITY\NETWORK SERVICE
Computer: <computer name>
Description:
The Operations Manager 2007 audit collector service encountered a fatal error while attempting 
to perform a database operation. The Operations Manager Audit Collector service is unable to continue operation and is stopping.
Event message 2
Event Type: Error
Event Source: AdtServer
Event Category: None
Event ID: 4618
Date: <date>
Time: <time>
User: N/A
Computer: <computer name>
Description:
Error occurred on database connection:
Status: 0x04080000
ODBC Error: 106
ODBC State: 42000
Message: [Microsoft][ODBC SQL Server Driver][SQL Server]Too many table names in the query. The maximum allowable is 256.
Database: SqlWriter
Connection: Maintenance
Statement:

CAUSE

This problem occurs because an SQL database has a built-in limitation of 256 tables. When ACS builds a view, ACS creates a select statement that contains data from all the partition tables. When the number of partition tables exceeds 256, this problem occurs.

RESOLUTION

Update Information

To resolve this problem, obtain the latest version of Microsoft System Center Operations Manager 2007. For more information, refer to this Microsoft Web site: http://www.microsoft.com/systemcenter/operationsmanager/en/us/how-to-buy.aspx (http://www.microsoft.com/systemcenter/operationsmanager/en/us/how-to-buy.aspx)

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have System Center Operations Manager 2007 Service Pack 1 installed to apply this hotfix. This hotfix must be applied to each computer that meets the following criteria:
  • The computer hosts a Microsoft Operations Manager Audit Collector

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
System Center Operations Manager 2007 Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Adtsrvdll.dll6.0.6278.34374,32822-07-200813:58x86
Dbcreatepartition.sqlNot applicable19,67122-07-200813:58Not applicable
Dbdeletepartition.sqlNot applicable5,68222-07-200813:58Not applicable
System Center Operations Manager 2007 Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Adtsrvdll.dll6.0.6278.34566,84022-07-200814:47x64
Dbcreatepartition.sqlNot applicable19,67122-07-200814:47Not applicable
Dbdeletepartition.sqlNot applicable5,68222-07-200814:47Not applicable
To apply this hotfix, you must run the two following procedures:
  1. You must extract the hotfix files by running the .MSI file in which the hotfixes are packaged on the ACS Collector.
  2. You must install the hotfix files into the ACS Collector.

Procedure 1: Extract the hotfix files

  1. Copy the following file to either a local folder or to an available network shared folder:
    SystemCenterOperationsManager2007-SP1-KB954948-X86-X64-ENU.MSI
  2. Run the file that you copied in step 1. Note the installation path that is requested during installation. The installation path is typically the following path:
    Program Files\System Center Hotfix Utility
You can run the file that is mentioned in step 1 from either Windows Explorer or at a command prompt.

Procedure 2: Install the hotfix files on the ACS Collector

  1. On the ACS Collector, open the Services MMC snap-in, locate Operations Manager Audit Collection Service, and then stop the service.
  2. Use Windows Explorer to locate the hotfix installation folder that you noted in Procedure 1.
  3. Open the following sub-folder:
    Q954948
    Within the Q954948 folder are two sub-folders for each platform (x86 or x64) for which the hotfix is available. Open the platform folder for the ACS update that is appropriate for your situation. This folder contains an update file. For example, for an x86-based update, the update file is named "Q954948-x86.msp."
  4. In Windows Explorer, double-click the update file. This starts the Welcome to the System Center Operations Manager Audit Collection Server Setup Wizard.
  5. Click Next to apply the updated files, and then click Finish to complete the wizard.
  6. To confirm the successful application of the hotfix, change to the %systemroot%\System32\Security\AdtServer folder, and then check the file properties for the following files:
    • AdtSrvDll.dll: The file version should be 6.0.6278.34.
    • DbCreatePartition.dll: The last modified date should be July 22, 2008.
    • DbDeletePartition.dll: The last modified date should be July 22, 2008.
  7. In the Services MMC, restart Operations Manager Audit Collection Service.

WORKAROUND

To work around the issue, reduce the ACS groom retention to less than 256 days.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.This problem was first corrected in Microsoft System Center Operations Manager 2007 R2.

MORE INFORMATION

For a list of issues that are fixed in Microsoft System Center Operations Manager 2007 R2, refer to the following article in the Microsoft Knowledge base:
971410  (http://support.microsoft.com/kb/971410/ ) List of issues that are fixed in System Center Operations Manager 2007 R2

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft System Center Operations Manager 2007 Service Pack 1
Keywords: 
kbautohotfix kbexpertiseinter kbbug kbfix kbqfe KB954948