Windows Server 2003 Terminal Server may crash during the terminal session logoff process, and you may receive a Stop error message: "Stop error code 0x00000050 (PAGE_FAULT_IN_NONPAGED_AREA)"

Article translations Article translations
Article ID: 955066 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Windows Server 2003 Terminal Server may crash during the terminal session logoff process. Additionally, you may receive the following Stop error message:
Stop 0x00000050 (parameter1, 00000000, parameter3, 00000000)
PAGE_FAULT_IN_NONPAGED_AREA
Note The parameters in this Stop error message vary, depending on the configuration of the computer.

CAUSE

This problem occurs because the Win32k.sys driver calls a user mode driver during the cleanup process.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Gdi32.dll5.2.3790.3091285,18418-Feb-200813:18x86SP1
Win32k.sys5.2.3790.32291,859,58416-Oct-200814:40x86SP1
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.43921,849,85616-Oct-200816:03x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091910,84817-Oct-200807:30IA-64SP1Not Applicable
Win32k.sys5.2.3790.32295,562,88017-Oct-200807:30IA-64SP1Not Applicable
Wgdi32.dll5.2.3790.3091288,76817-Oct-200807:30x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.43925,568,00017-Oct-200807:53IA-64
Windows Server 2003 with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091619,00817-Oct-200807:30x64SP1Not Applicable
Win32k.sys5.2.3790.32294,549,63217-Oct-200807:30x64SP1Not Applicable
Wgdi32.dll5.2.3790.3091288,76817-Oct-200807:30x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.43924,543,48817-Oct-200807:55x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 955066 - Last Review: January 20, 2012 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbqfe KB955066

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com