Error message when you run an application that uses the Application Desktop Toolbar (AppBar) component on a computer that is running Windows XP SP2 or Windows XP SP3: “0xC0000005 (Access Violation)”

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Article ID: 955109 - View products that this article applies to.
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SYMPTOMS

On a computer that is running Windows XP Service Pack 2 (SP2) or Windows XP Service Pack 3 (SP3), you have an application that uses the Application Desktop Toolbar (AppBar) component. However, when the application runs, the Windows Explorer (Explorer.exe) process crashes. Additionally, you receive the following error message:
0xC0000005 (Access Violation)

CAUSE

This problem occurs because the Explorer.exe process references a Null pointer after the application calls the AppBarRemove function to remove the toolbar. Therefore, Windows Explorer crashes.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP SP2 or Windows XP SP3 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Explorer.exe6.0.2900.34031,033,21603-Jul-200809:57x86
Windows XP with Service Pack 3, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Explorer.exe6.0.2900.56341,033,72803-Jul-200811:38x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 955109 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 3, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbfix kbbug kbexpertiseinter kbqfe KB955109

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