Article ID: 955233 - Last Review: February 12, 2009 - Revision: 2.0

You receive an error message when you save a security role in Microsoft Dynamics CRM 4.0

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SYMPTOMS

When you change the value in the Business Unit field for a security role in Microsoft Dynamics CRM 4.0, and then you save the security role, you receive the following error message:
User Error
=====================================
CrmScriptErrorReport> <ReportVersion>1.0</ReportVersion>
<ScriptErrorDetails>
<Message>&#39;crmTabBar&#39; is undefined</Message>
<Line>740</Line>
<URL>/Titan&#47;biz&#47;roles&#47;edit.aspx&#63;_CreateFromType&#61;10&#38;_CreateFromId&#61;&#37;7b2723AD99-7E31-DD11-9073-0007E94D8A19&#37;7d</URL>
<PageURL>/Titan&#47;biz&#47;roles&#47;edit.aspx&#63;_CreateFromType&#61;10&#38;_CreateFromId&#61;&#37;7b2723AD99-7E31-DD11-9073-0007E94D8A19&#37;7d</PageURL>
<Function>GetTab&#40;o, bMakeVisible&#41;</Function>
<CallStack> <Function>GetTab&#40;o, bMakeVisible&#41;</Function>
<Function>setFocus&#40;&#41;</Function>
</CallStack>
</ScriptErrorDetails>
<ClientInformation>
<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 6.0&#59; Windows NT 5.2&#59; SV1&#59; .NET CLR 1.1.4322&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; .NET CLR 3.0.04506.648&#41;</BrowserUserAgent>
<BrowserLanguage>en-us</BrowserLanguage>
<SystemLanguage>en-us</SystemLanguage>
<UserLanguage>en-us</UserLanguage>
<ScreenResolution>1128x972</ScreenResolution>
<ClientName>Web</ClientName>
</ClientInformation>
<ServerInformation>
<OrgLanguage>1033</OrgLanguage>
<OrgCulture>1033</OrgCulture>
<UserLanguage>1033</UserLanguage>
<UserCulture>1033</UserCulture>
<OrgID>&#123;EC986190-7E31-DD11-9073-0007E94D8A19&#125;</OrgID>
<UserID>&#123;2123AD99-7E31-DD11-9073-0007E94D8A19&#125;</UserID>
<CRMVersion>4.0.7333.3</CRMVersion>
</ServerInformation> </CrmScriptErrorReport>
<CrmScriptErrorReport>
<ReportVersion>1.0</ReportVersion>
<ScriptErrorDetails>
<Message>Object doesn&#39;t support this property or method</Message>
<Line>149</Line>
<URL>/Titan&#47;biz&#47;roles&#47;edit.aspx&#63;_CreateFromType&#61;10&#38;_CreateFromId&#61;&#37;7b2723AD99-7E31-DD11-9073-0007E94D8A19&#37;7d</URL>
<PageURL>/Titan&#47;biz&#47;roles&#47;edit.aspx&#63;_CreateFromType&#61;10&#38;_CreateFromId&#61;&#37;7b2723AD99-7E31-DD11-9073-0007E94D8A19&#37;7d</PageURL>
<Function>setFocus&#40;&#41;</Function>
<CallStack>
<Function>setFocus&#40;&#41;</Function>
</CallStack>
</ScriptErrorDetails>
<ClientInformation>
<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 6.0&#59; Windows NT 5.2&#59; SV1&#59; .NET CLR 1.1.4322&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; .NET CLR 3.0.04506.648&#41;</BrowserUserAgent>
<BrowserLanguage>en-us</BrowserLanguage>
<SystemLanguage>en-us</SystemLanguage>
<UserLanguage>en-us</UserLanguage>
<ScreenResolution>1128x972</ScreenResolution>
<ClientName>Web</ClientName>
</ClientInformation>
<ServerInformation>
<OrgLanguage>1033</OrgLanguage>
<OrgCulture>1033</OrgCulture>
<UserLanguage>1033</UserLanguage>
<UserCulture>1033</UserCulture>
<OrgID>&#123;EC986190-7E31-DD11-9073-0007E94D8A19&#125;</OrgID>
<UserID>&#123;2123AD99-7E31-DD11-9073-0007E94D8A19&#125;</UserID>
<CRMVersion>4.0.7333.3</CRMVersion>
</ServerInformation>
</CrmScriptErrorReport>

CAUSE

This problem occurs because both the Edit.aspx file that is associated with the role form and the code for the Edit.aspx file name the Tab bar "tabBar" instead of "crmTabBar." When you save the record in the role form, Microsoft Dynamics CRM tries to set the focus on the crmTabBar tab. Therefore, you receive the error message.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256  (http://support.microsoft.com/kb/949256/ ) Microsoft Dynamics CRM 4.0 updates and hotfixes

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates
For more information about Microsoft Business Solutions CRM software hotfix and update package terminology, click the following article number to view the article in the Microsoft Knowledge Base:
887283  (http://support.microsoft.com/kb/887283/ ) Microsoft Business Solutions CRM software hotfix and update package naming standards

APPLIES TO
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbautohotfix kbexpertiseinter kbfix kberrmsg kbsurveynew kbmbsmigrate kbqfe kbhotfixserver KB955233
 

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