Article ID: 955276 - Last Review: July 10, 2008 - Revision: 1.0

Error message when you try to connect to Intelligent Application Gateway: "Too many users"

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SYMPTOMS

You receive the following error message when you try to connect to Microsoft Intelligent Application Gateway (IAG):
Too many users
Additionally, the following event is logged in the Web Monitor:

Severity: Warning
Category: Session
ID: 15
Type: Number of Max Concurrent Sessions Exceeded

CAUSE

This problem may occur for one of the following reasons:
  • The number of concurrent sessions exceeds the maximum concurrent session limit that is defined in IAG.
  • An error occurs when the IAG Session Manager (Whale SessionMgr) service tracks sessions.

RESOLUTION

To resolve this problem, try the following methods. If the problem is not resolved after you try one method, continue to try other methods.

Method 1

Use the Web Monitor to examine the currently active sessions. To do this, follow these steps:
  1. Click Start, point to All Programs, point to Whale Communications IAG, point to Additional Tools, and then click Web Monitor.
  2. In the navigation pane, click Active Sessions under Session Monitor.
  3. In the Trunk list, select the appropriate trunk that users access.
  4. Check for the number of sessions that are currently established.
Then, increase the maximum concurrent sessions to accommodate the desired number of concurrent sessions. To do this, follow these steps:
  1. Open the IAG Configuration console. To do this, click Start, point to All Programs, point to Whale Communications IAG, and then click Configuration.
  2. In the console tree, click the trunk that you want to configure, and then click Configure next to Advanced Trunk Configuration.
  3. On the Session tab, type the desired value in the Maximum Concurrent Sessions box, and then click OK.

    Note The number in the Maximum Concurrent Sessions box should be large enough to accommodate the sessions that are likely to be established.
  4. On the File menu, click Activate.
  5. Click Activate to confirm the activation operation.
  6. Click OK.

Method 2

If the maximum concurrent sessions setting is sufficient to accommodate the concurrent sessions, follow these steps to reset the Whale SessionMgr service:
  1. If a redirect trunk is used to handle the sessions, delete the redirect trunk, and then re-create the redirect trunk. If no redirect trunk is used, go to step 3.
  2. Activate the configuration. To do this, click Activate on the File menu. Click Activate to confirm the activation operation, and then click OK.
  3. Restart the Whale SessionMgr service. If the problem is not resolved after the service restarts, go to step 4.
  4. Reset Internet Information Services (IIS). At a command prompt, type the following command, and then press ENTER:
    iisreset -restart
    If the problem is not resolved after the IIS reset, go to step 5.
  5. Restart the IAG server.

Method 3

If neither method 1 nor method 2 resolves the problem, we recommend that you enable Session Manager tracing and filter logging to troubleshoot this problem.

To enable Session Manager tracing, follow these steps:
  1. Locate the Trace.inc file in the following folder, and then open it in Notepad:
    e-Gap\von\InternalSite\inc
    Note In these steps, the e-Gap placeholder represents the location in which IAG is installed.
  2. Change "trace_on = false" to "trace_on = true", and then save the file.
  3. Locate the Trace.ini file in the following folder, and then open it in Notepad:
    e-Gap\common\conf
  4. Add the following text to the file, and then save the file.
    [Trace\SessionMgrCom]
    *=xheavy
To enable filter logging, follow these steps.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit in the Open box, and then press ENTER.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\WhaleCom\e-Gap\Von\UrlFilter
  3. Right-click LogFlag, and then click Modify.
  4. In the Value data box, change the value from 0 to 4, and then click OK.
  5. Exit Registry Editor.
Logging information is saved to the following files:
  • e-Gap\von\conf\WebSites\TrunkName\Logs
  • e-Gap\logs\ComputerName.SessionMgrCom.default.DateString.log
Note The TrunkName placeholder represents the name of the trunk. The ComputerName placeholder represents the name of the computer. The DateString placeholder represents the date on which the log is generated.

After this problem occurs and after logs are generated, remove the changes that you made to the Trace.inc file and to the Trace.ini file. Then, restore the registry entry that you modified.

APPLIES TO
  • Intelligent Application Gateway 2007
  • Whale Communications Intelligent Application Gateway 3.6
Keywords: 
kberrmsg kbtshoot kbexpertiseinter kbprb KB955276
 

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