Cuando se utiliza un identificador de archivo para acceso de FileStream en una transacción de SQL Server 2008, la transacción puede cancelarse aleatoriamente a confirmar en Windows Server 2003 o en Windows XP Professional x 64 Edition

Seleccione idioma Seleccione idioma
Id. de artículo: 955280 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo que ejecuta Windows Server 2003 o Windows XP Professional x 64 Edition, cuando se utiliza la API de OpenSqlFilestream o la clase de .NET SqlFilestream para obtener un identificador de archivo para acceso de FileStream en una transacción en Microsoft SQL Server 2008, la transacción al azar puede no confirmar. Cuando se produce este problema, se registra en el archivo de registro de errores de SQL Server de uno de los errores siguientes:
  • 3910 (Contexto de transacción en uso por otra sesión)
  • 3981 (No se puede realizar la operación transacción porque hay trabajando en esta transacción de solicitudes pendientes)
  • 3922 No se (puede dar de alta la transacción porque la transacción no existe)
La causa de este problema no está relacionado con la característica FILESTREAM en SQL Server 2008. Sin embargo, normalmente tiene este problema cuando utiliza la característica FILESTREAM en SQL Server 2008.

Causa

Este problema se produce debido a un error en el servicio servidor de. El servicio servidor incorrectamente retrasos cerrar el archivo controlan. Por lo tanto, SQL Server 2008 no puede realizar operaciones de confirmación.

Solución

Información de revisiones

Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Este hotfix puede ser sometido a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Para resolver este problema inmediatamente, póngase en contacto con servicios de soporte de cliente de Microsoft para obtener la revisión. Para obtener una lista completa de los números de teléfono de los servicios de soporte técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.
Requisitos previos
Para aplicar este hotfix, debe estar ejecutando Windows Server 2003 Service Pack 1, Windows Server 2003 Service Pack 2, Windows XP Professional x 64 Edition o Windows XP Professional x 64 Edition Service Pack 2 en el equipo.
Requisito de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Esta revisión no reemplaza una revisión lanzada anteriormente.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.

Windows Server 2003 con Service Pack 1, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
SRV.sys5.2.3790.3177361,47218-Jul-200810: 15x 86

Windows Server 2003 con Service Pack 1 , x 64 -basándose en las versiones
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
SRV.sys5.2.3790.3177674,81621-Jul-200807: 32x 64
Windows Server 2003 con Service Pack 1, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
SRV.sys5.2.3790.31771,110,52821-Jul-200807: 32IA-64

Windows Server 2003 con Service Pack 2, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
SRV.sys5.2.3790.4337358,40018-Jul-200812: 04x 86

Windows Server 2003 con Service Pack 2, versiones de 64
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
SRV.sys5.2.3790.4337648,19221-Jul-200814: 57x 64

Windows Server 2003 con Service Pack 2, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
SRV.sys5.2.3790.43371,111,55221-Jul-200814: 54IA-64

Windows XP Professional x 64 Edition

Hay una revisión compatible de Microsoft. Sin embargo, se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Este hotfix puede ser sometido a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Para resolver este problema inmediatamente, póngase en contacto con servicios de soporte de cliente de Microsoft para obtener la revisión. Para obtener una lista completa de los números de teléfono de los servicios de soporte técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.
Requisitos previos
Para aplicar esta revisión, debe estar ejecutando Windows XP Professional x 64 edición o Windows XP Professional x 64 Edition Service Pack 2 en el equipo.
Requisito de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Esta revisión no reemplaza una revisión lanzada anteriormente.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.

Windows XP Professional x 64 Edition
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
SRV.sys5.2.3790.3177674,81621-Jul-200807: 32x 64

Windows XP Professional x 64 Edition con Service Pack 2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
SRV.sys5.2.3790.4337648,19221-Jul-200814: 57x 64

Solución

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
Advertencia Esta solución provocará un problema de rendimiento cuando que operan en comparte archivos en el sistema.


Para evitar este problema, establezca el valor de la entrada de registro Cachedopenlimit en 0 y, a continuación, reinicie el servicio servidor. Para ello, siga estos pasos:
  1. En el Editor del Registro, expanda la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanserver\Parameters
  2. Bajo la subclave del registro de parámetros , haga clic en Modificar , haga clic en nuevo , haga clic en Valor DWORD , escriba Cachedopenlimit y, a continuación, presione ENTRAR.
  3. Establezca el valor decimal de la entrada de registro Cachedopenlimit a 0 .
  4. Reinicie el servicio servidor.
Nota De forma predeterminada, el valor de la entrada de registro Cachedopenlimit es 5 , aunque no se estableció.

Advertencia Cuando se establece el valor en 0 , identificadores de archivo de todos los archivos compartidos no son almacenados en caché por el sistema. Esto puede causar un problema de rendimiento cuando tiene acceso a archivos compartidos en el sistema.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Este problema se también produce en Windows Server 2008 y en Windows XP x 86. Para obtener más información acerca de este problema en Windows Server 2008, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
953263Cuando se utiliza una instrucción Transact-SQL para funcionar en una columna FILESTREAM en SQL Server 2008, la instrucción puede error aleatoriamente confirmar y dañar los datos en Windows Server 2008
Para obtener más información sobre este problema en Windows XP x 86, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
955567Datos pueden dañarse cuando intenta anexar datos a una FILESTREAM varbinary (max) columna SQL Server 2008 en un equipo
Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:-
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Cuándo utilizar el almacenamiento FILESTREAM

En SQL Server 2008, los datos de objeto binario grande (BLOB) pueden ser los datos del tipo varbinary (max) que almacena datos en tablas de base de datos. Datos BLOB también pueden ser los datos del tipo Varbinary (max) FILESTREAM que almacena los datos en el sistema de archivos. El tamaño de los datos y el uso de datos determinan si debe utilizar el almacenamiento de base de datos o el almacenamiento FILESTREAM . Considere utilizar el almacenamiento FILESTREAM cuando se cumplen las condiciones siguientes:
  • Como promedio, los datos BLOB que se almacenan están más que 1 megabyte (MB).
  • Acceso de lectura rápida es importante.
  • Está desarrollando aplicaciones que utilizan un nivel medio para la lógica de aplicación.
Si los datos BLOB están menor que 1 MB, se debe considerar el uso del almacenamiento de base de datos. El almacenamiento de base de datos con frecuencia proporciona transmisión mejor rendimiento.

Para obtener más información, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
http://msdn.microsoft.com/en-us/library/bb933993.aspx

Propiedades

Id. de artículo: 955280 - Última revisión: martes, 13 de enero de 2009 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Palabras clave: 
kbmt kbexpertiseadvanced kbfix kbautohotfix kbsurveynew kbqfe kbhotfixserver KB955280 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 955280

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com