Evento de error después de personalizar una aplicación para utilizar los encabezados HTTP en IAG 3.6 o en IAG 2007: "el tamaño de encabezados (xxxx) es demasiado larga.

Seleccione idioma Seleccione idioma
Id. de artículo: 955316 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
Expandir todo | Contraer todo

Síntomas

De Whale Communications Intelligent Application Gateway (IAG) 3.6 o en Microsoft IAG 2007, se registra un suceso de error similar al siguiente en el Monitor de sucesos de IAG:

DATETIME: HTTP [tronco] [mensaje] ProductionPortal seguridad solicitud error [URL] [Escriba] [método] [host] [INFO] GET encabezados tamaño (xxxx) es demasiado largo.

Nota En este evento de error, el marcador de DATE y el marcador de posición TIME representan la fecha real y la hora. El marcador de posición xxxx representa el tamaño real de los encabezados HTTP.

Por ejemplo, si personaliza una aplicación para utilizar los encabezados HTTP y el tamaño del encabezado es 5683 bytes, el evento error se estado "tamaño de encabezados (5683) es demasiado largo." Además, se establecerá el valor de la propiedad MaxAllHeadersLen a 5683.

Causa

Este problema se produce porque IAG limita el tamaño máximo de todos los encabezados HTTP en una única solicitud HTTP o la respuesta HTTP. De forma predeterminada, el tamaño máximo para los encabezados HTTP es de 4096 bytes.

Solución

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.
Para resolver este problema, agregue una entrada del registro y, a continuación, configurarlo rto modifique la propiedad MaxAllHeadersLen . Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\WhaleCom\e Gap\Von\UrlFilter
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. Escriba MaxAllHeadersLen y, a continuación, presione ENTRAR.
  5. Haga doble clic en MaxAllHeadersLen , establecer el tamaño adecuado en bytes en el cuadro datos del valor y, a continuación, haga clic en Aceptar .
  6. En el menú archivo , haga clic en Salir .
  7. Haga clic en Inicio , haga clic en Ejecutar , escriba cmd y, a continuación, haga clic en Aceptar .
  8. En el símbolo del sistema, escriba iisreset y, a continuación, presione ENTRAR.

    Nota Después de agregar la entrada de registro MaxAllHeadersLen debe restablecer Internet Information Services (IIS). La línea de comandos iisreset desconecta todas las sesiones de usuario existentes.

Propiedades

Id. de artículo: 955316 - Última revisión: jueves, 10 de julio de 2008 - Versión: 1.0
La información de este artículo se refiere a:
  • Intelligent Application Gateway 2007
  • Whale Communications Intelligent Application Gateway 3.6
Palabras clave: 
kbmt kbexpertiseinter kbtshoot kbprb KB955316 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 955316

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com