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Article ID: 955319 - Last Review: July 14, 2008 - Revision: 2.0

An external IAG server cannot start the Whale e-Gap Manager service because of a dependency on a service that is associated with a program from Resonate Software

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SYMPTOMS

When you try to start an external Intelligent Application Gateway (IAG) server, the Whale e-Gap Manager service cannot be started, and you receive the following error message:
At least one service or driver failed during system startup. Use Event Viewer to examine the event log for details.
If you open Event Viewer, you notice that the Whale e-Gap Manager service was unable to start because of a dependency on a service that is associated with a program from Resonate Software.

CAUSE

This problem occurs when the following conditions are true:
  • The IAG server was configured as part of a High Availability (HA) software array that was running the Resonate program when IAG was installed on the server.
  • There is no Resonate software installed on the external server.
This problem may also occur when the following conditions are true:
  • From a backup, you restore a configuration that had a dependency on a Resonate service to an appliance on the external IAG server.
  • This appliance does not have Resonate software installed.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
If the external IAG server will be part of a Resonate HA cluster, you can resolve this problem by installing the Resonate program on the external server.

If the external IAG server will not be part of a Resonate HA cluster, follow these steps to remove the Resonate dependency.

Note You must edit the registry on both the internal and external IAG server. Otherwise, every time that the e-Gap Manager service restarts, the Resonate dependency will be reestablished.
  1. On the external IAG server, click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\whlegapd
  3. Right-click dependonservice, click Modify, and then delete Resonate from the Value data box.
  4. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\WhaleCom\e-Gap\HighAvailability
  5. Delete the subkey for the Resonate software, if it exists.
  6. On the internal IAG server, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\WhaleCom\e-Gap\HighAvailability
  7. Delete the subkey for the Resonate software, if it exists.
  8. Restart both the internal IAG server and the external IAG server.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

APPLIES TO
  • Whale Communications Intelligent Application Gateway 3.6
Keywords: 
kbhowto kbexpertiseadvanced KB955319

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