A distinguished name that contains more than 100 characters and that is discovered from Active Directory for an AMT host causes the SMS_EXECUTIVE service to crash in System Center Configuration Manager 2007

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Article ID: 955355 - View products that this article applies to.
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SYMPTOMS

When the SMS_EXECUTIVE service processes an .apx file that contains the name of an AMT host in Active Directory, the SMS_EXECUTIVE service crashes. This problem occurs when the following conditions are true:
  • The AMT host in Active Directory is discovered in System Center Configuration Manager 2007 Service Pack 1.
  • The length of the distinguished name plus the string "cn=" is longer than 100 characters.
Additionally, the following event log is logged in the System log:
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7034
Date: <Date>
Time: <Time>
User: N/A
Computer: <Computer Name>
Description:
The SMS_EXECUTIVE service terminated unexpectedly. It has done this <number> time(s).

CAUSE

This problem occurs because the maximum host name length is 100 characters. When the length of the distinguished name plus the string "cn=" is longer than 100 characters, the out of index range error occurs. Therefore, the SMS_EXECUTIVE service crashes.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft System Center Configuration Manager 2007, available from this Microsoft web site: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
For a list of issues resolved in this service pack, click on the following article number in the Microsoft Knowledgebase:
971348 List of hotfixes and updates that are contained in System Center Configuration Manager 2007 Service Pack 2

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have System Center Configuration Manager 2007 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Amtopmgr.dll4.0.6221.1107946,61630-Nov-200819:30x86
Amtproxymgr.dll4.0.6221.1107141,24030-Nov-200819:30x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 955355 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft System Center Configuration Manager 2007
Keywords: 
kbautohotfix kbexpertiseinter kbbug kbfix kbqfe KB955355

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