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Article ID: 955375 - Last Review: June 25, 2009 - Revision: 3.0

Problems occur when you try to open an Office document from a Web site hyperlink in a 2007 Office application on a Windows Vista-based client computer

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Problem description

On a Windows Vista-based client computer, you try to open a Microsoft Office document from a Web site hyperlink in a 2007 Microsoft Office application. When you do this, you may experience the following symptoms:
  • Performance is slow, or the 2007 Office application may stop responding for several minutes.
  • You are prompted for authentication even though you previously entered your credentials.
  • You lose session state. Then, you are redirected to a logon page or to an error page on the Web site.
  • The document is downloaded two times. When the files are large, the download process consumes more network bandwidth.
Note These problems do not occur when you try to open the document on a Windows XP-based computer or on a Windows Server 2003-based computer.

This article helps you fix the problem.

Resolution

To resolve thes problem apply hotfix 954573.

For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
954573  (http://support.microsoft.com/kb/954573/ ) Description of the 2007 Office system hotfix package: June 26, 2008
To have us activate this hotfix for you, go to the “Fix it for me” section. If you’d rather fix this problem yourself, go to the “Let me fix it myself” section.

Fix it for me

Note you must install the hotfix discussed in the Resolution section above before continuing.

To fix this problem automatically, click the Fix this problem link. Then click Run in the File Download dialog box, and follow the steps in this wizard.

Fix this problem

Note This wizard is temporarily in English only. However, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem.

Now go to the "Did this fix the problem?" section.

Let me fix it myself

Note you must install the hotfix discussed in the Resolution section above before continuing.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
To fix this problem, follow these steps.

Enable the hotfix by configuring the UseWinINETCopy registry entry. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\12.0\Common\Internet
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type UseWinINETCopy, and then press ENTER.
  5. Right-click UseWinINETCopy, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Exit Registry Editor.
  8. Restart the computer.
Note Applying this registry setting implies that read-only files open from a URL address will remain read-only as long as the file is open. This can negatively impact some features with Microsoft SharePoint Server. You should not apply this registry setting if you are a SharePoint client. For example, SharePoint has a feature that allows a user to open a file read-only and switch to read-write access at a later time by using the Server Document command from Office 2007. This kind of feature will not work with the registry setting that is applied here. This setting makes the file permanently read-only for the duration of the client open.

Cause

This problem occurs because, on a Windows Vista-based client computer, 2007 Office applications use the Windows WebDAV Mini-Redirector Client component to open URL-based files. This component provides read/write permissions to DAV-based Web servers that support Web authoring.

When you try to open a document from a hyperlink, 2007 Office applications may request that the Windows WebDAV Client try to author the document at the URL location. However, if the authoring attempt is not expected on certain Web servers or in certain situations, the symptoms that are mentioned in the "Problem description" section may occur.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • Visit the Fix it for me (http://blogs.technet.com/fixit4me) blog, or send us e-mail (mailto:fixit4me@microsoft.com?Subject=KB955375 - Use WinINET copy) to provide feedback or to report any issues with this solution.

APPLIES TO
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Small Business 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
Keywords: 
kbfixme kbmsifixme kbprb kbqfe kbexpertiseinter KB955375

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