Server Message Block (SMB) redirector functions time out more quickly than expected on a Windows XP-based computer that has multiple processors installed

Article translations Article translations
Article ID: 955535 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You are running a Windows XP-based computer that has multiple processors installed.
  • You have an application that uses some Server Message Block (SMB) redirector functions.
However, the SMB redirector functions time out more quickly than expected.

For example, Transact-SQL triggers that are defined on FILESTREAM varbinary(max) columns may behave inconsistently on a multiprocessor computer.

CAUSE

This problem occurs because of a race condition in the SMB redirector.

RESOLUTION

Download information

The following file is available for download from the Microsoft Download Center:

Collapse this imageExpand this image
Download
Download the Update for Windows XP (KB955535) package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) or a later Windows XP service pack installed.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.1.2600.3419455,93630-Jul-200809:44x86
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.1.2600.5650455,93630-Jul-200812:09x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about FILESTREAM, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/bb933993.aspx

Properties

Article ID: 955535 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbexpertiseinter kbautohotfix kbfix kbbug kbqfe KB955535

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com