SMB funciones de tiempo de espera anteriormente esperado en un equipo basado en Windows 2003 que tiene instalados varios procesadores

Seleccione idioma Seleccione idioma
Id. de artículo: 955544 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando una aplicación utiliza funciones de bloque de algunos mensajes del servidor (SMB), como el acceso a archivos compartidos o carpetas, en un equipo basado en Windows 2003 que tiene varios procesadores instalado, el SMB funciones de tiempo de espera anteriormente esperado.

Causa

Este problema se produce debido a una condición de anticipación en el SMB redirector.

Solución

Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a sistemas que experimenten el problema descrito en este artículo. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los clientes de Microsoft Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Debe tener Service Pack 1 de Windows Server 2003 o Windows Server 2003 SP2 instalado.
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.

Windows Server 2003 SP1, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Mrxsmb.sys5.2.3790.3183438,27230-Jul-200810: 00x 86
Windows Server 2003 SP2, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Mrxsmb.sys5.2.3790.4344438,27230-Jul-200811: 39x 86
Windows Server 2003 SP1, x 64
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Mrxsmb.sys5.2.3790.3183786.43230-Jul-200813: 07x 64
Windows Server 2003 SP2, x 64
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Mrxsmb.sys5.2.3790.4344786,94430-Jul-200813: 18x 64
SP1 de Windows Server 2003, IA64
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Mrxsmb.sys5.2.3790.31831,171,45630-Jul-200813: 10IA-64
SP2 de Windows Server 2003, IA64
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Mrxsmb.sys5.2.3790.43441,171,45630-Jul-200813: 15IA-64

Windows XP

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a sistemas que experimenten el problema descrito en este artículo. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los clientes de Microsoft Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Debe tener instalada la versión de Windows XP x 64.
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.

Windows XP SP1, x 64
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Mrxsmb.sys5.2.3790.3183786.43230-Jul-200813: 07x 64
Windows XP SP2, x 64
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Mrxsmb.sys5.2.3790.4344786,94430-Jul-200813: 18x 64

Más información

Por ejemplo, este problema se produce en el siguiente escenario:
  • El cliente utiliza una aplicación que se conecta a un equipo remoto que ejecuta Windows Server 2003 y SQL Server 2008.
  • La aplicación obtiene un identificador a un archivo FILESTREAM. La aplicación puede hacerlo mediante la API de OpenSqlFilestream o la clase .NET SqlFilestream .
  • La aplicación escribe en el controlador. A continuación, cierra el identificador de la aplicación.
  • El archivo FILESTREAM pertenece a una tabla que tiene instalado un desencadenador de actualización potencialmente larga. La aplicación pospone la operación de cierre del identificador hasta que el desencadenador finaliza su ejecución. Sin embargo, debido a un problema de en el SMB protocolo, la operación de cierre del identificador agota anteriormente.
  • La operación de cierre de identificador se agote. Por lo tanto, el asociado de SQL Server transacción no es válido. Por lo tanto, el intento de confirmar la transacción produce un error.
Para obtener más información acerca de la característica FILESTREAM, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
http://msdn.microsoft.com/en-us/library/bb933993.aspx
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
955535Redirector de bloque de mensajes (SMB) servidor funciona más rápidamente de lo esperado en un equipo basado en Windows XP que tiene varios procesadores instalados tiempo de espera
Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 955544 - Última revisión: jueves, 22 de enero de 2009 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Palabras clave: 
kbmt kbsurveynew kbautohotfix kbhotfixserver kbqfe KB955544 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 955544

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com