No puede conectarse a una instancia de ADAM en Windows Server 2003 con el protocolo Secure Sockets Layer 3 junto con un certificado que sea mayor que 1024 bytes

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Síntomas

Tenga en cuenta la situación siguiente:
  • Está ejecutando un Active Directory Application Mode (ADAM) instancia en un equipo basado en Windows Server 2003.
  • Conectarse a la instancia de ADAM mediante el protocolo Secure Sockets Layer (SSL) 3.
  • El certificado que se utiliza para el protocolo SSL 3 es mayor que 1024 bytes.
En este escenario, la conexión a la ADAM instancia restablece en lugar de que se va a establecer.

Nota Se puede establecer una conexión con un controlador de dominio de Windows Server 2003 de la misma configuración correctamente.

Causa

Este problema se produce porque ADAM trata incorrectamente los datos del certificado durante el proceso de enlace.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponibles" en la parte superior de este artículo de Knowledge Base. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe estar ejecutando uno de los siguientes:
  • Windows Server 2003 R2
  • Active Directory Application modo Service Pack 1

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003 con Service Pack 1, x 86
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Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Adamdsa.dll1.1.3790.31921,631,23218 De agosto de 200811: 20x 86
Windows Server 2003 con Service Pack 2, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Adamdsa.dll1.1.3790.43551,632,76818 De agosto de 200809: 11x 86
Windows Server 2003 con Service Pack 1, versiones basadas en 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Adamdsa.dll1.1.3790.31922,956,80018 De agosto de 200809: 02x 64
Windows Server 2003 con Service Pack 2, versiones basadas en 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Adamdsa.dll1.1.3790.43552,959,87218 De agosto de 200809: 09x 64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Solución

Para evitar este problema, utilice uno de los métodos siguientes:
  • Conectarse a la instancia de ADAM mediante un certificado de 1024 bytes para el protocolo SSL 3.
  • Conectarse a la instancia de ADAM mediante un sockets seguro protocolo de nivel 2.

Más información

Para obtener más información acerca de sockets seguros 3 del protocolo de capa, visite los siguientes sitios Web de Microsoft:
http://technet.microsoft.com/en-us/library/cc757054.aspx
http://technet.microsoft.com/en-us/library/cc785811.aspx
Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 955610 - Última revisión: martes, 23 de septiembre de 2008 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
Palabras clave: 
kbmt kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe KB955610 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 955610

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