Lista de problemas conocidos al instalar SQL Server en Windows 7 o en Windows Server 2008 R2

Seleccione idioma Seleccione idioma
Id. de artículo: 955725 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

INTRODUCCIÓN

En este artículo se describen los problemas conocidos al instalar Microsoft SQL Server en un equipo que ejecuta Windows 7 o Windows Server 2008 R2.

Notas
  • Para todas las ediciones, excepto Express Edition de SQL Server 2008 que se ejecuta en Windows 7 y en Windows Server 2008 R2, debe tener instalado al menos SQL Server 2008 Service Pack 1 (SP1). Express Edition ya incluye el Service Pack 1.
  • Para todas las ediciones de SQL Server 2005 que se ejecutan en Windows 7 y en Windows Server 2008 R2, debe tener instalado al menos SQL Server 2005 Service Pack 3 (SP3).
  • En este artículo, Windows 7 indica la versión cliente de Windows 7. Windows Server 2008 R2 indica la versión servidor de Windows 7.

Problemas conocidos

  • Windows 7 no utiliza la propiedad RequireKerberos para determinar si está habilitada la autenticación Kerberos

    Como Windows 7 no usa la propiedad RequireKerberos para determinar si la autenticación Kerberos está habilitada para un recurso de nombre de red, la instalación del clúster de conmutación por error de SQL Server 2008 RTM produce un error.
  • Cuando la directiva FIPS está habilitada en Windows 7 o en Windows Server 2008 R2, se produce un error de validación de clúster durante la instalación de SQL Server 2008 RTM

    Cuando la directiva FIPS está habilitada en Windows 7 o en Windows Server 2008 R2, se produce un error de validación de clúster durante la instalación de SQL Server 2008 RTM Por tanto, se produce un error en el programa de instalación.

    Para resolver estos dos problemas, debe instalar SQL Server 2008 junto con SQL Server 2008 (SP1) o una actualización posterior para instalaciones en clúster. Para obtener información adicional acerca de cómo obtener Microsoft SQL Server 2008 SP1, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    968382 Cómo obtener el Service Pack más reciente para SQL Server 2008
    Para obtener más información acerca de cómo actualizar la instalación de SQL Server en un entorno en clúster o no agrupado, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    955392 Cómo actualizar o instalar una instalación integrada de SQL Server 2008
  • La instalación de SQL Server 2008 RTM puede producir un error en Windows Server 2008 R2

    La instalación de SQL Server 2008 RTM puede producir un error en Windows Server 2008 R2 si .NET Framework no está habilitado. Este problema se produce porque la instalación de .NET Framework 3.5 es un requisito previo para esta instalación.

    En Windows Server 2008 R2, .NET Framework 3.5 se incluye como componente de Windows y no se instala de manera predeterminada. Para evitar este error de instalación, debe activar .NET Framework 3.5 desde las características de Windows antes de ejecutar la instalación de SQL Server 2008 RTM.
  • El programa de instalación de SQL Server 2008 puede producir un error

    El programa de instalación de SQL Server 2008 puede producir el siguiente error:
    No se puede llamar a Invoke o a BeginInvoke en un control hasta que se haya creado el identificador de ventana.
    Puede instalar una actualización acumulativa para resolver este problema. Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    975055 REVISIÓN: Aparece un mensaje de error al instalar SQL Server 2008 en un equipo que ejecuta Windows 7: "No se puede llamar a Invoke o a BeginInvoke en un control hasta que se haya creado el identificador de ventana."

Más información

Requisitos mínimos de versión para Windows 7 o para Windows Server 2008 R2

Antes de instalar SQL Server en un equipo que está ejecutando Windows 7 o Windows Server 2008 R2, debe asegurarse de que cumple los siguientes requisitos previos mínimos, según corresponda.

SQL Server 2008


Instalaciones en clúster:
Debe instalar SQL Server 2008 junto con SQL Server 2008 Service Pack 1 o una actualización posterior (también conocida como versión de instalación integrada).

Instalaciones no agrupadas:
Debe instalar SQL Server 2008 seguido de SQL Server 2008 Service Pack 1 o una actualización posterior.
Nota: se admite el tiempo de ejecución de SQL Server 2008 Express en Windows 7 y Windows 2008 R2.
Para obtener más información sobre los requisitos de hardware y software para instalar SQL Server 2008, visite el siguiente sitio web MSDN:
http://msdn.microsoft.com/es-es/library/ms143506.aspx

SQL Server 2005

Debe instalar SQL Server 2005 seguido de SQL Server Service Pack 3 o una actualización posterior.

Para obtener más información acerca de las instalaciones en clúster de SQL Server 2005, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
973993 Algunos nodos no se actualizan como se esperaba al aplicar Service Pack 3 o una actualización de Service Pack 3 en un clúster de SQL Server 2005 que se basa en clúster de conmutación por error de Windows Server 2008 R2
Para obtener más información acerca de cómo obtener los Service Pack de SQL Server 2005, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
913089 Cómo obtener el Service Pack más reciente para SQL Server 2005

Más información sobre SQL Server 2005

Nota: el tiempo de ejecución de SQL Server 2005 Express Service Pack 2 se admite en Windows 7 y Windows Server 2008 R2.

.NET Framework

Debe instalar Microsoft .NET Framework 3.5 SP1 antes de instalar SQL Server 2008 en un equipo que esté ejecutando Windows Server 2008 R2. .NET Framework 3.5 SP1 es un requisito previo para SQL Server 2008. El programa de instalación de SQL Server 2008 instalará .NET Framework 3.5 SP1 si no está ya instalado. Sin embargo, para el clúster de conmutación por error, debe instalarse .NET Framework 3.5 SP1 antes de la instalación de clúster de conmutación por error de SQL Server 2008.

En Windows Server 2008 R2, .NET Framework es un componente del sistema. Por tanto, no se puede instalar .NET Framework desde un punto de redistribución. Debe instalar .NET Framework desde la función de servidor o mediante ServerManagerCmd.exe.

No es necesario instalar .NET Framework en las situaciones siguientes:
  • En un equipo que ejecuta Windows Server 2008 R2 y en el que .NET Framework 3.5 SP1 está instalado
  • En un equipo que ejecuta Windows 7 (porque .NET Framework 3.5 SP1 está instalado de manera predeterminada)

Propiedades

Id. de artículo: 955725 - Última revisión: viernes, 12 de julio de 2013 - Versión: 7.2
La información de este artículo se refiere a:
  • Microsoft SQL Server 2008 Enterprise
  • Microsoft SQL Server 2008 Developer
  • Microsoft SQL Server 2008 Standard
  • Microsoft SQL Server 2005 Enterprise Edition
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Express Edition
  • Microsoft SQL Server 2005 Workgroup Edition
Palabras clave: 
kbsqlserverengine kbpreinstall kbinstallation kbprerequisite kbexpertiseadvanced kbsurveynew kbinfo kbhowto KB955725

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com